4

I'm on a Windows 7 machine, using the most recent version of vim-LaTeX with gVim. With all of the defaults, using \ll to compile my document only runs LaTeX once, when it should run multiple times, including a bibtex run. I tried manually adding the line

let g:Tex_MultipleCompileFormats = 'dvi'

but it does not help. I get no errors from the original LaTeX run.

What's strange is that this setup works fine for me on a different machine. I don't know what else to try.

5

I had the same problem with a project consisting of lots of separate .tex source files. I found that BibTeX is not called when I use

\include{other_file}

in my main file where other_file has new/updated citations. However, if I change this to

\input{other_file}

bibtex is called correctly. I also noticed in the latex-suite documentation (line 1469 in my version)

  1. Finally, it will try to see if this file includes other files via the \input command. For each such file found, Latex-Suite will repeat the previous two steps stopping at the first file which has either a \bibliography command or a thebibliography environment.

I guess it applies only to the \input command and not to \include.

4

I spent a few hours debugging vim-latex and found a problem similar to what you have mentioned. Hope this helps other people.

Before vim-latex runs bibtex it searches the .aux file for "\bibdata". If vim is compiled with python, it works fine. If it is not there is a bug that changes the current directory path and hence the search fails. I have corrected this by the following changes. In /.vim/ftplugin/latex-suite/main.vim

Replace the function on line 938 with the following:

function! Tex_GotoTempFile()
     let s:origdir = fnameescape(getcwd())
     if !exists('s:tempFileName')
        let s:tempFileName = tempname()
     endif
     exec 'silent! split '.s:tempFileName
     exe 'cd '.s:origdir
 endfunction " }}}

This corrects the error. Hope it helps and save others time :).

3

I'm using Windows 7 with Sumatra PDF Viewer and the following settings in my vimrc file work fine:

" Compiler and viewer settings
let g:tex_flavor='latex'  
let g:Tex_CompileRule_pdf = 'pdflatex --synctex=-1 -src-specials -interaction=nonstopmode -file-line-error-style $*'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'
let g:Tex_ViewRule_pdf =  'SumatraPDF -reuse-instance '

Hope it helps.

3

Looks strange, have you solved the problem?

For me, add the following line into .vimrc solved the problem

let g:Tex_MultipleCompileFormats='pdf,bib,pdf'

And my default pdf compileFormat is XeLaTeX

1

So, i tried the version of Ex_, but it did not work. However, a small change made it working perfectly.

I am running Linux Fedora with KDE, have TeX Live installed, and use Document Viewer as pdf viewer.

I added/changed the following in my .vimrc file:

let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf,bibtex,pdf'

Maybe this helps someone.

0

Add the below line into the .vimrc or _vimrc file.

let g:Tex_MultipleCompileFormats='pdf,bibtex,pdf'

this setting works well for multiple compile formats, and it will process xelatex, bibtex, xelatex in sequence.

  • 1
    can you elaborate on what this does? – naphaneal Nov 14 '18 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.