2

I need to create a document with Utopia (Fourier package) as the default font. However, at a certain point I need to change the default roman font to say for e.g. CM-Roman. At this point reverting back to utopia makes the text seem thicker and broader.

The MWE below illustrates my problem.

\documentclass[12pt, a4paper, draft]{article}
\usepackage{fourier}
\newcommand{\ffont}[2]{
     \fontencoding{#1}
     \fontfamily{#2}
     \selectfont
}

\begin{document}

Fourier-Utopia\\
The quick brown fox jumps over the lazy dog.\
\ffont{OT1}{cmr}
Compuer Modern Roman\\
The quick brown fox jumps over the lazy dog.\\

\ffont{T1}{put}
Fourier-Utopia Again\\
The quick brown fox jumps over the lazy dog.\
\end{document}

This seems to happen only with the Utopia Font. Can anyone let me know the correct way to achieve this please.

Thanks

2

make the font change local with putting it into {...}

\documentclass[12pt, a4paper, draft]{article}
\usepackage{fourier}
\newcommand{\ffont}[2]{%
     \fontencoding{#1}
     \fontfamily{#2}
     \selectfont}

\begin{document}

Fourier-Utopia\\
The quick brown fox jumps over the lazy dog.

{\ffont{OT1}{cmr}
Compuer Modern Roman\\
The quick brown fox jumps over the lazy dog.}

Fourier-Utopia Again\\
The quick brown fox jumps over the lazy dog.

\end{document}

the correct setting for fouriers roman font is \ffont{T1}{futs}

  • Thanks Herbert. From where did you get the correct font name as "futs", and what does "put" refer to in my original case, as it selects the utopia font. I ask because I got the name "put" from utopia.map and utopia.sty files. – Solar Jan 23 '11 at 11:01
  • I looked into the logfile (/usr/local/texlive/2010/../texmf-local/tex/latex/fourier/t1futs.fd) [1{/usr/lo ... – user2478 Jan 23 '11 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.