2

I'm using the LED template to MSc which uses memoir twoside. I need to print it and it requires extra margins for binding.

How do I simply add the extra space on the spine side of the page?

\documentclass[11pt, a4paper, twoside, makeidx]{memoir}
\input{style.tex}

STYLE.TEX:

\usepackage{graphicx}
\usepackage{epsfig}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage{booktabs}
\usepackage{stmaryrd}
\usepackage{url}
\usepackage{longtable}
\usepackage[figuresright]{rotating}
\usepackage{geometry}

\usepackage{polski}
\usepackage[cp1250]{inputenc}

% *************** Wygląd strony ***************
\settypeblocksize{*}{32pc}{1.618}

\setlrmargins{*}{1.47in}{*}
\setulmargins{*}{*}{1.3}

\setheadfoot{\onelineskip}{2\onelineskip}
\setheaderspaces{*}{2\onelineskip}{*}

\def\baselinestretch{1.1}

\checkandfixthelayout

% *************** Stylu rozdziałów i podrozdziałów ***************
\makechapterstyle{mychapterstyle}{%
    \renewcommand{\chapnamefont}{\LARGE\sffamily\bfseries}%
    \renewcommand{\chapnumfont}{\LARGE\sffamily\bfseries}%
    \renewcommand{\chaptitlefont}{\Huge\sffamily\bfseries}%
    \renewcommand{\printchaptertitle}[1]{%
        \chaptitlefont\hrule height 0.5pt \vspace{1em}%
        {##1}\vspace{1em}\hrule height 0.5pt%
        }%
    \renewcommand{\printchapternum}{%
        \chapnumfont\thechapter%
        }%
}

\chapterstyle{mychapterstyle}

\setsecheadstyle{\Large\sffamily\bfseries}
\setsubsecheadstyle{\large\sffamily\bfseries}
\setsubsubsecheadstyle{\normalfont\sffamily\bfseries}
\setparaheadstyle{\normalfont\sffamily}

\makeevenhead{headings}{\thepage}{}{\small\slshape\leftmark}
\makeoddhead{headings}{\small\slshape\rightmark}{}{\thepage}
6
  • Are line/page breaks allowed to change, or is this a "last-minute" correction that shouldn't affect (most of) the layout?
    – lockstep
    Jan 26 '13 at 13:30
  • Sadly "Last minute". Currently looks great... on screen.
    – Holy Sync
    Jan 26 '13 at 14:07
  • It's necessary to see the part of the preamble where the page parameters are set.
    – egreg
    Jan 26 '13 at 14:25
  • Question updated :)
    – Holy Sync
    Jan 26 '13 at 15:15
  • OK, It seems I found the solution: (at least it worked for me) \setlrmargins{}{2cm}{}
    – Holy Sync
    Jan 27 '13 at 12:21
3

As described in the memoir manual, chapter 2, the command \setlrmargins is available to adjust margins, with arguments:

\setlrmargins{<spine>}{<edge>}{<ratio>}

Only one argument could be given, with * for the two others e.g.

\setlrmargins{*}{2cm}{*}

There is also a command

\setbinding{<length>}

that adds to the inner margin to allow for the binding. This should be added after setting the page size, but before setting the margins.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.