I have tried setting the terminal to just about everything under the sun. I got it to read my latex notation for a brief compile and then it decided it didn't want to anymore again. The error that I am getting now is

Package pdftex.def Error: File `npn-eps-converted-to.pdf' not found

Though it is there and in the same directory. but I am calling the file like this


\caption{\small blblb}

If I call it like this


\caption{\small blblbl}

Them I get an error like this

LaTeX Error: File `npn.pdf' not found.


gnuplot << TOEND
# Set the output file
set terminal epslatex enhanced 
set output 'nfn.tex' 
unset key

set border 3
set xtics nomirror
set ytics nomirror

set format $g$
set format x "%2.0f" 
set format y "%2.0f" 

fit u(x) "nfn.dat" using 1:2 via m,b

set xzeroaxis linestyle 2 lt 2 lc 9
set xlabel "Applied Current mA" 

set ylabel "Voltage {$mV$}" offset -3.0 

set xrange [ -15.00 : 15.00 ]
set yrange [ -3.0 : 3.0 ]

plot  u(x), 'nfn.dat' using 1:2:3:4 with xyerrorbars


Yes the file exists. these are the packages I have added:

\usepackage[T1]{fontenc} % Use 8-bit encoding that has 256 glyphs
\usepackage[english]{babel} % English language/hyphenation
\usepackage{amsmath,amsfonts,amsthm} % Math packages
\usepackage{sectsty} % Allows customizing section commands
\usepackage{pst-grad} % For gradients
\usepackage{pst-plot} % For axes

Some of them are not really relevant but I don't know if there is a conflict causing it. I reinstalled all my packages and that didn't help either. It works fine until I try to use latex fonts and then come the problems.

  • 1
    why not use pgfplot with gnuplot and tikz? \begin{tikzpicture} \begin{axis} \addplot+[only marks] gnuplot [raw gnuplot]{ plot 'Data.txt' ; };\end{axis} \end{tikzpicture} – nonsense Jan 27 '13 at 13:43
  • I tried this before but I have a lot of graphs to make so I was hoping to use one script to write them all. The error bars were quite confusing on pgfplots too, – Magpie Jan 27 '13 at 13:47

Your gnuplot script creates files called nfn.tex and nfn.eps. In your LaTeX code you are trying to load npn.eps and npn.tex (i.e. you use p instead of f).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.