1

I try to compile the following document using XeLaTeX:

\documentclass[twoside,openright,draft]{scrreprt}

\usepackage{fontspec}
\setsansfont{Univers 65 Bold}  

\begin{document}

\section{Lorem Ipsum}
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod 
tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. 

\end{document}

As a result I get the following (stripped) logfile:

Running `LaTeX' on `test' with ``xelatex  -interaction=nonstopmode "\input" test.tex''
This is XeTeX, Version 3.1415926-2.4-0.9998 (TeX Live 2012)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2011/06/27>

[...]

*************************************************
* LaTeX warning: "xparse/redefine-command"
* 
* Redefining document command \oldstylenums with arg. spec. 'm' on line 107.
*************************************************

[...]

LaTeX Font Warning: Font shape `EU1/Univers65Bold(0)/bx/n' undefined
(Font)              using `EU1/Univers65Bold(0)/m/n' instead on input line 15.

[1] (./test.aux)

LaTeX Font Warning: Some font shapes were not available, defaults substituted.


** ERROR ** Invalid font: -1 (0)

Output file removed.
 )
Error 256 (driver return code) generating output;
file test.pdf may not be valid.
Transcript written on test.log.

LaTeX finished at Sun Jan 27 19:50:35

I have some trouble to interpret Invalid font: -1. Any thoughts on what might be causing the problem and, more importantly, how to solve it?

2

I found a solution. (Not pretty, some work, but solved the problem).

I had the font as Postscript Type 1. So I opened all font files with Fontforge and saved them as OpenType. Afterwards I removed the Postscript fonts from my system and installed the OpenType version. Document compiled without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.