1

Here is my biblatex setting in the preamble:

\usepackage[bibstyle=authoryear, 
firstinits=true, 
maxbibnames=5, 
maxcitenames=2, 
sorting=nyt, 
url=false, 
isbn=false, 
eprint=false, 
doi=false, 
dashed=false, 
natbib=true]{biblatex}

Still, my citations are being printed numerically e.g. [2], [72,58] etc. I have cleared all the aux, and bbl files and tried recompiling, but still getting same results. The references are being printed correctly and strangely enough, they don't have numbers. So there is a complete disconnect between citations and references.

2
  • Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). Also, you can use backticks ` to mark your inline code as I did in my edit.
    – hpesoj626
    Jan 29 '13 at 3:56
  • There is also no need to put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. :-)
    – hpesoj626
    Jan 29 '13 at 3:57
4

Load biblatex with style=authoryear. The default is style=numeric or equivalently bibstyle=numeric and citestyle=numeric. Just setting bibstyle=authoryear doesn't change citestyle=numeric.

1
  • @cryptic0 No problem. If you find the manual too overwhelming, you can try looking over the examples that come with the biblatex documentation.
    – Audrey
    Jan 29 '13 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.