2

This question already has an answer here:

Keep in mind, I am a beginner to LaTeX in general and not skilled in command lines.

MiKTeX Portable and TeXmaker are installed on my portable drive. TeXmaker has been properly configured to use MiKTeX - in fact normal documents compile correctly, save for EPS graphics. It is a requirement to have a portable latex setup and to use EPS files for me.

The problem

pdfLaTeX doesn't support EPS files, which in itself isn't so much of a problem. This can easily be solved by using the epstopdf package, which will convert EPS graphics on the fly to PDFs which will be correctly processed.

The real problem

  • Cannot install the epstopdf package on MiKTeX Portable.

    I have searched and I just do not know how to install the package into MiKTeX Portable. Using the Package Manager, it is not listed. When I searched for how to manually install a package, I found that you needed a .dtx file as well as an .ins file for the package. I can only find a .dtx file for epstopdf here.

In it:

Unpacking:
%    (a) If epstopdf.ins is present:
%           tex epstopdf.ins
%    (b) Without epstopdf.ins:
%           tex epstopdf.dtx

I don't know how to use the last line. It this a command I should write? If so, where and how?

  • Do LaTeX -> DVI -> PS -> PDF

I am not sure what this involves but I understand we're going from one format to another, and TeXmaker offers the option to do so (build LaTeX, then Dvi->PS then PS->PDF).

Doing the two first works, but PS->PDF brings up this error:

    Process started

'mgs.exe' is not recognized as an internal or external command, operable program or batch file.

Process exited normally

After googling a while, I found no quick fix for the 'missing' mgs.exe. There is indeed the mgs.exe file under miktek/bin/ AND the path to ps2pdf.exe is correct. Someone mentionned a problem with the %GSC% environnement variable, but I don't know what that is nor how can I fix it.

  • Using \usepackage{epstopdf} brings an error

As opposed to MiKTeX prompting me to download a missing package, the output of TeXmaker is as follow:

Process started

'epstopdf' is not recognized as an internal or external command, operable program or batch file.

And reading the log file I found this:

[1] [2] [3] [4]
Package epstopdf Info: Source file: <decimaux.eps>
(epstopdf)                    date: 2007-01-10 11:02:34
(epstopdf)                    size: 420543 bytes
(epstopdf)             Output file: <decimaux-eps-converted-to.pdf>
(epstopdf)             Command: <epstopdf --outfile=decimaux-eps-converted-to.p
df decimaux.eps>
(epstopdf)             \includegraphics on input line 256.
runsystem(epstopdf --outfile=decimaux-eps-converted-to.pdf decimaux.eps)...exec
uted (allowed).

Package epstopdf Info: Result file: <decimaux-eps-converted-to.pdf>.


! Package pdftex.def Error: File `decimaux-eps-converted-to.pdf' not found.

See the pdftex.def package documentation for explanation.

So I'm not even sure if I'm using epstopdf correctly.

Thanks for any help! You may have realized I may not understand fully some aspect of LaTeX, so please if you require more information do not hesistate I reply promptfully. If I need to submit more documents, please specify how to get them (or link instructions).

marked as duplicate by Speravir, Mensch, Qrrbrbirlbel, Werner, percusse Mar 3 '13 at 2:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to TeX.SX. – Claudio Fiandrino Jan 30 '13 at 16:02
  • 2
    epstopdf is in the oberdiek package. You should be able to install it with the package manager. – Ulrike Fischer Jan 30 '13 at 16:57
  • 1
    epstopdf is already included in MiKTeX portable! As package it is part of the oberdiek bundle, see in <MiKTeX-portable>\tex\latex\oberdiek. But you should also read texmaker 3.5 miktex portable 2.9 and epstopdf. – Speravir Jan 30 '13 at 16:57
  • Ok I checked the linked question. It seems I should use \graphicspath. But how do I use it? Do I just place "\graphicspath" in my header...? My EPS files are in the same folder as the main .tex file. But then what if they were one folder below? – Blkbox Jan 31 '13 at 1:44
  • Also I still get the message "'epstopdf' is not recognized as an internal or external command, operable program or batch file" as I run the Quick Build (pdfLatex). Or can I just run epstopdf from the cmd line? I wouldn't mind doing it manually. – Blkbox Jan 31 '13 at 1:52