I am trying to install a local package draftwatermark to override an out-of-date version of the package, by applying the answer in How to have local package override default package .

I have placed the files draftwatermark.ins and draftwatermark.dtx from http://www.ctan.org/tex-archive/macros/latex/contrib/draftwatermark into the directory


Unfortunately, based on version number, pdflatex is still using the global version. Therefore, I am wondering how I can interrogate pdflatex for its package search path, and modify it without root privileges.

  • 2
    You may have discovered that there's a small bug in the version of draftwatermark on CTAN; while the package has version 1.1, it still advertises itself as version 1.0; try kpsewhich draftwatermark.sty from the command line to see what path is used for loading it. However, you should first unpack draftwatermark.sty by running pdflatex on draftwatermark.ins – egreg Jan 31 '13 at 0:18
  • Also, the link above does not have draftwatermark.sty. Where can I get an authoritative version of this file? – merlin2011 Jan 31 '13 at 0:19

It turned out that I did not realize I needed to run latex on the ins file to generate the sty. Previously I had been working with packages that already had the sty file.

When I ran latex on the .ins file and placed the sty file in the above directory, it worked correctly even though the bug with reporting is still there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.