1

So I am trying to get BibTex to work and I run into the above error: . After a quick search in here I found that it is a problem with extra space in the BibTex file that could be solved by adding the \DeclareUnicodeCharacter{00A0}{~} to the preamble. So I did that but I still get the error. I have added the part of the preamble where I have added the line. Can anyone see where I'm going wrong? (Using Texmaker on mac)

\usepackage[Lenny]{fncychap}         
\usepackage[english]{babel}  
\usepackage[T1]{fontenc}         
\usepackage[utf8]{inputenc}    
\DeclareUnicodeCharacter{00A0}{~}
\usepackage{verbatim}            
\usepackage{shortvrb}            
\usepackage{courier}             
\usepackage{ae}                  
\usepackage{booktabs}            
\usepackage{color}               
\usepackage{enumerate}           
\usepackage{longtable}                  
\usepackage{palatino}               
\usepackage{footmisc}                       
\usepackage{eso-pic}
\usepackage[font={small}]{caption}
  • 5
    Rather than that long list of packages, you should show the problematic entry in the .bib file. – egreg Feb 4 '13 at 10:59
  • 5
    bibtex is inherently 7 bit. See this FAQ question for some discussion. Either you need to use tex sequences such as \"a for accents in your bibliography, or your need to switch to an 8bit system. biblatex would be my choice. – Andrew Swann Feb 4 '13 at 11:01
  • 1
    Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Reinstate Monica - M. Schröder Feb 4 '13 at 11:31
  • Please see here for a possible answer: Use biber and biblatex. – Reinstate Monica - M. Schröder Feb 4 '13 at 11:35
  • 1
    Look around newton.ex.ac.uk/tex/pack/bibtex/btxdoc/btxdoc.html for a lot of BibTeX suggestions. Make sure there is no non-ASCII character in the *.bib files, use e.g. {\"a} for accents (that way BibTeX collates (almost) right). – vonbrand Feb 4 '13 at 11:56

Browse other questions tagged or ask your own question.