In an attempt to save valuable space on a 128GB SSD drive, I endeavored to replace my full 2012 MacTex texlive install (>3.5GB) with 2012Basic (270MB!). I understand that packages are not installed by default. Using tlmgr, I installed several of the packages my .tex document calls for. They are installed by tlmgr in /usr/local/texlive/2012basic/texmf-dist/tex. This is very similar to where the full texlive installs packages. However, my GUI (LaTeXian) fails to complile the document (fails to locate packages...).

  • I ran texhash (both as root and as my user)
  • I tried playing around with paths in texmf.cnf
  • I created a symbolic link from ~/Library/texmf to /usr/local/texlive/2012basic/texmf-dist/tex
  • I tried adding the package location to $PATH (seems like a messy hack...)

No dice. The texmf.cnf file points to ~/Library/texmf, but so does the texmf.cnf in the full install... And, I'd prefer to let tlmgr handle the packages rather than install manually in ~/Library/texmf

What am I missing?

closed as unclear what you're asking by Joseph Wright Aug 7 '13 at 10:33

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    What does kpsewhich article.cls return? Also kpsewhich for a package you just installed. Do basic documents compile properly for you (i.e. ones that don't use the extra packages you installed)? – Alan Munn Feb 8 '13 at 21:02
  • @AlanMunn: basic docs do compile. kpsewhich article.cls returns /usr/local/texlive/2012basic/texmf-dist/tex/latex/base/article.cls Trying kpsewhich amsmath (which exists in as ../text-dist/tex/latex/amsmath/amsmath.sty returns nothing (not "bad command", simply nothing). – jjwebster Feb 8 '13 at 21:18
  • @jjwebster Try kpsewhich amsmath.sty... – Paul Gaborit Feb 8 '13 at 22:30
  • d'oh. kpsewhich amsmath.sty gives /usr/local/texlive/2012basic/texmf-dist/tex/latex/amsmath/amsmath.sty Does this mean the problem lies with my GUI? If so, why does it work with the full texlive install... but not basic (simply by flipping the current texlive instance in System Prefs?) – jjwebster Feb 8 '13 at 23:02
  • It's possible that LaTeXian has hard coded paths and that's why it doesn't work. – Alan Munn Feb 8 '13 at 23:19