I have MikTeX 2.9 installation and Strawberry Perl

All the latexdiff, latexdiff-fast, latexidff-so paths seem to be present in the scripts.ini file and their .exe files in the miktex/bin/x64.

Somehow when I try to run latexdiff command in the directory where the two versions of .tex files are present, I get this error

latexdiff: The Perl script could not be found.

latexdiff: Data: scripts/latexdiff/perl/latexdiff.pl

When I run the command, a pop-up window asks for installation of latexdiff.pl and I press ok, but it ends up in the error shown above. I followed some posts with similar problem, but couldn't find a solution.

Any help would be appreciated.

  • 1
    This seems to be a bug in MiKTeX: With the call of latexdiff you actually make a call of latexdiff.exe, what is a wrapper. In this wrapper the path shown in th error message seem s to be hardcoded, but it is empty on my machine. So file a bug in the MiKTeX Bugs Tracker. BTW there were recently also problems with other perl based scripts in MiKTeX.
    – Speravir
    Commented Feb 16, 2013 at 19:13
  • I think, it is not really related, but let me point you to latexdiff problem in MikTex 2.8 after update: “Perl script not found”.
    – Speravir
    Commented Feb 16, 2013 at 19:18
  • @Speravir I came across this post before I posted mine, but the post didn't really suggest a solution. I'll try to file a bug with the MiKTeX Bugs Tracker.
    – user24021
    Commented Feb 17, 2013 at 9:40
  • @Speravir MiKTeX Bugs Tracker doesn't allow to me file the bug. I created an account in SourceForge and tried creating a ticket, but it says 'We are sorry your request could not be processed' and doesn't give any further information.
    – user24021
    Commented Feb 17, 2013 at 9:59

2 Answers 2


I've just faced this exact problem with latexdiff.

Follow the solution found here for a different package,


but also rename the latexdiff perl files to also have a .pl extension.

  • Welcome to TeX.sx! Commented Mar 21, 2013 at 11:11
  • 4
    Please consider to include more details, so that your answer becomes self-contained.
    – lockstep
    Commented Mar 21, 2013 at 11:14
  • I followed this approach (made a folder perl in scripts/latexdiff, moved all files there; added .pl to all of them and refresh FNDB) and I still get the error. Did I miss something?
    – remus
    Commented Sep 10, 2013 at 13:01
  • I moved latexdiff.pl to my working folder and invoked perl latexdiff.pl old.tex new.tex > diff.tex but I would like to use it normally from miktex.
    – remus
    Commented Sep 10, 2013 at 13:14
  • Could you explain what you actually did step by step? I tried simply making a /perl folder in MiKTeX 2.9/scripts/latexdiff and giving everything a .pl extension and the same error still occurs.
    – Elliot
    Commented Jan 15, 2015 at 21:46

Maybe not what you want but have you tried installing Cygwin, Perl and latexdiff there? I think installing TeXLive is also an option but installing 2Gb software just to have access to a script might be too much. I do understand how latexdiff can be important. Several journals where I was submitting asked me for the difference between submitted and reviewed versions of papers.

Not the answer you're looking for? Browse other questions tagged .