2

I'm trying to compile simple thesis example using TexMaker with MiKTeX 2.9. I need pdfpages package in order to include pdf as the title page. Without the following line the code compiles fine:

\usepackage{pdfpages}

With this line, every time I try to compile I get the following window:

enter image description here

I tried many different repositories, but it always ends up with

Error: File 'pdfpages.sty' not found. ...

So I decided to install it manually, downloaded this package: http://www.ctan.org/tex-archive/macros/latex/contrib/pdfpages

I've uncompressed the package in the following directory: C:\Program Files\MiKTeX 2.9\tex\latex\pdfpages and then I run these commands from that directory:

> latex pdfpages.ins
> latex pdfpages.dtx

After that, more files were created in that directory (including pdfpages.sty). But TexMaker still can't detect those files. Still shows me the "Package Installation window".

Minimum example code:

\documentclass[a4paper,12pt,twoside]{article}
\usepackage{theorem}
\usepackage{graphicx}
\usepackage{pdfpages}
\includepdf{title_page.pdf}
\begin{document}
test
\end{document}

I really couldn't find any solution to this problem in Google nor in StackExchange database. How to get it working?

1

You must update the FNDB (in admin mode) if you put files in this location. I can't say why installation doesn't work, but instead of manual installation I suggest to first try to set up a local repository: Windows 7: problem with TeXnicCenter, MiKTeX2.9

0

I had the same exact problem except I was using WinEdt rather than TexMaker. Here is what I did. I simply close WinEdt. Then right click on WinEdt icon and then select "Run as administrator". Then compile your file as usual. It should go through the instalation without any error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.