12

I seem to be getting a strange error after updating MiKTeX 2.9. I am using pdfLaTeX and TeXmaker with the graphicx package to include .png images. When I try to compile, I get the error LaTeX Error: File 'title' not found. If I include the file extension, then the error becomes LaTeX Error: Cannot determine size of graphic in title.png (no BoundingBox). I wasn't getting these errors a few days ago when I started creating my presentation. It has also worked without problems in the past.

MWE:

\documentclass{beamer}
\usepackage{graphicx}
\graphicspath{{figures/}}
\begin{document}
    \title{title}
    \author{author}
    \date{date}
    \titlegraphic{\includegraphics[scale=0.5]{title}}
    \frame{\titlepage}
\end{document}

Also, from the logfile it seems that pdfLaTeX is not in PDF mode, and that all graphics are being treated as .eps:

Package: ifpdf 2011/01/30 v2.3 Provides the ifpdf switch (HO)
Package ifpdf Info: pdfTeX in PDF mode is not detected.
...
File: title.png Graphic file (type eps)

Does anyone know how to fix this problem?

13
  • 2
    Welcome to TeX.sx! The first problem is related to the second (and actual) problem. latex cannot determine the natural dimensions of an image. So the real question is: Why is pdfLaTeX not in PDF mode? Does your MWE compile if you use pdflatex from the command line (pdflatex <filename>)? It seems as if your editor is set up to use latex rather than pdflatex. Commented Feb 18, 2013 at 5:17
  • 1
    Could it be that you have several files with basename title, that some of them have a pdf or an eps extension and that they're corrupt? If yes, a possible solution may be adding the extension to the filename title.
    – user10274
    Commented Feb 18, 2013 at 6:23
  • 3
    @m0nk3y: There was an update some days ago (12.2.) which broke the formats. The error has been corrected but perhaps you still have remains. Run the update manager (admin + user mode). Recreate all formats. If the problem persist you will have to find the local ini-files and correct them manually. If you are in a hurry: you can also put \pdfoutput=1 at the start of your document, this will switch the mode back to pdf. Commented Feb 18, 2013 at 8:22
  • 1
    @hjschulz: Updating is not enough. You should also recreate the formats (as user). If this doesn't help: Rename in the UserData and (perhaps) CommonData-root (not in the main root!) in the folder miktex/config formats.ini, language.ini and if it exists pdflatex.ini. And then recreate the formats again. (This can change the language and format settings, you can reset them in miktex->settings). Commented Feb 18, 2013 at 14:30
  • 1
    @m0nk3y: I explicitly wrote that you should not change files in the main root (=installation root). Go to miktex-setting, tab "root", activate "show miktex roots", it will show you the path to UserConfig (not UserData as I wrote by mistake in the previous comment). There you will find the local ini's. Commented Feb 19, 2013 at 8:35

1 Answer 1

1

This problem was solved by renaming pdflatex.fmt and pdftex.fmt in the CommonConfig/miktex/data/le/pdftex directory and then recreating formats as "user".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .