I admit that this may be a netbook problem rather than a LyX problem, but I am doubtful since I have adobe and everything else in LyX is working fine. When I click the eyeballs in LyX, which usually allows me to view my work in PDF form on my laptop, I get this message on my netbook: enter image description here

Is there a way to fix this in the settings? I've even tried to export the pdf, yet the same message appears.

  • 2
    Does the file exist? Can you open it manually (find in the directory tree and open it)? I guess it is quite clear to you that we can hardly help you without further information. – yo' Feb 18 '13 at 16:41
  • The LyX file exists while I am working on it. On my laptop I create the pdf by opening LyX and then exporting the pdf or clicking the eyeballs. I'm not sure why I am getting this message in my netbook. At the moment, the only way I can create a pdf is to transport the LyX file to my laptop and to create the pdf from there. – The Substitute Feb 18 '13 at 16:48
  • 2
    Then it seems to be a problem of your netbook install. I can't help you more (and there are not many LyX users around here). I hope you manage to find out the problem. If you do, it is worth self-answering. If you don't but you get some more info, update the question ;) – yo' Feb 18 '13 at 17:30
  • 1
    When you export everything is fine (no error)? Which LyX version are you using? The Windows installer is still getting some bugs worked out so if you haven't tried with the newest version (, installer version 4). One more thing to try is a different PDF viewer. I've heard good things about Sumatra. – scottkosty Feb 18 '13 at 20:12
  • I have version 2.0. I will update it and see what happens. – The Substitute Mar 6 '13 at 18:30

The access to the temporal file has been blocked. Adobe Reader blocks access to the pdf. Try with Sumatra. Is light weight and does not block the pdf, allowing to LyX to erase it and LaTeX replace it with a different version.

  • The same issue occurs with Sumatra, but I like this pdf reader much better than Adobe. Thanks. – The Substitute Mar 10 '13 at 8:44

I've had the same problem. I solved it by first right-clicking on the Lyx shortcut and then clicking on "Run as administrator".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.