I'm trying to use arara with TeXworks in Ubuntu 12.10 (TeX Live 2012). I've been searching all over the web but couldn't get it working.

First: I'm not sure how to correctly implement arara: Should it already come with TeX Live 2012? If no, how can I install it right? (I tried to install it using the .jar file and add a symbolic link to arara in /usr/local/bin.)

Second: How do I tell TeXworks to run arara? (I added a Processing tool in Preferences-Typesetting with /usr/local/bin/arara as program, but TeXworks tells me that the program can't be found)

I'm kind of stuck and don't know at which point I did wrong. Any help is appreciated!

  • You guys are really quick, thanks for the answers.
    – Bernd Mi
    Feb 18, 2013 at 23:07
  • @DJP I installed arara again under /opt/arara using the .jar file adding a symbol link in /usr/local/bin/ (this time working), thanks for the hint.
    – Bernd Mi
    Feb 18, 2013 at 23:18
  • @Paulo Cereda: Your instructions worked really fine with my Texworks, document successfully compiled :) Thanks a lot for the help and also for arara, makes working with Latex a lot easier for me!
    – Bernd Mi
    Feb 18, 2013 at 23:19

1 Answer 1


arara was recently included in TeX Live 2012, as seen in the output of

$ tlmgr info arara
package:     arara
category:    Package
shortdesc:   Automation of LaTeX compilation.
installed:   Yes
revision:    29052
cat-version: 3.0
cat-date:    2013-02-06 08:25:13 +0100
cat-license: bsd
collection:  collection-binextra

Did you update your TeX Live distro recently? If not, maybe arara is missing from the repositories. A quick tlmgr update --self --all will ensure an update to every single package and tool available in the TL tree to their last revisions.

With arara deployed in TL, open your terminal and try

$ arara
  __ _ _ __ __ _ _ __ __ _
 / _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
 \__,_|_|  \__,_|_|  \__,_|

arara 3.0 - The cool TeX automation tool
Copyright (c) 2012, Paulo Roberto Massa Cereda
All rights reserved.

usage: arara [file [--log] [--verbose] [--timeout N] [--language L] |
             --help | --version]
 -h,--help             print the help message
 -L,--language <arg>   set the application language
 -l,--log              generate a log output
 -t,--timeout <arg>    set the execution timeout (in milliseconds)
 -v,--verbose          print the command output
 -V,--version          print the application version

TeX Live takes care of adding a symbolic link to the arara.sh script which calls arara.jar with the operating system's Java Virutal Machine (if I recall correctly, Ubuntu comes with at least OpenJDK, which arara is compliant).

If you cannot get the output, maybe the TeX Live 2012 bin/ folder was not added to the path. Try running which pdflatex in your terminal and see the full path, it should have mention to the TL2012 install. If not, you might need to include the correct folder. Of course, it depends how you installed TeX Live in the first place.

According to the user manual, go to Preferences,

Info 1

then go to Typesetting path, and click the + button in the Processing tools.

Info 2

Now select the path to arara. Note that in this image, I used the path provided with the standalone installer of arara, since you are using the TeX Live version, stick with the link available in TL's /bin folder.

Info 3

Then arara is available in the Profiles list.

Info 4

Hope it helps. :)

Update: If we are talking about the TeX Live 2012 version available through Ubuntu's own repositories and not the TL version from TUG (a.k.a vanilla), arara is not available.

The best option, in this case, is to use the standalone installer available in the project repository. For more information on how to install arara with the installer, I kindly suggest Chapter 2 of the manual.

  • 2
    Ubuntu doesn't have tlmgr, maybe this helps to get it onto your system?
    – DJP
    Feb 18, 2013 at 20:00
  • 2
    @DJP: I was expecting a vanilla TeX Live install. :) I'm not well versed in Ubuntu affairs, so the best option is to use the standalone installer available in the project repository. Feb 18, 2013 at 20:06
  • 1
    @PauloCereda: Excellent walkthrough. The hint that it's on TeXLive and the many friendly screenshots (which make it easy to adapt the process to TeXMaker) finally made me try out arara as well (I hang my head in shame for having waited so long) and my it's awesome! Thanks for the excellent work (also to the other people on the team)!
    – Jake
    Feb 18, 2013 at 20:12
  • 1
    @Jake: /blushes Feb 18, 2013 at 20:12
  • 2
    @Uwe: I'm still studying a way of replacing the .sh file by a Perl one, so the deployment would work on all platforms. A quick solution is to copy a file named runscript.exe which lives inside bin/win32 and rename the copy arara.exe, also inside the same folder. I think it's enough to make Windows TL run arara. :) Feb 18, 2013 at 20:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .