50

I cannot stand the auto-completion of TeXStudio (formerly TexMakerX) regarding parentheses, braces, etc. I agree auto-completion is useful sometimes, but here it does just not work as I would like. How can I remove it completely?

Under configuration -> completion nothing is checked. From where do I remove the auto-completion of these?

5
  • 3
    There are parentheses (), braces {}, and brackets []. I don’t get any sort of auto-completion for parentheses in Texmaker. Could you describe in how exactly we can reproduce the undesired behavior you’re asking about? A screen shot might be helpful as well.
    – doncherry
    Feb 23, 2013 at 20:28
  • 4
    Have you seen “Auto Complete Parentheses” under “Special Options” in the “Adv. Editor” tab of the “Configure TeXstudio” window? Feb 23, 2013 at 21:14
  • @Qrrbrbirlbel Great that is it, thank you ! Can you post this as an answer so I accept it ? I actually haven't seen the Advance editor box, which opens up some good customization options. Love it. Thank you.
    – redfiloux
    Feb 23, 2013 at 22:09
  • Ah, so we’re talking about Texstudio/TexMakerX? Could you edit your question accordingly?
    – doncherry
    Feb 23, 2013 at 22:27
  • @doncherry: Just did it. Sorry, forgot this isn't the original TexMaker. I will actually have a look to see their differences. Thanks to all.
    – redfiloux
    Feb 23, 2013 at 23:05

1 Answer 1

68

Under OptionsConfigure TeXstudioAdv. EditorSpecial options the option Auto Complete Parentheses dis-/enables the Auto-Completion of all braces, brackets and parentheses. The Tab Adv. Editor is visible after the checkbox Show Advanced Options is checked.

enter image description here

5
  • 12
    +1 for Screenshot: I am always confused by GUI configurations.
    – Lukas
    Jan 2, 2014 at 13:07
  • 3
    Wow, Tex Studio has made it very hard to figure out how to turn off their annoying autocomplete feature.
    – littleO
    Nov 5, 2018 at 0:46
  • 2
    Yes. How is this considered an advanced feature? It's nearly impossible to write out maths with it enabled. Dec 4, 2018 at 18:09
  • After unchecking that box, for some reason I can't use special characters such as "~" from keyboard anymore. When I type "ALT + 126" I don't get anything. Does anybody know how to fix this issue?
    – Lele99_DD
    Feb 12, 2019 at 14:49
  • 3
    Just to make it extra clear since it took me a second: You have to check the box Show-Advanced Options for Adv. Editor to appear.
    – Kvothe
    Mar 4, 2020 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.