4

I am trying to make a CV using moderncv. I tried some example CV tex files, but got no pdf being produced, though there was no any error actually. So rather I tried a simple one like this:

\documentclass[11pt,a4paper]{moderncv}

%% ModernCV themes
\moderncvtheme[blue]{casual}  
%\moderncvstyle{casual}
%\moderncvcolor{blue}
\renewcommand{\familydefault}{\sfdefault}
\nopagenumbers{}

%% Character encoding
\usepackage[utf8]{inputenc}

%% Adjust the page margins
\usepackage[scale=0.75]{geometry}

%% Personal data
\firstname{Protik}
\familyname{Das}
\title{Resume}
\address{University of Dhaka}
%\mobile{+1~(234)~567~890}
\phone{01678-715530}
%\fax{+3~(456)~789~012}
\email{john@doe.com}
\homepage{www.johndoe.com}
\extrainfo{additional}
\photo[6pt][0.4pt]{pic}
\quote{Some quote (optional)}

%%------------------------------------------------------------------------------
%% Content
%%------------------------------------------------------------------------------
\begin{document}

\maketitle

\section{Education}

\end{document}

I got one badbox & other warning type while running this. These are:

badbox: Underfull \hbox (badness 10000) in paragraph at lines 36--36 warning: \footskip is too small (30.0pt): Make it at least 36.71997pt.

I tried both \maketitle & \makecvtitle they both showed the same error. If I omit the \maketitle then it runs & only a pdf with Education section is produced.

I'm using texmaker with most updated Miktex. Can anybody please help?

2
  • Your MWE compiles perfectly on my system (assuming your picture is named pic.jpg). You are probably missing a few required packages or use outdated ones. Update your system and provide use with the output of \listfiles if your problem isn't solved.
    – Xavier
    Feb 24 '13 at 16:55
  • @Xavier, thanks for the info about \address. I was compiling with the version that shipped with the DVD TeXLive 2012 before I downloaded the newest. I believe that this problem is TL as can be seen from the self-answer.
    – hpesoj626
    Feb 24 '13 at 22:36
2

It took nearly 24 hours to find the cause. But the solution is as simple it can be. Actually underfull was never the problem. The problem was hidden in the log file. No pdf was produced beacuse of the special icons like mobile or email icons on the address lines. One just have to run two simple commands in the command prompt & everything should be alright in no time. Try these commands seperately & run the tex file again.

initexmf --mkmaps
initexmf --update-fndb

Happy texING!!! :D

3
  • It didn't work for me.
    – Veliko
    Jan 13 '17 at 12:48
  • Thanks for this, it was a huge help. The problem still exists in 2017 Jun 15 '17 at 21:11
  • Thanks. Finally a solution that worked for me. Problem still exists in 2019.
    – marcel
    Aug 23 '19 at 9:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.