4

Can anyone provide me with some intuition about what might cause an error like this?

Argument of \XC@definec@lor has an extra }

I am unable to produce an MWE that demonstrates the error, as it occurs in a large document and when I extract the part that seems to be causing the error and compile it by itself it works as expected and does not produce the error.

I think that it is related to a TikZ picture I am trying to draw.

Reference: How to paramerize a tikz chain picture with list of nodes

7
  • Looks like somewhere in your picture you have a typo such as a missing comma as in fill=redcircle.
    – percusse
    Feb 24, 2013 at 21:46
  • Is it possible that some other macro or something defined in another package could cause something like this to happen? As exactly the same text seems to work when I put it in a document by itself. Feb 24, 2013 at 21:49
  • Also possible. This error usually pops up when the color name is replaced by a number or something incompatible. So maybe a macro which holds the color name is being overwritten by a number etc.
    – percusse
    Feb 24, 2013 at 21:51
  • 1
    I don't know the syntax package though looks quite old (1996). As far as I can see you can use TikZ for that directly. The fourth tutorial Putting a Diagram in chains in the manual seems to replicate the functionality. Without an example it's really difficult to say more.
    – percusse
    Feb 24, 2013 at 22:28
  • 1
    Narrow... but would solve my problem... :-( Aug 28, 2017 at 14:34

0

Browse other questions tagged .