6

I'm trying to disable links in the first use of glossary entries. I've seen a number of questions asked regarding the formatting of first uses, e.g. here and here, and another question dealing with how to disable links for all items in a type of entry. However, none of these seem to do what I want (and that last question, which seems like it would get the closest, has only one answer that hasn't been accepted, for whatever reason).

So far, I've been using \gls*{<label>} for first uses. However, since I'm still in my draft phase, I'm not sure what entry will be the first, and I keep finding \gls* commands that were first at one point and that I've forgot to update to \gls. What I would like is to not have to worry about this, which would be easy if there was some sort of nolinkonfirst option, or something of the sort (some of you might say I shouldn't worry about this during the draft phase, but I kinda do, and I thought this might be easily fixed).

I've checked the documentation, and thought maybe redefining \glsdisplayfirst or using \defglsdisplayfirst would be what I need. However, I cannot seem to understand how to use them.

1 Answer 1

9

Load the package with

\usepackage[hyperfirst=false]{glossaries}
4
  • Works like a charm. Can't believe I missed it in the documentation.
    – jja
    Feb 25, 2013 at 17:47
  • Is that also possible for just some glossaries? For acronyms I like false but for the main glossary I would like to set true
    – LaRiFaRi
    Aug 11, 2013 at 11:07
  • 1
    @LaRiFaRi Unfortunately, hyperfirst is a package-wide boolean, so it either applies to all glossaries, or none. But maybe @NicolaTalbot can implement it as a glossary-wide option if we ask nicely :-)
    – mafp
    Aug 11, 2013 at 20:58
  • I just did. Thanks for answering. When something is coming up, I hope it will be seen here: tex.stackexchange.com/q/127702/32245
    – LaRiFaRi
    Aug 11, 2013 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .