Linked Questions

265
votes
10answers
140k views

How to install “vanilla” TeXLive on Debian or Ubuntu?

Debian and Ubuntu have very good texlive packaging. But I'd like to use tlmgr to have a more fine-grained control about upgrades and which packages I want to be installed. So how do I install "...
301
votes
6answers
261k views

How do I update my TeX distribution?

I'm trying to compile a document that only works with an up-to-date distribution, so I'd like to know: how do I update my distribution? Please provide screenshots where appropriate. List of answers ...
28
votes
1answer
19k views

(k)ubuntu, TeXLive manually installed, tlmgr not working

(Summary: tmlgr was not working in a typical manual (non-apt) install of TeXLive in Ubuntu.) In Kubuntu, I used install-tl-unx.tar.gz, and install-tl --gui=text to make a basic install. That is, I ...
27
votes
3answers
4k views

How to build my LaTeX automatically using Travis CI?

How to do I build my LaTeX files with TeX Live using the continuous integration server Travis CI to which I push with git, especially considered that I do not want to download everything of TeX Live ...
3
votes
2answers
7k views

Error using tlmgr in Tex Live

I am getting an error when using tlmgr to update or install latex packages. For example, the command tlmgr update -all in the terminal yields the following response: (running on Debian, switching ...
2
votes
1answer
3k views

tlmgr error with Ubuntu 16.10

I'm on Ubuntu 16.10 and using TexLive from the default Ubuntu repo. I'm trying to use the package sansmath. Looking with kpsewhich comes back blank. So I try tlmgr install sansmath and (with/without ...
1
vote
1answer
740 views

“luaotfload.sty not found” and tlmgr “running on debian” issue

I've just installed Linux Mint 18.2 and TeX Live 2017 (I'm pretty sure; see below). I actually have two separate issues masked into one, so I will present them both. I have the following minimum ...
2
votes
0answers
623 views

Manual TexLive install---Texworks collection doesn't show up. Should I just use Ubuntu/Debian Texworks package?

I just installed LaTeX on my system, which is a Linux Mint 16 (Cinnamon) 32-bit installation on a 64-bit Lenovo e420. I originally had used apt-get to install the base Ubuntu package along with ...
0
votes
1answer
613 views

error when trying to compile .tex files: File `pgfpages.sty' not found. \RequirePackage

Compiling this file worked well under Linux Mint 17.2, but since I upgraded to Mint 18, I get this error. I tried installing pgfpages with tlmgr, but the package isn't present in repositories. I get ...
1
vote
0answers
523 views

\usepackage[T1]{fontenc} produces numerous errors and ruins PDF

All I want is to be able to use \guillemotleft and \guillemotright. I'm on Ubuntu 14.04, 64-bit. These are the packages I load, after declaring documentclass article. \usepackage{mathtools} \...
0
votes
0answers
121 views

`titlepages.sty' not found [duplicate]

i'm trying to use the titlepages package \usepackage{titlepages} but TeX Maker gives me this error: ! LaTeX Error: File `titlepages.sty' not found. Type X to quit or to proceed, or enter new ...