Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [bugs]

Bugs in TeX related programs

0
votes
0answers
18 views

Macro for writing names bug? [duplicate]

I have just defined this macro: \newcommand{\ER}{Erd\H{o}s-R\'enyi} that should allow me to write \ER and get Erd\H{o}s-R\'enyi, so that I can save some time. The problem is that if I want to write ...
2
votes
1answer
79 views

How can I circumvent this TikZ circuits bug when placing symbols at start or at end?

In the following MWE (essentially taken from page 603 of the pgf manual), when I try to place the symbols at start and at end, two unintended effects occur: In each symbol there is an extra line ...
0
votes
0answers
16 views

Bug in section numbering indentation? [duplicate]

I used automatically generated documents to export some computation results and I have observed that when section number reach 100 the indentation becomes too small to prevent some overlaps: I have ...
3
votes
1answer
41 views

Disappearing left side of `aligned`

The following code \documentclass{amsart} \begin{document} \[ \begin{aligned} [E^dx,y]&=E^k[E^{d-k}x,y]-kE^{k-1}[E^{d-k}x,Ey]\\ &+\binom k2E^{k-2}[E^{d-k}x,E^2y]-...\\ &+(-1)^j\binom ...
4
votes
1answer
86 views

Which fixes from mathtools were merged to the AMS packages already?

mathtools aims to fix bugs and problems with the AMS package set. Quote from the AMS site http://www.ams.org/publications/authors/tex/amslatex: In 2016, LuaTeX version 1 was released, and ...
1
vote
1answer
26 views

\AtEndOfEveryFile is executed in \begin{itemize}

I was quite surprised that the \AtEndOfEveryFile hook defined by the filehook package is executed in \begin{itemize}. Is this behaviour intended? If not, how and where do I file a bug report? \...
2
votes
1answer
68 views

Gmail built in pdf viewer omits last symbol in an url, any idea why? [closed]

Using amsrefs, I want to refer to an answer on mathoverflow. That site has automated amsrefs entry creation option. When I use it, everything goes fine, and the pdf file contains correct link. However ...
0
votes
1answer
56 views

Wrong position of arrows in Tikz with pgfplots version 1.3

I use the following code to draw an arrow in Tikz with \pgfplotsset{compat = 1.3}: \documentclass{standalone} \usepackage{pgfplots} \pgfplotsset{compat = 1.3} \begin{document} \begin{tikzpicture}...
3
votes
1answer
84 views

Can't use “if” in tikzmath - undefined control sequence “ifpgfmathfloatparseactive”

MWE (copied from TikZ manual): \documentclass{article} \usepackage{tikz} \usetikzlibrary{math} \begin{document} \begin{tikzpicture} \tikzmath{ int \x; for \k in {0,10,...,350}{ if \k&...
5
votes
2answers
238 views

'Dimension too large' error when \setmathfont has the option Scale=MatchLowercase

\documentclass{article} \usepackage{unicode-math} \setmainfont{Georgia} \setmathfont[Scale=MatchLowercase]{Cambria Math} \begin{document} n $n \sqrt[n]{n}$ \end{document} The above code when typeset ...
3
votes
0answers
131 views

LaTeX3 Error in MOdiagram package

I try to compile empty document with MOdiagram package (38448 (0.2g)) and get an LaTeX3 error ! LaTeX3 Error: Variant form 'cNc' deprecated for base form (LaTeX3) '\dim_compare:nNnTF'. One ...
0
votes
0answers
55 views

TeXmaker crashes when typing a left curly brace

Whenever I type a left curly brace in my LaTeX document, the editor crashes. It crashes when copy-pasting the curly brace, too. This happens on two different computers, with just one file. I've tried ...
6
votes
1answer
655 views

Getting errors using Acro for abbreviations and acronyms: Undefined Control Sequence in acro.sty

I've been trying to use acro for abbreviating terms in a report. It mostly works but each compile requires intervention to complete and does something to my first page, leaves an =1 and a page break. ...
2
votes
1answer
62 views

Why Does fancyvrb Turn Comments into Non-comments?

When I execute the following code, I get a nice .pdf as a Result: \documentclass{minimal} \usepackage{fancyvrb} \begin{document} \begin{Verbatim} sdfsdfs \end{Verbatim} \end{document} Below is the ...
0
votes
1answer
50 views

Gibberish string prepended to deleted text in the PDF obtained by compiling 'diff' file generated by latexdiff

I am using latexdiff for marking up corrections requested by the examiners to my PhD thesis. I have a strange issue with this. Upon compiling the diff.tex file, I get a specific string 4.0pt=-.55ex ...
4
votes
1answer
68 views

Incompatibility between babel-french and tasks

There seems to be an incompatibility between these two packages. Look at these two MWE: The right one \documentclass{article} \usepackage{tasks} %\usepackage[french]{babel} \begin{document} \begin{...
1
vote
1answer
194 views

Second line of paragraphs indented in source, TeXShop 4.12 OSX

After updating to the latest version of TeXShop, every paragraph in my source displays with the second and subsequent lines indented. This is true for new and old documents. How do I disable this ...
1
vote
1answer
32 views

Missing line (its vertical skip) after \multirow command

I am creating a table that will use \multirow (and \multicolumn) command(s). Before compilation, I can imagine what I expect and it is this: So, my code look like this: \documentclass{article} \...
1
vote
0answers
26 views

Text on one page is different color than other pages

I'm writing an article and as I was editing it I noticed that sometime within the last half hour the text on one of the pages had turned blue. I wasn't doing anything other than adding/removing text, ...
2
votes
1answer
74 views

bug in frankenstein?

I cannot get includedocskip in the newclude package to work. As far as I can tell, it requires the allocate option, but this option loads allocate.sto, which uses an InitWheel command that has not ...
1
vote
0answers
57 views

Question Mark Boxes (⍰) in LyX menus

I am running LyX 2.3.1 on OS X 10.13.6 with the latest MacTex distribution. I've also updated the installed packages with TeX Live Manager recently. Question mark boxes appear next to some menu items ...
1
vote
0answers
97 views

Package xcolor Error: “Undefined colors when master (classicthesis 3.1) has PDF included” even though the PDF has been deleted from the document

I think this is a bug I've stumbled upon and it's driving me up the wall. Referring to this question, I've got the same setup: Package xcolor Error: Undefined colors “Maroon”/“Royal Blue” when master ...
2
votes
0answers
127 views

Shell command error when compiling with LuaLaTeX shell-escape in Fedora 28 [closed]

When compiling this minimal TeX file with lualatex --shell-escape test.tex I get an initial shell error (that is output to stderr), sh: all: command not found (check in the 7th line). The error doesn'...
1
vote
1answer
50 views

Bug with curly braces and \fontsize? [duplicate]

I've noticed that the second argument of \fontsize appears to get ignored sometimes when wrapped in curly braces. Instead, the text appears to be set with minimal leading. Example 1: \fontsize{18}{...
1
vote
0answers
98 views

Why does TeXstudio crash after the second compilation of this file? [closed]

I'm working on the following file, whose main structure is borrowed from the @Tom Bombadil's answer. \documentclass[12pt,letter]{book} \usepackage{tikz} \usepackage{setspace} \usepackage[left=1in, ...
4
votes
1answer
96 views

Incorrect output with algorithm2e when using “newtxtext” package

I have a LaTeX document displaying an algorithm and the output is incorrect when I use the package newtxtext with algorithm2e. Here is the minimum working example that shows this problem. \...
2
votes
1answer
217 views

Automatic setting of greek letters in \begin{} environment

I am not quite sure, what happened, but I was working on some equations, and all of a sudden, TexStudio became buggy. It automatically writes all I write in the \begin{} statement in greek letters (...
4
votes
1answer
113 views

Spacing issue with literate in listings

I answered this question and OP showed me a problem with the answer. The code: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{listings} \lstset{ % keepspaces, % Apparently this ...
5
votes
2answers
140 views

The “max” function on Tikz being annoying, help?

I used Tikz to chart the following function. This is fine, except that I want the function to equal 0 instead of negative values. So I tried using "max(0,f(x))", where f(x) is my function (specified ...
14
votes
1answer
407 views

Is PSTricks breaking LaTeX?

Sorry for the newspaper headline title :P I have a document in which I (ab)use LaTeX's control structures, namely \@for. Naturally, the contents of some of these loops contain \par agraph breaks. I ...
3
votes
1answer
130 views

Weird arrows with mhchem - Bug in package, font or LuaTeX?

I am using the mhchem package with the Libertinus font family in my PhD thesis. When typesetting with LuaTeX, there are some weird issues with arrows depicting reactions. Here is the MWE to ...
1
vote
1answer
73 views

Bug in colaction for nested multicols environments?

I found this bug related to the colaction feature of multicol : The "column number indicator" doesn't switch back to 1 after the "inner" two-column multicols environment ends. (The bold number ...
0
votes
1answer
41 views

Texstudio throws compilation error if a custom output directory is selected

I am using Texstudio with texlive-most on Arch Linux. I have modified the pdflatex command to save all auxillary files in a separate directory using: pdflatex -synctex=1 -interaction=nonstopmode --...
0
votes
1answer
70 views

all option breaks xy package

I've been trying to load xy with the all option, but I get the error ! LaTeX Error: Two \documentclass or \documentstyle commands. See the LaTeX manual or LaTeX Companion for explanation. Type H &...
9
votes
0answers
639 views

Transparency and PDF: Wrong Colors (Bug / Feature Request) [closed]

There are some questions regarding rendering problems (color shifts) in Adobe Acrobat Reader when using transparency in tikz and friends or transparent PNGs. The solutions (that work for me so far) ...
1
vote
1answer
74 views

How can I use \appendix with Beamer's ignorenonframetext option?

I am almost certain that the following used to work just fine. However, it certainly doesn't work any more. I have workshop materials (based on UK TUG's) which use wrappers to input a common file ...
0
votes
0answers
317 views

Texmaker crashes as soon as I open an “environment” \begin{}

I have reinstalled Windows 10 and I'm now having trouble with the last version of Texmaker (5.0.2). I'm working on quite a long .tex file (300 pages) and Texmaker crashes as soon as I write \begin{ ...
2
votes
1answer
440 views

“Undefined control sequence” heisenbug

I'm editing the file below and I started getting an "Undefined control sequence" error. The thing is, I don't think there is an error with the code. In fact, in item 6, the second math display is ...
25
votes
1answer
2k views

biblatex broken overnight

As late as last week my setup for biblatex worked fine. Going back to the same project today not even a minimal file compiles: \documentclass{article} \usepackage{biblatex} %\addbibresource{...
1
vote
0answers
69 views

something went wrong with mdframed package when tikz is applied [closed]

The following is the code I downloaded from the Internet: a ordinary environment of theorem. \documentclass{ctexart} \usepackage{xcolor} \usepackage[framemethod=tikz]{mdframed} \usepackage{amsthm} %%%...
2
votes
1answer
541 views

How to fix hypertargets directing links to the line after the target? It looks like a bug

If the hypertarget is in a text-mode location, links to it work normally (they show the target line at the top of the page). However, if the hypertarget is in math mode (of any kind: in-line or in ...
1
vote
1answer
70 views

Bug in using listing, an “é” pop at the first line

Currently using \usepackage{listings} and since I did not have any trouble. But my last two insertion I have a bug : an "é" is inserted at the first line. I am using Overleaf and here is the context : ...
2
votes
0answers
115 views

bug in latest build of PSTricks? [duplicate]

Earlier today, I tried applying the update (on my MkTeX system, running under Win7 Pro) for PSTricks from 2.78 (27-Nov-17 build date) to 2.80a (31-Dec-2017 build date), and doing so caused a ...
1
vote
0answers
138 views

TeXMaker, LaTeX problem or memory?

If I want to compile in Ubuntu TexLive2013 tex file with "ł" in proof enviroment, if "ł" is outside, then is OK: Underfull \hbox (badness 7558) in paragraph at lines 17--18 \OT4/cmr/m/n/10.95 ho-mo-...
0
votes
1answer
295 views

Problem/bug with Beamer and multimedia package

EDIT: This is indeed a bug that has been fixed in https://github.com/josephwright/beamer/issues/437#event-1377360577 and should be available soon. Since updating Miktex today (12/7/2017) I cannot ...
1
vote
0answers
625 views

TeXStudio throws an error when using build and view once the file is saved [closed]

I have this "Could not start the command: Build & View" error, with the difference to the existing questions, that it works for old files I created in the past. And for unsaved files. But once I ...
0
votes
2answers
175 views

undefined control sequence \OT when ß appears in TOC [closed]

I use the command \addtocontents \documentclass[a5paper, 11pt]{scrbook} \usepackage[ngerman]{babel} \usepackage[utf8]{inputenc} \usepackage{helvet} \usepackage{tocloft} \usepackage{scrpage2} \begin{...
1
vote
1answer
129 views

Inside a minipage centering or flushing environments disables \color command (Is it a bug?) [closed]

The next is the MWE that demonstrates the failure of pdflatex and LaTeX to color text that is inside minipage in a center or flushleft/flushright environment using command \color. XeLaTeX works fine ...
0
votes
0answers
654 views

latexmk -recorder doesn't find .fls file containing pdflatex process ID in its name

I've started editing LaTeX documents using VS Code's Latex Workshop extension, which uses the very flexible latexmk and its -recorder option under the hood. This is nice, but I've noticed that files ...
1
vote
1answer
87 views

hfill works different after syllabification

I realized that hfill only flushes the first word to the right if the line started with the second half of a syllabification. If there is a manual linebreak afterwards the problem does not occure: \...