Skip to main content

Questions tagged [bugs]

Bugs in TeX related programs

Filter by
Sorted by
Tagged with
0 votes
0 answers
25 views

Memoir header marks are blank when page style is changed within the document

I copied from the Memoir documentation some very simple and working code to modify headings. It seems like \rightmark and \leftmark fail to resolve if the page style is set temporarily or changed in ...
Shevvek's user avatar
1 vote
0 answers
35 views

amsmath and lmodern incompatibility [duplicate]

I noticed that \usepackage{lmodern} will break amsmath automatic sizing. Am I doing something wrong? (I thought that Latin Modern was the way to go, for newer documents, but it seems buggy at the ...
Atcold's user avatar
  • 1,747
2 votes
2 answers
85 views

Extraneous indentation on the line following double-dollar display math with \eqno or \leqno

MWE: \documentclass{article} \begin{document} $$x\eqno (1)$$ N\\N $$y\leqno (2)$$ N\\N \end{document} The lines following display equations $$...$$ with \eqno or \leqno are slightly indented. ...
Alexey's user avatar
  • 2,161
3 votes
0 answers
49 views

What causes calign=fixed edge angles to behave inconsistently when grow is not equal to 270?

I would like to understand what causes the following behaviour in forest. MWE [Note that most of the code isn't code necessary to reproduce the problem but rather annotations I've added in an attempt ...
cfr's user avatar
  • 207k
0 votes
0 answers
22 views

Runaway argument: ! Paragraph ended before \\customcventry was complete. <to be read again> \par

I'm trying to figure out how to fix the bugs in my code in overleaf so I can submit and have an actual copy of my resume. In order to do so, I kinda need to fix the bugs which is hard considering how ...
Leonard Way's user avatar
0 votes
1 answer
31 views

Text alignment with flushright centers my text instead, is this a bug?

Using TeXstudio. I've been trying to align a piece of poetry I wrote to the right side of the page. Essentially, I want to achieve a two column structure with their alignment being left/right flushed. ...
xDonnervogelx's user avatar
0 votes
0 answers
31 views

Asymptote: white gaps in surface

In a question and answer of mine, I provided some Asymptote code which compiled nicely. Now, compiling the same code, I get a different output. Here the code repeated, identical to the old answer: \...
Gargantuar's user avatar
  • 1,231
1 vote
0 answers
522 views

Text disappearing in MiKTeX

This is about a hard-to-reproduce problem that has plagued me intermittently for years. I reported it earlier, but to no avail. I was now finally able to boil it down to a very small test case and I ...
Frunobulax's user avatar
  • 2,228
2 votes
1 answer
156 views

LuaLaTeX bugged out with unicode in supplementary planes?

MWE: \documentclass[margin=0pt, 12pt]{standalone} \usepackage{fontspec} \usepackage{unicode-math} \setmonofont{FiraCodeNerdFontPropo}[ Extension = .ttf, Path = ../../../fonts/FiraCodeNerdFont/, ...
zhtluo's user avatar
  • 35
1 vote
1 answer
85 views

Quantikz circuits bugs in TexStudio

I'm working in a huge file in Tex Studio in which I create lots of circuits using quantikz. The issue is that whenever I draw a circuit in the third chapter or later, the diagram that appears in the ...
ryoutatsu's user avatar
1 vote
1 answer
20 views

amsbook and subappendixes: the word "Appendix" appears twice

I would like to include per-chapter appendices in my long paper, which uses the amsbook document class. To do this, I use the subappendices environment from the appendix package (c.f. this older ...
Alex Elzenaar's user avatar
0 votes
0 answers
149 views

Bug in fontspec 2.9a or luaotfload (which one?) while use LuaLaTeX

LuaLaTeX does not find the CMU font. Package fontspec Error: The font "CMUSansSerif" cannot be found. \setmainfont At the same time, XeLaTeX compiles normally. I am using TeXLive2023 (Win ...
sergiokapone's user avatar
  • 5,598
1 vote
1 answer
187 views

Broken TeXLive update

I've just updated my TeXLive 2023 installation (with the tlmgr update --self --all command) and it appears to be broken. Specifically something in the polyglossia package. I have these lines (headers) ...
Marcel S.'s user avatar
  • 1,313
1 vote
1 answer
56 views

Dimension too large error while using path decoration in TikZ

An error occurs when connecting the path decorations. ! Dimension too large. <to be read again> \relax l.12 ...lot[] ({-sin(\t r)}, {cos(\t r) + 5e-2*\t}); ...
sergiokapone's user avatar
  • 5,598
4 votes
1 answer
79 views

Strange number using hep-math package

I wanted reproduce this image, using hep-math package at the link Diffcoeff turns ordinary derivative into partial derivative but when I put in the x a superscript \sigma to the denominator I see a ...
Sebastiano's user avatar
  • 56.7k
1 vote
1 answer
42 views

animate and pgfplots, variable in domain leads to "TeX capacity exceeded"

I'd love to animate a plot but the problem even appears on this simple minimum example. It would be kind if someone could check if there is a programming error on my side or perhaps a bug involved. I ...
Martin's user avatar
  • 207
7 votes
1 answer
180 views

Why do I get "unused global options warning" for options forwarded to a package except for the first option?

I am working on a custom package for my macros and shortcuts, and a custom class for my preferred style of the document. I am using DeclareKeys to define key-value options in my package, and then my ...
Shai Avr's user avatar
  • 909
4 votes
1 answer
141 views

Confusing scoping of bolding in beamer

I'm not sure if I've happened on a bug or am merely misunderstanding how some font commands in latex ought to behave. The following is a heavily minimized example that produces a bolded "tt" ...
daniel gratzer's user avatar
0 votes
1 answer
38 views

Comments within \pgfplotstableread{...} lead to error

I use the \pgfplotstableread{} command of the pgfplotstable package and manually type in a table. \documentclass{article} \usepackage{pgfplotstable} \begin{document} \pgfplotstableread{ Col1 Col2 ...
babajabba's user avatar
8 votes
1 answer
84 views

Footnotes defined with \newfootnoteseries don't work

I'm having trouble with new footnotes defined using \newfootnoteseries. The following MWE \documentclass{memoir} \newfootnoteseries{P} \begin{document} \footnote{Test1} \footnoteP{Test2} \footnoteP{...
rzach's user avatar
  • 436
3 votes
2 answers
122 views

How to use \MakeUppercase in combination with the bm package in LaTeX 2022-11-01

I am trying to submit LaTeX sources to arXiv and I ran into some issues. My project lives in overleaf where I am using TeX Live 2021 and everything compiles without any errors or warnings (except from ...
Mr Tsjolder from codidact's user avatar
0 votes
0 answers
97 views

Strange artifacts with \hhline

I'm trying to use \hhline to draw partial lines in my tables (for which I can't use \cline since my tables contain coloured cells and it is a well-known problem that this combination doesn't work). I'...
Mew's user avatar
  • 843
0 votes
1 answer
46 views

Texstudio - tooltips not showing up

I am running TeXstudio 4.6.3 on a Windows 11 machine with TexLive distribution. I am getting crazy, I am not able to see any tooltips for any LaTeX commands. I have tried all the possible ...
Massimo Bortolotto's user avatar
2 votes
1 answer
115 views

How do I highlight text or formulas?

I want to highlight newlined sentences and formulas. The following code will allow me to highlight newlined sentences, but I get an error if they contain quotations (\cite) or formulas (\begin{...
ayato kanada's user avatar
0 votes
0 answers
53 views

Spreadtable bug \ST@after@ref@found

Tried to compile an old, once working document, but a bug popped out. Took an example from the documentation, but the bug showed up. I use TexLive2023, I update it regularly \documentclass[]{article} ...
sergiokapone's user avatar
  • 5,598
0 votes
0 answers
23 views

What is the best way to report this apparent bug re setting tikz font size in documentclass minimal? [duplicate]

I was using Overleaf to do drafts of various figures and was unable to set the font size. For example, this \documentclass{minimal} \usepackage{tikz} \begin{document} \begin{tikzpicture} \node[font=\...
Nat Kuhn's user avatar
  • 676
0 votes
3 answers
343 views

pdf plots/figures have weird artifacts

So I used to use svg-files for my plots, but compiling with too many figures took way too long, so I switched to pdf-figures, which works way better in that aspect. I did not convert the svg files to ...
maxxel_'s user avatar
  • 51
2 votes
1 answer
93 views

Bug in siunitx?

I am using power to 1/2 in siunitx: \documentclass{standalone} \usepackage[per-mode = symbol-or-fraction]{siunitx} \usepackage{xfrac} \begin{document} \unit{\second\tothe{\text{\sfrac12}}} \unit{\...
Pygmalion's user avatar
  • 6,329
8 votes
3 answers
286 views

Why does the "\left [" partially disappear when I color a row in a table? But [ does not disappear

The problem is shown in the picture below: the tall left-hand square brackets that should be produced by \left[ and \begin{bmatrix} vanish. The code is as follows \documentclass{article} \usepackage[...
Darkhomo Van's user avatar
1 vote
1 answer
92 views

bug with backrefalt and natbib's sort&compress

I encountered a bug between natbib's sort&compress and the backrefalt feature to locate the section of citation in the bib. Here is a short template to reproduce the error: \documentclass[11pt]{...
namin's user avatar
  • 153
3 votes
1 answer
352 views

pdflatex bug(?) with Elsevier template and accents in authors name

I found a weird bug in the Elsevier (Automatica) template when I'm building it with pdflatex. If one of the authors has an accent (ó, or something). The building of the document yields an error. If ...
seaver's user avatar
  • 503
2 votes
1 answer
77 views

Undefined control sequence but everything is defined

Minimal not working example: \documentclass{article} \usepackage{amsmath,amsthm,amssymb,varwidth,xstring,environ} \newsavebox{\tempbox} %Allows to use fbox in newenvironment \makeatletter \...
Flowt's user avatar
  • 181
-2 votes
1 answer
65 views

Strange black bar in booktabs table doesn't go away [closed]

First of all, the following problem cannot be replicated on other machines. Creating a MWE solves the problem, but I have to solve it within the context of my thesis, which includes a preamble that is ...
Serendipity's user avatar
1 vote
1 answer
80 views

Texshade on Overleaf won't select amino acids by sequence

I would like to highlight certain short sequences of amino acids in a protein sequence. Choosing them by specifying their numbers works, but since some of them occur several times I would prefer to ...
bolzep's user avatar
  • 43
5 votes
1 answer
198 views

A bug in LuaTeX?

I think the output of the following document is wrong %\the\textdir \textdir TLT ab{\textdir TRT ab}\textdir TLT ab \bye If I remove at least one of the "unnecessary" \textdir TLT I get ...
Udi Fogiel's user avatar
  • 4,479
0 votes
1 answer
24 views

"pages=some" option ignored by backgroud package when passed using the \backgroundsetup command

I am trying to use the background package to include watermark-style in the background of my document. However, I only want the background in certain, but not all pages. Supposedly, the package has an ...
mapf's user avatar
  • 253
0 votes
0 answers
287 views

bibtex output for @misc without year seems to depend on the label name of the misc item?

I have a very strange bug using Latex with bibtex. I managed to solve it but I have no idea why it happened. I am using revtex4-2 on overleaf, with apsrev4-2 bibliography style. The document I am ...
JustaPhysicist's user avatar
0 votes
1 answer
49 views

Main language not reselected correctly if previous section ends with other language and section title starts with other language

I have an issue with XeLaTeX with a document with two languages, Hebrew and English. I use a different font for Hebrew (here DejaVu Sans, but any font will do). The problem is that when (1) a section ...
Keelan's user avatar
  • 5,445
0 votes
0 answers
24 views

For some older pdfs the `includepdf` command displays empty pages

I have a XeTeX code as below, but for this n16.pdf it renders empty pages. This is true for most of pre-2000 year pdfs I have. \documentclass[landscape,a4paper]{article} \usepackage{pdfpages} \...
user2925716's user avatar
  • 1,960
1 vote
1 answer
79 views

paracol breaks title marks in headers set by titleps

I noticed that the paracol environment from the paracol package makes \toptitlemarks, \firsttitlemarks, and \bottitlemarks from the titleps package not work. See the following code: \documentclass{...
Amarakon's user avatar
  • 165
1 vote
0 answers
81 views

\MakeUppercase problems with babel [closed]

Why doesn't this code work? \documentclass[10pt,a4paper]{article} \usepackage{babel} \begin{document} \MakeUppercase{Flipa} \end{document}
Daniel soler's user avatar
4 votes
2 answers
435 views

Is it bad practice to use tabs to indicate indentation in LaTeX? [closed]

Should I make it a habit to use spaces instead of tabs when indenting? Casual use of tabs didn't cause problems but so far I experienced a few niche cases where using tabs leads to unexpected behavior....
sion35725's user avatar
12 votes
4 answers
3k views

Quicklook on MacOS Ventura not working anymore for .tex files

since I have updated my M1 macbook air to macOS Ventura I am no longer able to use the quicklook feature for my .tex files, in the finder when pressing the space bar on a files it simply prompts me : &...
Lorenzo's user avatar
  • 123
7 votes
2 answers
327 views

Dog bites man as news, or the verbosity of the messages for no changes to math alphabets

I have a certain LaTeX project that results in a 250 page PDF file whose log file is filled with «No math alphabet change to frozen version normal on input line blah» messages. In fact, the file is ...
Mariano Suárez-Álvarez's user avatar
0 votes
0 answers
193 views

Texmaker crashes when typing \begin{

I have a .tex document with 9021 lines. I use Texmaker 5.1.3 on Windows 10. I have uninstalled and reinstalled. All of a sudden today when I start typing \begin as soon as I type { Texmaker just ...
Thomas's user avatar
  • 2,857
0 votes
1 answer
357 views

Can't use \usemintedstyle and \setstyle for multiple languages

I have the latest version of minted in which I can define color styles for each language (since v2.0, now it's v2.6), but apperently, when using minted environment for multiple languages the code ...
Andrew15_5's user avatar
2 votes
2 answers
145 views

Possible bug in perpage package. TexLive 2022

I'm using XeLaTeX, and the version is: $ xelatex -version | grep 'TeX Live' XeTeX 3.141592653-2.6-0.999994 (TeX Live 2022) When I use the perpage package with the memoir class, the footnote on the ...
zzjing's user avatar
  • 181
0 votes
1 answer
39 views

Enumerate exhibits unexpected behavior when renamed

Enumerate exhibits unexpected behavior when renamed In the example below I renamed enumerate to enum for brevity. \documentclass{article} \usepackage{enumerate} \newcommand{\enum}{\enumerate} \title{...
supsd72184's user avatar
0 votes
0 answers
39 views

Weird output with ragged2e and tikzposter class

I was making a tikzposter and noticed a strange 1=1 output somewhere on the output pdf. Trying to debug what was the cause of this result, I found out that the following simple working example, ...
ado sar's user avatar
  • 203
1 vote
1 answer
46 views

Little glitch in MnSymbol

MnSymbol uses a few symbols from the text font, like \dagger, in math, and does so using the definition \ifx\Mn@Bold\math@version \text{\bfseries#1}% \else \text{\mdseries#1}% \fi} ...
Mariano Suárez-Álvarez's user avatar

1
2 3 4 5