Questions tagged [bugs]

Bugs in TeX related programs

Filter by
Sorted by
Tagged with
25
votes
1answer
2k views

biblatex broken overnight

As late as last week my setup for biblatex worked fine. Going back to the same project today not even a minimal file compiles: \documentclass{article} \usepackage{biblatex} %\addbibresource{...
16
votes
1answer
2k views

TeX Live 2016: minted doesn't work with LuaLaTeX (bug fixed in June 2016)

I've installed TeX Live 2016 as it was released today (thanks to the developers for that). Now I have the following MWE: \documentclass{article} \usepackage{minted} \begin{document} \begin{minted}{...
14
votes
3answers
3k views

I need to save/compile a few times and a bunch of weird files (like foo.tex.Ak6664) appear in my Dropbox folder each time

I need to compile between two and four times before I see changes I make in the editor (TeXstudio) and each time I compile, a new .tex file is created with random letters and numbers at the end. For ...
14
votes
1answer
416 views

Is PSTricks breaking LaTeX?

Sorry for the newspaper headline title :P I have a document in which I (ab)use LaTeX's control structures, namely \@for. Naturally, the contents of some of these loops contain \par agraph breaks. I ...
12
votes
1answer
1k views

Set precise font size in memoir class

It seems, that there is a problem with font sizes in memoir class. In the manual of the memoir class, p. 48, it is written that for example using class option 14 pt we'll get \normalsize = 14 pt. ...
11
votes
2answers
758 views

How to place a dot below for example: e?

After I updated my TL2016 (Windows) environment (10 minutes ago) compiling documents containing for example \d{e} or \d e throws an error message. The following MWE should demonstrate this: \...
10
votes
2answers
446 views

Latest newtx package update (v1.601 Oct 2, 2019) breaks the footnote command [update: bug fixed by package author]

The latest newtxtext package (v1.601 Oct 2, 2019) seems to have broken the \footnote command. Here's a MWE \documentclass{IEEEtran} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{...
10
votes
2answers
350 views

Mathtools' underbrackets and MinionPro

The code \documentclass{article} \usepackage{mathtools} \usepackage{MinionPro} \begin{document} \[ \underbracket{123}_{x} \underbracket[1pt]{123}_{x} \] \end{document} produces If one ...
10
votes
0answers
815 views

Transparency and PDF: Wrong Colors (Bug / Feature Request) [closed]

There are some questions regarding rendering problems (color shifts) in Adobe Acrobat Reader when using transparency in tikz and friends or transparent PNGs. The solutions (that work for me so far) ...
9
votes
2answers
889 views

Incompatibility with mathtools and unicode-math in xelatex?

I find unexpected behaviour in using mathtools in conjunction with unicode-math, which shows up if the 'range' command is used. Some incompatibilities have been noted before, so perhaps this is ...
8
votes
1answer
145 views

Using fancyref in TeX Live 2019 fails with undefined control sequence

The following code worked well for me in TeX Live prior to 2019: \documentclass{article} \title{TEST} \usepackage{fancyref} \begin{document} \section{Actor}\label{sec:actor} See \fref{sec:actor} ...
7
votes
1answer
915 views

Hyperref conflicts with footnote

I dont know if this is a well known problem. I recently used hyperref to make my table of contents clickable, but then I found out that throughout the document, wherever footnote would appear i.e. ...
6
votes
1answer
194 views

Spacing issue with literate in listings

I answered this question and OP showed me a problem with the answer. The code: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{listings} \lstset{ % keepspaces, % Apparently this ...
6
votes
1answer
173 views

fnpct package in TeX Live 2017 not working

Does the newest fnpct package have a bug in it? The following works with (the frozen version of) TeX Live 2016 but not with TeX Live 2017 \documentclass{article} \usepackage{fnpct} \begin{document}...
6
votes
1answer
1k views

Getting errors using Acro for abbreviations and acronyms: Undefined Control Sequence in acro.sty

I've been trying to use acro for abbreviating terms in a report. It mostly works but each compile requires intervention to complete and does something to my first page, leaves an =1 and a page break. ...
6
votes
1answer
147 views

Weird output from the sidenotes package

Although I have been successfully using the sidenotes package for years, it suddenly stopped behaving. Here is the code, \documentclass[oneside]{book} \usepackage[utf8]{inputenc} \usepackage{...
6
votes
1answer
56 views

Wrong keyword style when using multiple languages in listings

With this code \documentclass{article} \usepackage{xcolor} \usepackage{listings} \lstset{% language=[AlLaTeX]TeX, alsolanguage=MetaPost, texcsstyle=\color{blue}, basicstyle=\ttfamily% } \...
6
votes
1answer
2k views

Problem with latest version of babel

I have a problem with that latest version of babel (3.10). If I compile this file: \documentclass{article} \usepackage[ukenglish]{babel} \pagestyle{empty} \begin{document} Hello world! \end{document} ...
5
votes
2answers
301 views

'Dimension too large' error when \setmathfont has the option Scale=MatchLowercase

\documentclass{article} \usepackage{unicode-math} \setmainfont{Georgia} \setmathfont[Scale=MatchLowercase]{Cambria Math} \begin{document} n $n \sqrt[n]{n}$ \end{document} The above code when typeset ...
5
votes
2answers
172 views

The “max” function on Tikz being annoying, help?

I used Tikz to chart the following function. This is fine, except that I want the function to equal 0 instead of negative values. So I tried using "max(0,f(x))", where f(x) is my function (specified ...
5
votes
1answer
74 views

\AtBeginShipoutInit macro of atbegshi causes weird behavior of opacity option in tikz with xelatex

Using \AtBeginShipoutInit causes the opacity option doesn't work at the first page properly, without that there is no problem with the code. \documentclass{article} \usepackage{lipsum} \usepackage{...
5
votes
0answers
1k views

Be careful with latest MikTeX update: MSVCP140_CODECVT_IDS.dll missing [closed]

I noticed that almost all of the MikTeX binaries were updated (looks like they were released today). After backing up my install (if you don't do this before applying updates, you should...), I ...
4
votes
2answers
91 views

top-aligned marginpar on wrong side (even/odd) after pagebreak

Under plain LaTeX with twoside option, I use \leavevmode\marginpar{#1} at the beginning of a paragraph to obtain top-aligned margin notes. Immediately after a pagebreak the margin note may or may not ...
4
votes
1answer
73 views

Incompatibility between babel-french and tasks

There seems to be an incompatibility between these two packages. Look at these two MWE: The right one \documentclass{article} \usepackage{tasks} %\usepackage[french]{babel} \begin{document} \begin{...
4
votes
1answer
112 views

Which fixes from mathtools were merged to the AMS packages already?

mathtools aims to fix bugs and problems with the AMS package set. Quote from the AMS site http://www.ams.org/publications/authors/tex/amslatex: In 2016, LuaTeX version 1 was released, and ...
4
votes
1answer
163 views

Incorrect output with algorithm2e when using “newtxtext” package

I have a LaTeX document displaying an algorithm and the output is incorrect when I use the package newtxtext with algorithm2e. Here is the minimum working example that shows this problem. \...
4
votes
1answer
294 views

Mac Texshop - How to Use Arara (Potential Bug)

This question was asked previously; however, it was not answered for my issues. I correctly: Copied the arara.engine file from .\Engines\Inactive\ to .\Engines. Used the Macro\Program pulldown to ...
4
votes
1answer
353 views

How to set the interactive editor in TeXLive? lualatex bug?

After some research we determined this is a problem inherent to lualatex. If you have a solution for this problem in LuaLaTeX please post it below and I will accept you answer. When compiling a ...
4
votes
1answer
185 views

Weird arrows with mhchem - Bug in package, font or LuaTeX?

I am using the mhchem package with the Libertinus font family in my PhD thesis. When typesetting with LuaTeX, there are some weird issues with arrows depicting reactions. Here is the MWE to ...
4
votes
1answer
83 views

lualatex chokes on tikzposter + unicode-math

Using lualatex, LuaTeX, Version 0.95.0 (the most recent version available for my distribution, ArchLinux), the following minimal example never finishes compiling on my machine. It simply stalls at ...
4
votes
1answer
811 views

pgfplots on tikzmath function with conditionals returns an error

Plotting with pgfplots a function defined using the tikzmath function syntax does not seem to work. The error message : ! Illegal unit of measure (pt inserted). <to be read again> ...
4
votes
1answer
156 views

Unexpected behavior of the “knots” tikz library when a crossing is close to another (thick) line: What's going on?

I recently tried to draw some Olympic rings using the tikz library "knots", and ran into some unexpected behavior. As can be seen in the linked answer, the lower crossing of the black and green rings ...
4
votes
1answer
111 views

How can I correct for a bug in ArabXeTeX that causes problems in left-to-right text?

There seems to be a bug in the arabxetex package that came with the new MacTeX 2016 distribution. The problem I have noticed is not in Arabic text but rather in ordinary left-to-right text. In ...
4
votes
0answers
268 views

LaTeX3 Error in MOdiagram package

I try to compile empty document with MOdiagram package (38448 (0.2g)) and get an LaTeX3 error ! LaTeX3 Error: Variant form 'cNc' deprecated for base form (LaTeX3) '\dim_compare:nNnTF'. One ...
3
votes
1answer
52 views

Disappearing left side of `aligned`

The following code \documentclass{amsart} \begin{document} \[ \begin{aligned} [E^dx,y]&=E^k[E^{d-k}x,y]-kE^{k-1}[E^{d-k}x,Ey]\\ &+\binom k2E^{k-2}[E^{d-k}x,E^2y]-...\\ &+(-1)^j\binom ...
3
votes
1answer
156 views

Can't use “if” in tikzmath - undefined control sequence “ifpgfmathfloatparseactive”

MWE (copied from TikZ manual): \documentclass{article} \usepackage{tikz} \usetikzlibrary{math} \begin{document} \begin{tikzpicture} \tikzmath{ int \x; for \k in {0,10,...,350}{ if \k&...
3
votes
1answer
122 views

Crossings for small knots: I can't seem to manage to flip one of two very close crossings

This question is related to this one on small knots, but the solution there does not help (though it is needed in order for the intersections to appear at all. My problem is the following: I'm ...
3
votes
1answer
44 views

Tcolorbox parbox=false option breaks by height fill option

Tcolorbox parbox=false option breaks by height fill option \documentclass[]{article} \usepackage[most, many]{tcolorbox} \usepackage{lipsum} \begin{document} \begin{tcolorbox}[ parbox=false, height ...
3
votes
1answer
55 views

\asbuk numbering is buggy?

I have russian alphanumeric numbering in a constantly updating document. Recently, the numbering went terribly wrong. MWE: \documentclass{article} \usepackage{ifxetex} \ifxetex \usepackage{fontspec} ...
3
votes
1answer
735 views

How to fix hypertargets directing links to the line after the target? It looks like a bug

If the hypertarget is in a text-mode location, links to it work normally (they show the target line at the top of the page). However, if the hypertarget is in math mode (of any kind: in-line or in ...
3
votes
1answer
224 views

Comma as decimal separator in exsheets package broken

If I want to allow a comma as a decimal separator for points in exams I usually use the solution proposed by @clemens in a comment here as in the example below. However since I updated to texlive ...
3
votes
1answer
87 views

How to prevent colored cite links (hyperref) within tikz node [fill=black, text=white] to reset text color to black?

The following MWE should demonstrate the problem: \documentclass[12pt]{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @book{companion, author = {Goossens, ...
3
votes
1answer
522 views

Pgfplots and large exponents in expression and domain

After I discovered the fpu library for increased precision, I tried to make a plot involving large exponents. I choosed as an example a plot of the gravitational force of the moon on a test mass in SI-...
3
votes
0answers
94 views

No space between columns in twocolumn layout bug

I have a latex document and sometimes there is no space between the two columns on some pages, which makes the text hard to read(and ugly). I managed to figure out, that the problem appears, if I use ...
2
votes
1answer
321 views

Where to report bugs in the LaTeX3 documentation?

Where can I report bugs in the LaTeX3 documentation, e.g. in The LaTeX3 Interfaces document?
2
votes
1answer
703 views

“Undefined control sequence” heisenbug

I'm editing the file below and I started getting an "Undefined control sequence" error. The thing is, I don't think there is an error with the code. In fact, in item 6, the second math display is ...
2
votes
1answer
43 views

Why does dvisvgm produce faulty svg code for some expressions involving fractions and certain fonts?

I would like to ask for help with figuring out exactly what triggers a weird phenomenon concerning rendering of textstyle fractions in certain fonts with dvisvgm (version 2.6.3, distributed as part of ...
2
votes
1answer
68 views

Cases bugged - lines overlapping [duplicate]

The following code overlaps equations: $$U(x) = \begin{cases} - \frac{1}{\lambda} e^{-\lambda x} & \text{gdy} \lambda \neq 1 \\ \ln x & \text{gdy} \lambda =1 \end{...
2
votes
1answer
72 views

Why Does fancyvrb Turn Comments into Non-comments?

When I execute the following code, I get a nice .pdf as a Result: \documentclass{minimal} \usepackage{fancyvrb} \begin{document} \begin{Verbatim} sdfsdfs \end{Verbatim} \end{document} Below is the ...
2
votes
1answer
79 views

Gmail built in pdf viewer omits last symbol in an url, any idea why? [closed]

Using amsrefs, I want to refer to an answer on mathoverflow. That site has automated amsrefs entry creation option. When I use it, everything goes fine, and the pdf file contains correct link. However ...