Questions tagged [bugs]

Bugs in TeX related programs

Filter by
Sorted by
Tagged with
5
votes
1answer
75 views

\AtBeginShipoutInit macro of atbegshi causes weird behavior of opacity option in tikz with xelatex

Using \AtBeginShipoutInit causes the opacity option doesn't work at the first page properly, without that there is no problem with the code. \documentclass{article} \usepackage{lipsum} \usepackage{...
14
votes
3answers
3k views

I need to save/compile a few times and a bunch of weird files (like foo.tex.Ak6664) appear in my Dropbox folder each time

I need to compile between two and four times before I see changes I make in the editor (TeXstudio) and each time I compile, a new .tex file is created with random letters and numbers at the end. For ...
3
votes
1answer
126 views

Crossings for small knots: I can't seem to manage to flip one of two very close crossings

This question is related to this one on small knots, but the solution there does not help (though it is needed in order for the intersections to appear at all. My problem is the following: I'm ...
0
votes
0answers
26 views

Breqn and TeX Live 2016 [duplicate]

Since upgrading to MacTeX 2016 the following example no longer compiles as expected: \documentclass{article} \usepackage[T1]{fontenc} \usepackage{amsmath} \usepackage{breqn} \begin{document} \begin{...
0
votes
1answer
86 views

Possible bug of mhchem package v4.05

It is an error arise with package option \mhchemoptions{arrows=pgf} after last update 2016-08-08 to v4.05. Somebody can confirm? \documentclass[]{article} \RequirePackage[version=4]{mhchem} \...
2
votes
2answers
710 views

Error with color package and \AtBeginDocument in cls file

I have myclass.cls with the following content: \NeedsTeXFormat{LaTeX2e} \ProvidesClass{myclass} \LoadClass{article} \AtBeginDocument{ \tableofcontents \clearpage } \endinput I also have mydoc....
3
votes
1answer
228 views

\clipbox of a \scalebox not working properly in xelatex

Using xelatex... when I apply a \clipbox upon a \scalebox of a box that uses the optional argument, the clip is not performed properly. The problem goes away if: using pdflatex, the optional ...
10
votes
2answers
360 views

Mathtools' underbrackets and MinionPro

The code \documentclass{article} \usepackage{mathtools} \usepackage{MinionPro} \begin{document} \[ \underbracket{123}_{x} \underbracket[1pt]{123}_{x} \] \end{document} produces If one ...
2
votes
1answer
76 views

forest with externalization ignores line breaks (bug?)

This code, compiled with pdflatex --shell-escape does not work as expected: \documentclass{article} \usepackage[external]{forest} \begin{document} this is the line of text I compile \end{document} ...
7
votes
1answer
999 views

Hyperref conflicts with footnote

I dont know if this is a well known problem. I recently used hyperref to make my table of contents clickable, but then I found out that throughout the document, wherever footnote would appear i.e. ...
4
votes
1answer
160 views

Unexpected behavior of the “knots” tikz library when a crossing is close to another (thick) line: What's going on?

I recently tried to draw some Olympic rings using the tikz library "knots", and ran into some unexpected behavior. As can be seen in the linked answer, the lower crossing of the black and green rings ...
1
vote
1answer
340 views

Tikz Library Graph.standard Error: Minimal working example about Tikz Graph library?

I am trying to get a minimal working example about Tikz Graph library working but unsuccessful. I am getting the examples from the page 298 on the tikz manual 3.0.0-cvs, also the page 299 on the 3.0.1 ...
3
votes
1answer
564 views

Pgfplots and large exponents in expression and domain

After I discovered the fpu library for increased precision, I tried to make a plot involving large exponents. I choosed as an example a plot of the gravitational force of the moon on a test mass in SI-...
4
votes
1answer
112 views

How can I correct for a bug in ArabXeTeX that causes problems in left-to-right text?

There seems to be a bug in the arabxetex package that came with the new MacTeX 2016 distribution. The problem I have noticed is not in Arabic text but rather in ordinary left-to-right text. In ...
2
votes
0answers
2k views

Log file not found with Texstudio [closed]

I am using texstudio under windows to execute my .tex files. When I compile the .tex source file and there are no errors, everything goes well and no problem appears. However, if my .tex source file ...
4
votes
1answer
359 views

How to set the interactive editor in TeXLive? lualatex bug?

After some research we determined this is a problem inherent to lualatex. If you have a solution for this problem in LuaLaTeX please post it below and I will accept you answer. When compiling a ...

1 2
3