Questions tagged [bugs]

Bugs in TeX related programs

Filter by
Sorted by
Tagged with
25
votes
1answer
2k views

biblatex broken overnight

As late as last week my setup for biblatex worked fine. Going back to the same project today not even a minimal file compiles: \documentclass{article} \usepackage{biblatex} %\addbibresource{...
1
vote
0answers
78 views

something went wrong with mdframed package when tikz is applied [closed]

The following is the code I downloaded from the Internet: a ordinary environment of theorem. \documentclass{ctexart} \usepackage{xcolor} \usepackage[framemethod=tikz]{mdframed} \usepackage{amsthm} %%%...
3
votes
1answer
687 views

How to fix hypertargets directing links to the line after the target? It looks like a bug

If the hypertarget is in a text-mode location, links to it work normally (they show the target line at the top of the page). However, if the hypertarget is in math mode (of any kind: in-line or in ...
1
vote
1answer
72 views

Bug in using listing, an “é” pop at the first line

Currently using \usepackage{listings} and since I did not have any trouble. But my last two insertion I have a bug : an "é" is inserted at the first line. I am using Overleaf and here is the context : ...
2
votes
0answers
117 views

bug in latest build of PSTricks? [duplicate]

Earlier today, I tried applying the update (on my MkTeX system, running under Win7 Pro) for PSTricks from 2.78 (27-Nov-17 build date) to 2.80a (31-Dec-2017 build date), and doing so caused a ...
1
vote
0answers
159 views

TeXMaker, LaTeX problem or memory?

If I want to compile in Ubuntu TexLive2013 tex file with "ł" in proof enviroment, if "ł" is outside, then is OK: Underfull \hbox (badness 7558) in paragraph at lines 17--18 \OT4/cmr/m/n/10.95 ho-mo-...
0
votes
1answer
338 views

Problem/bug with Beamer and multimedia package

EDIT: This is indeed a bug that has been fixed in https://github.com/josephwright/beamer/issues/437#event-1377360577 and should be available soon. Since updating Miktex today (12/7/2017) I cannot ...
1
vote
0answers
748 views

TeXStudio throws an error when using build and view once the file is saved [closed]

I have this "Could not start the command: Build & View" error, with the difference to the existing questions, that it works for old files I created in the past. And for unsaved files. But once I ...
0
votes
2answers
210 views

undefined control sequence \OT when ß appears in TOC [closed]

I use the command \addtocontents \documentclass[a5paper, 11pt]{scrbook} \usepackage[ngerman]{babel} \usepackage[utf8]{inputenc} \usepackage{helvet} \usepackage{tocloft} \usepackage{scrpage2} \begin{...
1
vote
1answer
139 views

Inside a minipage centering or flushing environments disables \color command (Is it a bug?) [closed]

The next is the MWE that demonstrates the failure of pdflatex and LaTeX to color text that is inside minipage in a center or flushleft/flushright environment using command \color. XeLaTeX works fine ...
0
votes
0answers
934 views

latexmk -recorder doesn't find .fls file containing pdflatex process ID in its name

I've started editing LaTeX documents using VS Code's Latex Workshop extension, which uses the very flexible latexmk and its -recorder option under the hood. This is nice, but I've noticed that files ...
1
vote
1answer
106 views

hfill works different after syllabification

I realized that hfill only flushes the first word to the right if the line started with the second half of a syllabification. If there is a manual linebreak afterwards the problem does not occure: \...
3
votes
1answer
216 views

Comma as decimal separator in exsheets package broken

If I want to allow a comma as a decimal separator for points in exams I usually use the solution proposed by @clemens in a comment here as in the example below. However since I updated to texlive ...
2
votes
1answer
38 views

Using second optional scale for chemfig causes bug in ring with circle [duplicate]

I found a bug in chemfig: If you use the second optional argument in \chemfig[][scale=0.5] the circle in the ring is not resized: \documentclass[captions=tableabove,ngerman]{scrreprt} \usepackage{...
0
votes
1answer
380 views

How can I change the distance between the dots in the leader ToC memoir 3.7f ? (bug in \@dotsep)

I use memoir 3.7f and I can not change \@dotsep. The bug was tested in two PCs. How can I change the disctance between the dots now? memoir documentation citations: p.142 The distance, in math ...
2
votes
1answer
321 views

Where to report bugs in the LaTeX3 documentation?

Where can I report bugs in the LaTeX3 documentation, e.g. in The LaTeX3 Interfaces document?
2
votes
1answer
96 views

Can't substitute LGR font with fbb if [proportional] option given

Running pdflatex, I'm unable to substitute a Greek font with the fbb package if I give the [proportional] option to the package. Without that option, the substitution is fine. Is there a reason this ...
6
votes
1answer
172 views

fnpct package in TeX Live 2017 not working

Does the newest fnpct package have a bug in it? The following works with (the frozen version of) TeX Live 2016 but not with TeX Live 2017 \documentclass{article} \usepackage{fnpct} \begin{document}...
0
votes
1answer
47 views

Bug in \SetProgSty command in algorithm2e package

I found a bug in the \SetProgSty command. Currently, it incorrectly sets the \ArgSty command instead of \ProgSty: \newcommand{\SetProgSty}[1]{\renewcommand{\ArgSty}[1]{\textnormal{\csname#1\endcsname{...
1
vote
1answer
615 views

biber - biblatex issues

I try using biblatex with biber backend, but keep running into problems. I have seen many questions about this here on stackexchange, most recommending to run 'pdflatex, biber, pdflatex' and to check ...
3
votes
1answer
84 views

How to prevent colored cite links (hyperref) within tikz node [fill=black, text=white] to reset text color to black?

The following MWE should demonstrate the problem: \documentclass[12pt]{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @book{companion, author = {Goossens, ...
2
votes
0answers
270 views

Bug in package `acro` [closed]

I think I found a bug in the acro-package which shows up with the single-option in use. Consider the following MWE: \documentclass[]{article} \usepackage[single]{acro} \DeclareAcronym{HMM}{% ...
1
vote
0answers
234 views

A problem with auto-pst-pdf and latest update of graphics-def

Since last update of graphics-def (2017-06-12) I have error messages when using auto-pst-pdf and pstricks. These error messages involve the \stockwidth and stockheight lengths, which are defined by ...
2
votes
0answers
69 views

TexStudio keeps overwriting the ini file [closed]

I just tried to switch from Texmaker to TexStudio, and I would prefer to stay there. I experienced a bug with the Circumflex key, effectively making TexStudio unusable for me, but I could fix it by ...
2
votes
1answer
432 views

! error: (lua): not enough memory

I have a heavy document that is compiled with LuaLaTeX (TeXLive). On Linux, no problem. On Windows, it stop compiling in the middle of the document with the error: ! error: (lua): not enough memory !...
12
votes
1answer
1k views

Set precise font size in memoir class

It seems, that there is a problem with font sizes in memoir class. In the manual of the memoir class, p. 48, it is written that for example using class option 14 pt we'll get \normalsize = 14 pt. ...
6
votes
1answer
2k views

Problem with latest version of babel

I have a problem with that latest version of babel (3.10). If I compile this file: \documentclass{article} \usepackage[ukenglish]{babel} \pagestyle{empty} \begin{document} Hello world! \end{document} ...
4
votes
1answer
82 views

lualatex chokes on tikzposter + unicode-math

Using lualatex, LuaTeX, Version 0.95.0 (the most recent version available for my distribution, ArchLinux), the following minimal example never finishes compiling on my machine. It simply stalls at ...
0
votes
1answer
114 views

Unicode characters are not being rendered anymore, what happened? [closed]

I used to be able to render Unicode characters without any issues in LaTeX. However, since a couple days (I noticed) TeXstudio is not rendering them anymore... If I use: \documentclass[10pt,a4paper]{...
1
vote
1answer
94 views

catdvi: “Does not start with preamble”

Whatever input I give catdvi, it gives the same error: "Does not start with preamble". For terseness, instead of posting my whole project here, I'll just paste an example: \documentclass[a4paper,...
0
votes
0answers
855 views

Problems with Mendeley generated citations

I have recently started using Menedely to generate my references which is great because they are generated automatically. However I have recently encountered the following bug that I'm not sure how to ...
0
votes
2answers
510 views

Why does Texstudio only runs first command of command list after failed build?

I am running into a problem where Texstudio is only running the first command of a list of commands, and I am wondering if I am doing something wrong. Here is a minimal working example so you can see ...
2
votes
1answer
82 views

biblatex philosophy-modern: another bug?

biblatex-philosophy (modern) fails to make proper line breaks when there is no author/editor/translator, etc., to declare. Here is the MWE: \documentclass[12pt,a4paper]{article} \usepackage{...
6
votes
1answer
139 views

Weird output from the sidenotes package

Although I have been successfully using the sidenotes package for years, it suddenly stopped behaving. Here is the code, \documentclass[oneside]{book} \usepackage[utf8]{inputenc} \usepackage{...
11
votes
2answers
731 views

How to place a dot below for example: e?

After I updated my TL2016 (Windows) environment (10 minutes ago) compiling documents containing for example \d{e} or \d e throws an error message. The following MWE should demonstrate this: \...
3
votes
0answers
90 views

No space between columns in twocolumn layout bug

I have a latex document and sometimes there is no space between the two columns on some pages, which makes the text hard to read(and ugly). I managed to figure out, that the problem appears, if I use ...
4
votes
1answer
287 views

Mac Texshop - How to Use Arara (Potential Bug)

This question was asked previously; however, it was not answered for my issues. I correctly: Copied the arara.engine file from .\Engines\Inactive\ to .\Engines. Used the Macro\Program pulldown to ...
2
votes
1answer
138 views

Bug between mdframed and titlesec

EDIT: The version of titlesec I use is titlesec.sty 2011/12/15 v2.10.0 Sectioning titles I am using mdframed for defining boxes and theorem-like environments. When I load the package titlesec, ...
4
votes
1answer
762 views

pgfplots on tikzmath function with conditionals returns an error

Plotting with pgfplots a function defined using the tikzmath function syntax does not seem to work. The error message : ! Illegal unit of measure (pt inserted). <to be read again> ...
5
votes
1answer
72 views

\AtBeginShipoutInit macro of atbegshi causes weird behavior of opacity option in tikz with xelatex

Using \AtBeginShipoutInit causes the opacity option doesn't work at the first page properly, without that there is no problem with the code. \documentclass{article} \usepackage{lipsum} \usepackage{...
3
votes
1answer
118 views

Crossings for small knots: I can't seem to manage to flip one of two very close crossings

This question is related to this one on small knots, but the solution there does not help (though it is needed in order for the intersections to appear at all. My problem is the following: I'm ...
0
votes
0answers
25 views

Breqn and TeX Live 2016 [duplicate]

Since upgrading to MacTeX 2016 the following example no longer compiles as expected: \documentclass{article} \usepackage[T1]{fontenc} \usepackage{amsmath} \usepackage{breqn} \begin{document} \begin{...
14
votes
3answers
3k views

I need to save/compile a few times and a bunch of weird files (like foo.tex.Ak6664) appear in my Dropbox folder each time

I need to compile between two and four times before I see changes I make in the editor (TeXstudio) and each time I compile, a new .tex file is created with random letters and numbers at the end. For ...
8
votes
2answers
839 views

Incompatibility with mathtools and unicode-math in xelatex?

I find unexpected behaviour in using mathtools in conjunction with unicode-math, which shows up if the 'range' command is used. Some incompatibilities have been noted before, so perhaps this is ...
0
votes
1answer
81 views

Possible bug of mhchem package v4.05

It is an error arise with package option \mhchemoptions{arrows=pgf} after last update 2016-08-08 to v4.05. Somebody can confirm? \documentclass[]{article} \RequirePackage[version=4]{mhchem} \...
0
votes
0answers
87 views

Why does this picture kills my pc? Bug or mistake?

When I start this I get pdflatex to use all the CPU without any result: \documentclass[border=5]{standalone} \usepackage{tikz} \begin{document} \def\b{2} \def\h{2} \begin{tikzpicture} \...
2
votes
2answers
655 views

Error with color package and \AtBeginDocument in cls file

I have myclass.cls with the following content: \NeedsTeXFormat{LaTeX2e} \ProvidesClass{myclass} \LoadClass{article} \AtBeginDocument{ \tableofcontents \clearpage } \endinput I also have mydoc....
2
votes
1answer
207 views

\clipbox of a \scalebox not working properly in xelatex

Using xelatex... when I apply a \clipbox upon a \scalebox of a box that uses the optional argument, the clip is not performed properly. The problem goes away if: using pdflatex, the optional ...
10
votes
2answers
340 views

Mathtools' underbrackets and MinionPro

The code \documentclass{article} \usepackage{mathtools} \usepackage{MinionPro} \begin{document} \[ \underbracket{123}_{x} \underbracket[1pt]{123}_{x} \] \end{document} produces If one ...
2
votes
1answer
72 views

forest with externalization ignores line breaks (bug?)

This code, compiled with pdflatex --shell-escape does not work as expected: \documentclass{article} \usepackage[external]{forest} \begin{document} this is the line of text I compile \end{document} ...