Questions tagged [dvips]

dvips is the process that converts `myfile.dvi` to `myfile.ps`

Filter by
Sorted by
Tagged with
34
votes
6answers
47k views

How to allow line break in a long hyperlink in a PDF compiled by latex-dvips-ps2pdf?

I am using latex-dvips-ps2pdf steps with -Ppdf option passed to dvips. The following code snippet \documentclass{article} \usepackage[colorlinks]{hyperref} \usepackage{breakurl} \hypersetup{...
9
votes
3answers
29k views

How to fix EPS with incorrect bounding box?

I want to get a standalone EPS graphic from DVI. This process can be done using the batch file as follows latex %1 dvips -E %1 -o %1.eps And the test file is as follows \documentclass{minimal} \...
6
votes
2answers
4k views

Biblatex: URL-breaking not working in DVI-mode

I'm preparing my bibliography and noticed that biblatex-printbibliography produces Overfull \hbox several times. Examples (gray lines indicates text margins, red line is the physical page margin): ...
10
votes
3answers
25k views

How to fix “Package hyperref Error: Wrong DVI mode driver option `dvips'”?

I'm having this Error when I try to compile my .tex file with xelatex: ! Package hyperref Error: Wrong DVI mode driver option `dvips', (hyperref) because XeTeX is running. See the ...
7
votes
2answers
2k views

Can't get my pdf and .ps files to use type 1 fonts

I am preparing a paper for submission to ACM proceedings and Digital Library. However, I keep getting the "Your pdf and .ps files both use type 3 fonts, you need use type 1 fonts" error from the ...
9
votes
1answer
2k views

PNG figures in black and white

I'm trying to include a png figure and it works when I see it in dvi, but the ps comes in black and white. If I compile directly to pdf there is no problem. However I'm using psTricks for a different ...
12
votes
1answer
886 views

tikzpictures give huge pdf files when processed via dvips and ps2pdf

I have written a paper that includes a couple of TikZ pictures and submitted it to a (Springer) journal. I was quite shocked when I got the pdf file they produced from my source file, since it was ...
5
votes
2answers
4k views

Problems with TexLive 2012 on Ubuntu after network installation

I totally purged TexLive from my system, and then I installed the latest version of TexLive from the internet installer as described here instead of via the Ubuntu package manager. Next, I installed ...
5
votes
1answer
945 views

Searching for a better workflow to get a cropped PDF and EPS graphics - Stage 1

I am using TeX Live 2010. I don't use MikTeX anymore because of many troubles I found in the past. Input files: gridon.tex: % gridon.tex \documentclass{minimal} \usepackage{pstricks} \pagestyle{...
3
votes
2answers
306 views

Output difference between MacTeX 2015 and 2017 with powerdot class

I upgraded MacTeX on my laptop from the 2015 distribution to the basic 2017 distribution. After installing the required packages, I tried to compile one of my slide decks which use the powerdot class, ...
2
votes
1answer
479 views

BreakURL package using DVIPS only works on URL and not DOI

I've prepared my bibliography using biblatex, and my DOI addresses are not breaking their lines properly. I know that using pdflatex will solve this issue, I have to compile my document using latex -> ...
4
votes
1answer
641 views

What kind of “magic” does preview package do to produce a tight paper size?

Actually the following method, that looks like reinventing the wheel, has been discarded once I have known the existence of preview package. % WithoutPreview.tex \documentclass{article} \usepackage{...
9
votes
3answers
1k views

Plain TeX and different hyperlink styles in dvi and pdf

I use the harvmac macros to write papers with plain TeX, and harvmac loads the hyperbasics file to enable hyperlinks. However I can't figure out why the hyperlinks have a different appearance in the ...
3
votes
1answer
572 views

eforms using a LaTeX (custom) font for text fields \textFont

I'm unable to use a LaTeX font (e.g., Augie) for text fields in a PDF form generated with eforms. I'm using MikTeX 2.9 on Windows 10. Acrobat Reader is choosing another font to display in its place (...
6
votes
1answer
372 views

Asymptote with lualatex and otf fonts

Consider the following simple asymptote file: import settings; import three; settings.tex = 'lualatex'; settings.outformat = 'pdf'; texpreamble("\usepackage{luatex85} \usepackage[math-style = TeX]{...
5
votes
1answer
1k views

PDF Layers (OCG) using latex->dvips

I want to generate a ps file with layers. Ocg.sty does not support ps, so I want to write a simple example by myself to see if its possible. I took a pdf version from here and tried to change the ...
3
votes
0answers
509 views

Line breaking with adjustment but no hyphenation

I have the following situation: very long function names that are put into text with a macro \fun{this-is-a-very-long-fuction-name}. This macro includes indexing, but then finally puts the function ...
2
votes
1answer
1k views

TikZ with “remember picture” compiled with pdflatex yields different results compared to dvips -> ps2pdf

The following document \documentclass[11pt,a4paper]{report} \usepackage{tikz} \usetikzlibrary{shapes} \usetikzlibrary{arrows} \usetikzlibrary{positioning} \begin{document} \begin{tikzpicture}[...
1
vote
0answers
70 views

dvipdfmx and dvips do not expand fonts properly with lualatex in DVI mode

dvilualatex with microtype is supposed to support expansion, even in DVI mode. And indeed it seems to work when producing the DVI file. But then the generated file does not actually include expanded ...
0
votes
1answer
1k views

Hyperref links lost when using latex --> dvips --> ps2pdf

Given a latex file using the hyperref package, I wish to convert it to pdf via: latex "foo.tex" dvips "foo.dvi" -z -P Pdf ps2pdf "foo.ps" However, all hyperlinks are lost this way! Here's a ...
4
votes
2answers
1k views

Problem with hyperref and hypdvips

In my table of contents, there are entries that span more than one line. Since I compile with LaTeX -> PS -> PDF, the links created by hyperref are not correctly displayed in the output file (pdf). To ...
4
votes
3answers
2k views

How to replace AUCTeX's “LaTeX” command with latex->dvips->ps2pdf chain?

What is the proper way of solving this problem with respect to AUCTeX's design - I mean, how to do that in a way that it will still recognize the errors, display log on demand, make "View" command ...
4
votes
1answer
219 views

colored box hyperref error for latex->dvips->ps2pdf in tex live 2019

I am using tex live 2019, and I have a problem with hyperref. The error does not happen when I use PDFLaTeX as shown in the first image. However, when I use latex->dvips->ps2pdf, all citations and ...
4
votes
1answer
768 views

Compiling the latex->dvips->ps2pdf with dvips -Ppdf

The documents I create heavily depend on postscripts (I use pstricks quite a lot). I've had some issues with resolution, and it's been recommended to try using dvips -Ppdf. But recently, I've been ...
3
votes
1answer
957 views

hyperref with ocgcolorlinks option & dvips/ps2pdf

In my PDF document, while opened in the PDF viewer (AR), I would like to have coloured text as hyperlinks instead of boxes. So I set the package option ocgcolorlinks with hyperref, because links ...
2
votes
1answer
324 views

Trouble with latex and dvips with an FSTTCS documentclass

Following from my other question Which DVI viewer on linux?, now that I can easily view DVI files I came to the conclusion that the unusual document class I used for my document defines some non-...
2
votes
1answer
437 views

Cropping an image genereated with latex -> dvips and tikzexternalize

The image is not cropped when building it with latex -> dvips. How could I get the resulting image from dvips cropped? \documentclass{article} \usepackage{pgfplots} \pgfplotsset{compat=newest} \...
1
vote
1answer
425 views

Why isn't dvips finding my Type 1 fonts?

I've installed Cygwin on two Windows 7 machines. Both of them have the Adobe basic 35 fonts installed in the system as Type 1 fonts. Yet when I run a file that uses, say, Palatino through dvips, the ...
1
vote
1answer
164 views

Problem with sansmathfonts and dvips

Hoping that this is not off-topic: the MWE \documentclass{article} \usepackage{sansmathfonts} \begin{document} $E=\sqrt{p^2+m^2}$ \end{document} produces a correct pdf output when processed with ...