Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [errors]

{errors} is for questions regarding or including compilation or similar errors.

Filter by
Sorted by
Tagged with
177 votes
2 answers
66k views

Biblatex/biber fails with a strange error about missing recode_data.xml file

I'm trying to use biblatex and when I compile my document I get an error like the following: Windows data source C:\Users\<username>\AppData\Local\Temp\par-5061756c\ cache-...
Alan Munn's user avatar
  • 219k
37 votes
4 answers
44k views

Troubleshooting for biber

I'm trying to switch from BibTeX to biber and ran into the problem that biber does not produce any output file. I noticed several questions about problems with biber e.g., Biblatex/biber does not ...
cryingshadow's user avatar
  • 2,350
130 votes
2 answers
521k views

What does the phrase "Underfull \hbox (badness 10000) in paragraph" actually mean?

What does the actual phrase above mean?
Charles Boehm's user avatar
38 votes
2 answers
38k views

PSTricks error "Undefined control sequence <recently read> \c@lor@to@ps"

I have a problem with this file tex: \begin{document} \begin{figure} \begin{center} \begin{pspicture}(0,0)(1,3.8) \psline{-<}(0,0)(0,.2) \psline{-}(0,.2)(0,.4) \psline{*->}(0,.4)(0,.9) \psline{-...
Lorenzo's user avatar
  • 381
197 votes
6 answers
598k views

Cannot determine size of graphic

I'm trying to include graphics in my Latex-file, which I compiled with latex+dvipdf on OS X. Latex however returns this error: "Cannot determine size of graphic" My graphic is exported from ...
user avatar
108 votes
2 answers
58k views

No room for a new \dimen

I have this error message: ! No room for a new \dimen . \ch@ck ...\else \errmessage {No room for a new #3} \fi which I can not find a cure for.
Zbigniew's user avatar
  • 2,312
31 votes
3 answers
11k views

Error with square bracket in table

\begin{table}[ht] \makebox[\textwidth][c]{ \begin{tabular}{ccccc} \hline \hline [] & [] & [] & [] & []\\ [] & [] & [] & [] & []\\ ...
Benjamin's user avatar
  • 413
28 votes
4 answers
12k views

How to put \verb command inside of \textbf{} block?

It looks like you can't use \verb|...| inside of \textbf{...}. I tried the following: \textbf{Be very careful when using \verb|-i| as it's destructive and it's not reversible!} And got this error: !...
user avatar
50 votes
2 answers
31k views

Package PGF Math Error: Unknown operator `o' or `of'

I am getting a unhelpful error while trying to place a node above another node using the below= syntax. \documentclass{article} \usepackage{tikz} \begin{document} \begin{tikzpicture} \node[] (node1)...
Felix's user avatar
  • 1,302
64 votes
6 answers
14k views

Documents with typical LaTeX errors

I am giving a LaTeX course and have the idea to let the students find and solve problems within a few documents. Basically they shall learn how to create minimal examples and read error messages. ...
Matthias Pospiech's user avatar
17 votes
1 answer
44k views

MiKTeX: Two things did not succeed

I installed a new hard drive on my computer this summer and I'm trying to install MiKTeX on it now. There were no problems when I was using my old hard drive. My OS is Windows 8.1. I'm trying to ...
trb123's user avatar
  • 273
138 votes
13 answers
436k views

inputenc Error: Unicode char \u8: not set up for use with LaTeX

This is with ref to my previous question Package clash in multilingual report. \documentclass[11pt,table,a4paper]{article} \usepackage{lmodern} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \...
Manish's user avatar
  • 1,581
104 votes
7 answers
190k views

Package babel Error: Unknown option `francais'

I recently updated my operating system from Ubuntu 13.04 to Ubuntu 13.10. Since then, I am facing difficulties compiling my TeX code in which the french babel package is called. Please note that all ...
Martingal's user avatar
  • 1,336
110 votes
10 answers
140k views

pdfTeX error (font expansion): auto expansion is only possible with scalable

I'm using a custom class file. My main file looks like this: \documentclass[12pt,a4paper]{thesis} \begin{document} \frontmatter \pagenumbering{alph} \pagenumbering{roman} \clearpage ...
Elmer's user avatar
  • 2,264
95 votes
3 answers
44k views

How to trace LaTeX errors efficiently?

One of the most annoying things about LaTeX is that handling errors can be cumbersome and nerve-racking. In fact, it is the main reason that keeps me from actively recommending LaTeX to most people (...
Christoph's user avatar
  • 2,477
29 votes
3 answers
5k views

Applying a postaction to every path in TikZ

Sometime, for example in a solution to a recent question, one wants to apply a postaction (like a decoration) to a group of paths. A naive solution is to use every path/.style={}. Unfortunately this ...
Caramdir's user avatar
  • 89.4k
99 votes
5 answers
89k views

Too many unprocessed floats

I'm trying to a large number of figures. The code is \begin{figure} \includegraphics[scale=0.5]{m2T4.pdf} \caption{M2T, Problem Size 513} \end{figure} I'm not able to compile, I get the error ! ...
psteelk's user avatar
  • 1,307
30 votes
2 answers
12k views

Error: Counter too large! with \alph{cntr} and cntr>26

I would like to have \alph{counter} for values larger than 26. The following MnWE gives me the error ! LaTeX Error: Counter too large. \documentclass{article} \begin{document} \begin{enumerate} \def\...
yo''s user avatar
  • 51.5k
12 votes
8 answers
61k views

New installation – TeX editor says: "Error: Could not start the command"

I just downloaded and installed Texmaker. I've never used any (La)TeX before. When I click the Run button with an arrow next to "Quick build" I get an error saying "Could not start the command". Why? ...
David's user avatar
  • 123
252 votes
4 answers
605k views

\mathbb{Z} yields undefined control sequence error

I am using WinEdt 6 for compiling my TeX documents. I am getting an error with contains the line $\mathbb{Z}$ showing that it is undefined control sequence. How should I rectify it? Should I include ...
Ramana Venkata's user avatar
242 votes
8 answers
174k views

tlmgr cannot setup TLPDB

I'm trying to update my installation of texlive 2013 under Ubuntu 13.10. However, I followed the instruction on this answer, but I get an error (running on Debian, switching to user mode!) cannot ...
adn's user avatar
  • 11.3k
29 votes
11 answers
85k views

Windows API error 5: "Access is denied" when trying to compile TikZ picture

I installed PGF but are unable to compile the following document: \documentclass[10pt]{article} \usepackage{pgf,tikz} \begin{document} \begin{tikzpicture} \draw (0,0) --(1,2); \end{tikzpicture} \end{...
siyu's user avatar
  • 391
13 votes
1 answer
2k views

Getting xetex to complain when a character is missing

Consider the following minimal document: \documentclass{article} \begin{document} tām आ ṁ \end{document} If you compile it with xelatex se.tex, you get something normal and innocuous, like: This ...
ShreevatsaR's user avatar
  • 45.7k
8 votes
1 answer
1k views

Misplaced \noalign error with \input in a table after the 2020 fall LaTeX release

With the 2020 fall update, the behaviour of \input{} changed. Before, I would have a main latex document (main.tex) and then the table contents in another file (table.tex) . Importantly, the file ...
Max's user avatar
  • 83
281 votes
13 answers
473k views

Package natbib Error: Bibliography not compatible with author-year citations

I have a basic tex file and a bibliography which is exported from Mendeley However, when I want to cite in the author-year style, I get the error: Package natbib Error: Bibliography not compatible ...
grrrbytes's user avatar
  • 3,885
153 votes
6 answers
175k views

Error in TeX Live – Font ... not loadable: Metric (TFM) file not found

I freshly installed 'basic' version of TeX Live 2012 (not full, only basic version). I have following line in my code: \usepackage[T1]{fontenc} I get following error: (/usr/local/texlive/2012/texmf-...
abhinavkulkarni's user avatar
109 votes
5 answers
50k views

"Too many math alphabets" error

I just got the error Too many math alphabets used in version normal. on a document I'm editing. What can I do to fix this, other than stop using an alphabet? All I've found online is instructions ...
Ben Webster's user avatar
  • 1,945
38 votes
1 answer
136k views

Change Language in \usepackage[<language>]{babel}?

I've been trying to change the language of my LaTeX document by replacing \usepackage[swedish]{babel} with \usepackage[english]{babel} but I only get this message: ! Package babel Error: You haven't ...
Djamillah's user avatar
  • 483
162 votes
8 answers
351k views

Error message: There's no line here to end

In a letter-class document that had no previous errors I am suddenly getting the error message: "There's no line here to end" \opening{text} I've used this file many times and today it starts giving ...
Kent's user avatar
  • 2,131
103 votes
10 answers
63k views

\pdfendlink ended up in different nesting level than \pdfstartlink

I started using showkeys in one of my documents and see this error \pdfendlink ended up in different nesting level than \pdfstartlink A bit of google suggests that this "happens when hyperref is ...
Leo Liu's user avatar
  • 5,465
93 votes
1 answer
85k views

What does this warning mean? (fancyhdr and headheight)

My LaTeX file compiles fine. However, in reading my .log file, I see many repeated instances of Package Fancyhdr Warning: \headheight is too small Looking for it in google, I found some 'fixes', but ...
josinalvo's user avatar
  • 1,177
26 votes
3 answers
8k views

\pgfmathsetmacro - dimension too large (biggest value allowed?)

I want to import some data with parameters to parametrize some plots. After importing a table, I assign specific variables of the table to a placeholder by using \pgfplotstablegetelem. And it works ...
kromuchi's user avatar
  • 2,197
17 votes
1 answer
9k views

TeX capacity exceeded (save size)

I am generating a fairly large index of .txt, .tex, and .pdf files. This process has worked for a long time, and the size of the index is not the issue. I have added logic to insert additional links ...
Peter Grill's user avatar
14 votes
1 answer
11k views

Error when using TikZ-Feynman package

Today I downloaded and installed the new TikZ-Feynman package to draw Feynman diagrams. I included the packages \usepackage{tikz} \usepackage{tikz-feynman} \tikzfeynmanset{compat=1.0.0} \...
Thomas's user avatar
  • 435
12 votes
1 answer
6k views

Tikz and ctable incompatibility, gives error when printing

When I print a report I get an error: An error exists on this page. Acrobat may not display the page correctly. Please contact the person who created the PDF document to correct the problem ...
user avatar
58 votes
3 answers
17k views

Is there any way to generate custom errors/warnings in LaTeX?

I want something like \ifmmode\else\GenerateWarning{The command \backslash uzuka is supported only in math mode.}\fi, which is supposed to generate a warning "The command \uzuka is supported only in ...
fiktor's user avatar
  • 1,953
26 votes
4 answers
15k views

pdflatex bash script to supress all output except error messages? [duplicate]

I have a bash script which I use to compile a file with pdflatex twice (to make sure it sorts out references properly, etc.). This is the 'latexbuild' script I use: module load ctan pdflatex --shell-...
Eddy's user avatar
  • 1,885
13 votes
3 answers
5k views

Misplaced \omit. \multispan with \newcommand defined with optional argument

I'm trying to build my own cookbook-style, which has an ingredient makro. Sometimes the ingredients should be separated and have a headline, so I tried with an optional argument. A minimum example ...
causa prima's user avatar
26 votes
4 answers
16k views

Making a new environment combining equation and split

I'm trying to define a new environment that consists of a split environment inside an equation environment. But I'm getting an error. Here's what I'm doing: \documentclass[a4paper,12pt]{article} \...
Malabarba's user avatar
  • 7,012
26 votes
1 answer
3k views

biblatex broken overnight

As late as last week my setup for biblatex worked fine. Going back to the same project today not even a minimal file compiles: \documentclass{article} \usepackage{biblatex} %\addbibresource{...
Florian's user avatar
  • 2,919
25 votes
3 answers
7k views

Uninformative error message when using AUCTeX

I often have this error when using AUCTeX: TeX-error: Error occured after last TeX file closed However, when running for instance pdflatex on the command line, I have a proper error message. But the ...
anol's user avatar
  • 539
20 votes
6 answers
14k views

sharelatex: PDF inclusion: required page does not exist <5>

I checked the other question similar to this issue yet I could not find a proper solution for the issue I am facing for including an .svg file which is converted using inkscape with pdf+latex option ...
user3012914's user avatar
2 votes
1 answer
14k views

Quickest way of applying thesis to tex template

I am trying to apply my thesis to a TeX template. I have pdflatex installed on a Linux box (in my university), but cannot get it to work. When I point to my TeX file as below, it gives an error: ...
user2152812's user avatar
110 votes
8 answers
201k views

Tex capacity exceeded, sorry [input stack size = 5000]

This is the error I am getting since I have added some new references to my .bib file. I think is more than a filled stack. Any ideas? references.bib It was requested a minimum working example but I ...
Chris-Top's user avatar
  • 1,285
47 votes
2 answers
12k views

Cite in theorem environment argument [duplicate]

When I try to cite a book in such a way \begin{theorem}[\cite[p.~90]{bibitem}] Theorem body. \end{theorem} I've got an error because of multiple use of [ and ]. Is it possible to cite in such a way ...
xen's user avatar
  • 705
29 votes
3 answers
46k views

How can I fix the error "GUI framework cannot be initialized" with TeXnicCenter and MiKTeX?

I don't know what I've done, but all of a sudden I am unable to compile any document which uses the geometry package. Minimal (non)-working example: \documentclass[11pt]{article} \usepackage{...
Zev Chonoles's user avatar
  • 5,526
20 votes
2 answers
24k views

tikzpicture "There is no ... in font nullfont", but no extraneous text

While looking at the log file of my document, I see a lot of paired error message lines that look like this (there might be slight inaccuracies, I am typing this on another computer for reasons I won'...
Hammerite's user avatar
  • 3,596
19 votes
5 answers
6k views

Double superscript error involving tilde

When I write {{\tilde{C}}^{0}_{har}}^{\Gamma} (or the same with fewer curly brackets) in Tex I obtain a double superscript error and I can't solve it. Does someone know how to fix this?
iago's user avatar
  • 927
11 votes
1 answer
82k views

MiKTeX can't write on pdf file [closed]

I am using MiKTeX 2.9 on Windows 7. I'm getting the error: "can't write on pdf file." The pdf doesn't reflect what I wrote. What did I do wrong? My input: \documentclass[12pt]{article} \...
user21127's user avatar
  • 111
8 votes
1 answer
3k views

Syntax of Using Math Mode: Empty Lines (Beginner Question)

I'm just starting to learn LaTeX. I tried typing \begin{equation*} (math goes here) \end{equation*} and I got a whole bunch of errors. It seems LaTeX interpreted the empty line as the equation: ...
Luke Davis's user avatar

1
2 3 4 5
21