Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [errors]

{errors} is for questions regarding or including compilation or similar errors.

Filter by
Sorted by
Tagged with
281 votes
13 answers
473k views

Package natbib Error: Bibliography not compatible with author-year citations

I have a basic tex file and a bibliography which is exported from Mendeley However, when I want to cite in the author-year style, I get the error: Package natbib Error: Bibliography not compatible ...
grrrbytes's user avatar
  • 3,885
252 votes
4 answers
605k views

\mathbb{Z} yields undefined control sequence error

I am using WinEdt 6 for compiling my TeX documents. I am getting an error with contains the line $\mathbb{Z}$ showing that it is undefined control sequence. How should I rectify it? Should I include ...
Ramana Venkata's user avatar
242 votes
8 answers
174k views

tlmgr cannot setup TLPDB

I'm trying to update my installation of texlive 2013 under Ubuntu 13.10. However, I followed the instruction on this answer, but I get an error (running on Debian, switching to user mode!) cannot ...
adn's user avatar
  • 11.3k
197 votes
6 answers
598k views

Cannot determine size of graphic

I'm trying to include graphics in my Latex-file, which I compiled with latex+dvipdf on OS X. Latex however returns this error: "Cannot determine size of graphic" My graphic is exported from ...
user avatar
177 votes
2 answers
66k views

Biblatex/biber fails with a strange error about missing recode_data.xml file

I'm trying to use biblatex and when I compile my document I get an error like the following: Windows data source C:\Users\<username>\AppData\Local\Temp\par-5061756c\ cache-...
Alan Munn's user avatar
  • 219k
162 votes
8 answers
351k views

Error message: There's no line here to end

In a letter-class document that had no previous errors I am suddenly getting the error message: "There's no line here to end" \opening{text} I've used this file many times and today it starts giving ...
Kent's user avatar
  • 2,131
153 votes
6 answers
175k views

Error in TeX Live – Font ... not loadable: Metric (TFM) file not found

I freshly installed 'basic' version of TeX Live 2012 (not full, only basic version). I have following line in my code: \usepackage[T1]{fontenc} I get following error: (/usr/local/texlive/2012/texmf-...
abhinavkulkarni's user avatar
138 votes
13 answers
436k views

inputenc Error: Unicode char \u8: not set up for use with LaTeX

This is with ref to my previous question Package clash in multilingual report. \documentclass[11pt,table,a4paper]{article} \usepackage{lmodern} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \...
Manish's user avatar
  • 1,581
130 votes
2 answers
521k views

What does the phrase "Underfull \hbox (badness 10000) in paragraph" actually mean?

What does the actual phrase above mean?
Charles Boehm's user avatar
110 votes
10 answers
140k views

pdfTeX error (font expansion): auto expansion is only possible with scalable

I'm using a custom class file. My main file looks like this: \documentclass[12pt,a4paper]{thesis} \begin{document} \frontmatter \pagenumbering{alph} \pagenumbering{roman} \clearpage ...
Elmer's user avatar
  • 2,264
110 votes
8 answers
201k views

Tex capacity exceeded, sorry [input stack size = 5000]

This is the error I am getting since I have added some new references to my .bib file. I think is more than a filled stack. Any ideas? references.bib It was requested a minimum working example but I ...
Chris-Top's user avatar
  • 1,285
109 votes
5 answers
50k views

"Too many math alphabets" error

I just got the error Too many math alphabets used in version normal. on a document I'm editing. What can I do to fix this, other than stop using an alphabet? All I've found online is instructions ...
Ben Webster's user avatar
  • 1,945
108 votes
2 answers
58k views

No room for a new \dimen

I have this error message: ! No room for a new \dimen . \ch@ck ...\else \errmessage {No room for a new #3} \fi which I can not find a cure for.
Zbigniew's user avatar
  • 2,312
104 votes
7 answers
190k views

Package babel Error: Unknown option `francais'

I recently updated my operating system from Ubuntu 13.04 to Ubuntu 13.10. Since then, I am facing difficulties compiling my TeX code in which the french babel package is called. Please note that all ...
Martingal's user avatar
  • 1,336
103 votes
10 answers
63k views

\pdfendlink ended up in different nesting level than \pdfstartlink

I started using showkeys in one of my documents and see this error \pdfendlink ended up in different nesting level than \pdfstartlink A bit of google suggests that this "happens when hyperref is ...
Leo Liu's user avatar
  • 5,465
100 votes
4 answers
253k views

! LaTeX Error: Not in outer par mode

I am using an image within minipage and getting error message. ! LaTeX Error: Not in outer par mode. Below is minimal working example. \documentclass[11pt,table,a4paper]{article} \usepackage{...
manish's user avatar
  • 9,181
99 votes
5 answers
89k views

Too many unprocessed floats

I'm trying to a large number of figures. The code is \begin{figure} \includegraphics[scale=0.5]{m2T4.pdf} \caption{M2T, Problem Size 513} \end{figure} I'm not able to compile, I get the error ! ...
psteelk's user avatar
  • 1,307
95 votes
3 answers
44k views

How to trace LaTeX errors efficiently?

One of the most annoying things about LaTeX is that handling errors can be cumbersome and nerve-racking. In fact, it is the main reason that keeps me from actively recommending LaTeX to most people (...
Christoph's user avatar
  • 2,477
93 votes
1 answer
85k views

What does this warning mean? (fancyhdr and headheight)

My LaTeX file compiles fine. However, in reading my .log file, I see many repeated instances of Package Fancyhdr Warning: \headheight is too small Looking for it in google, I found some 'fixes', but ...
josinalvo's user avatar
  • 1,177
80 votes
13 answers
72k views

Missing $ inserted issue

Trying to get my dissertation sorted (due in a few hours) and I keep getting this error: ! Missing $ inserted. <inserted text> $ l.190 ... pp. 225--236, 10.1007/978-0-387-68772-...
Jon's user avatar
  • 803
76 votes
4 answers
82k views

MikTeX 2.8 Update Error "Windows API error 87"

I was happily updating packages when the following error appeared: Error: Windows API error 87: The parameter is incorrect. The full update report with this error at the very end is as follows: ...
ptrcao's user avatar
  • 6,623
76 votes
5 answers
234k views

Subfigure: error "Missing number, treated as zero"

\begin{figure} \center \begin{subfigure}[b] \includegraphics[width=60mm]{a} \label{fig:a} \end{subfigure} % \begin{subfigure}[b] \includegraphics[width=60mm]{b}...
Pavasaris's user avatar
  • 2,971
66 votes
3 answers
30k views

(error) \tightlist (converting .md file into .pdf using pandoc)

I was converting 'lecture1.md' file I made via Rstudio into 'lecture1.pdf' using Pandoc at Mac Terminal. and I got this error message : ! Undefined control sequence. <recently read> \tightlist ...
inmybrain's user avatar
  • 772
65 votes
6 answers
21k views

How to obtain verbatim text in a footnote?

I want to employ a \verb command in a footnote. But, when I run pdflatex on \documentclass{article} \begin{document} I want this.\footnote{\verb|But, it does not work!|} \end{document} I get this:...
vanden's user avatar
  • 31.2k
64 votes
6 answers
14k views

Documents with typical LaTeX errors

I am giving a LaTeX course and have the idea to let the students find and solve problems within a few documents. Basically they shall learn how to create minimal examples and read error messages. ...
Matthias Pospiech's user avatar
63 votes
8 answers
60k views

How to find the lost text part when having "Float(s) lost" error

I've lost some text. I don't know if theres something missing, so how can I find it? I'm not in the mood to compare the chapter1.tex to the pdf file by reading both. Chapter 1 (chapter1.tex) is rather ...
helt's user avatar
  • 855
63 votes
6 answers
13k views

Shortest code causing "Emergency stop." error

This question is purely academic. TeXing a file containing \valign{\halign#\cr! causes an ! Emergency stop. error. Is that the shortest code which produces a fatal error in TeX?
Bruno Le Floch's user avatar
62 votes
3 answers
30k views

How to overcome Acrobat Reader error 131 with a pdfLaTeX doc?

I'm generating a PDF document with pdflatex (more precisely, latexmk invoked from TexMaker 3.4. My LaTeX install is TeXLive 20120719). I can read the document fine in Okular and Gmail's attachment ...
Luis E.'s user avatar
  • 983
61 votes
3 answers
8k views

$327.68 Knuth reward check

I know something about $327.68 Knuth reward check. However, I cannot find a comprehensive list of people rewarded for finding errors in TeX. I do know, that among them is Bogusław Jackowski (Twice, ...
Przemysław Scherwentke's user avatar
61 votes
1 answer
10k views

Using TikZ inside a figure caption

I have a PNG plot with a couple of black patches in it, and I'd like to refer to it in the \caption of the figure. According to the TikZ manual, I'd have to \tikz \fill[black] (1ex,1ex) circle (1ex); ...
Nico Schlömer's user avatar
60 votes
1 answer
56k views

Undefined control sequence \url error

I got this error while trying to run the latex command: ! Undefined control sequence. l.10 \newblock Available from: \url {http://www.google.com}. ? Why is it an ...
Mika H.'s user avatar
  • 3,481
58 votes
3 answers
17k views

Is there any way to generate custom errors/warnings in LaTeX?

I want something like \ifmmode\else\GenerateWarning{The command \backslash uzuka is supported only in math mode.}\fi, which is supposed to generate a warning "The command \uzuka is supported only in ...
fiktor's user avatar
  • 1,953
56 votes
1 answer
447k views

Writing multiplication dots

I try to write a multiplication dot and use \cdot, 4 = 2\cdot{2}. But I get the error message Missing $ inserted. What have I forgotten?
user30523's user avatar
  • 1,013
55 votes
2 answers
105k views

I get the warning "Undefined control sequence" with \mathbb

I am doing my first LaTeX work using TeXstudios and I'm having trouble with an Undefined control sequence. When I've checked solutions on google it appears as this is caused by typos in the ...
Cenderze's user avatar
  • 731
54 votes
2 answers
97k views

How to use algorithmicx package?

I found the algorithmicx package on this page, and tried to compile this example from the pdf file. \documentclass{article} \usepackage{algorithmicx} \begin{document} \begin{algorithm} \caption{...
prosseek's user avatar
  • 6,043
54 votes
8 answers
239k views

Texmaker (Windows version) - first use - Error: Log file not found!

This is my first time using a LaTeX editor. I installed Texmaker allowing it to use the default directory on the C drive. Software Versions Windows: 7 Ultimate 64-bit Texmaker 3.4.1 for Windows ...
Guy Coder's user avatar
  • 653
53 votes
3 answers
53k views

Unknown graphics extension: .1.png

I have a file called xxxx_0.1.png, and want to import it as an image in my document. I am using graphicx with the following command: \includegraphics[width=0.5\textwidth]{images/xxxx_0.1.png} and ...
user avatar
52 votes
3 answers
551k views

What is causing undefined control sequence?

I'm getting this error: ! Undefined control sequence. l.64 ...p(- \frac{E_j - E_i}{k_B T}) & \quad \text {: E_j > E_i}\\ ? ! Undefined ...
AncientSwordRage's user avatar
50 votes
2 answers
31k views

Package PGF Math Error: Unknown operator `o' or `of'

I am getting a unhelpful error while trying to place a node above another node using the below= syntax. \documentclass{article} \usepackage{tikz} \begin{document} \begin{tikzpicture} \node[] (node1)...
Felix's user avatar
  • 1,302
50 votes
3 answers
119k views

Is there really no better solution to "Overfull \hbox" than adding a line break?

I am going through a rather long book to resolve the Overfull \hbox problem. Here is an example: varies greatly from organization to organization, team to team, and manager to manager. Innovation is ...
AgilePro's user avatar
  • 1,326
49 votes
7 answers
57k views

! Package inputenc Error: Unicode char ́ (U+301)(inputenc)

I get this error message, during compiling my .tex-document. line 234 - ! Package inputenc Error: Unicode char ́ (U+301)(inputenc) not set up for use with LaTeX.See the inputenc package documentation ...
Marius Knapp's user avatar
49 votes
2 answers
7k views

Teach me to debug

Ok, 35 years of programming has not prepared me to debug tex errors. It's painful. I can't create an MWE because the point is to be able to debug in place. Everything was working well, I would ...
Dov's user avatar
  • 1,511
47 votes
2 answers
12k views

Cite in theorem environment argument [duplicate]

When I try to cite a book in such a way \begin{theorem}[\cite[p.~90]{bibitem}] Theorem body. \end{theorem} I've got an error because of multiple use of [ and ]. Is it possible to cite in such a way ...
xen's user avatar
  • 705
46 votes
3 answers
19k views

How to disable the prompt on error?

When pdflatex can't compile a file, it drops me to a prompt. I've never used it and always try to get away from there as quickly as possible, usually generating a q.log file in the process. Is there ...
Tim N's user avatar
  • 10.2k
45 votes
6 answers
171k views

"Misplaced alignment tab character &" error when citing a particular entry

I've been getting the error: 'Misplaced alignment tab character & ...' even in sentences where the &-character is not used. It says it in sentences where I am citing. \documentclass{article} \...
Rob's user avatar
  • 471
43 votes
2 answers
2k views

Static analysis of LaTeX documents?

For programming languages like C, C++, C#, Java and so on there always exist some kind of static analysers, tools that check the sourcecode for unreachable code, unused variables, memory leaks and ...
Foo Bar's user avatar
  • 13.3k
41 votes
3 answers
66k views

LaTeX Error: File `scrpage2.sty' not found

Can someone explain how to solve this problem: LaTeX Error: File `scrpage2.sty' not found? I read all the answers but didn't understand what to do. Today I install miktex 2.9 and winedt 10.3.
Silva's user avatar
  • 511
41 votes
4 answers
3k views

TeX Live Manager crashes with "Unknown docfile tag"

Today my TeX Live 2013 stopped updating packages. I use tlmgr to update packages but it's crashing with the following error: $ sudo tlmgr update Unknown docfile tag: texmf-dist/doc/latex/pythontex/...
seeberg's user avatar
  • 521
40 votes
3 answers
51k views

Compiler gives hundreds of "invalid character" suddenly

I am writing my latex document in TexMaker and suddenly in one of the thousands of compilations I make there is a error and I cant get rid of it. The error is: ! Text line contains an invalid ...
Ander Biguri's user avatar
  • 1,837
39 votes
2 answers
78k views

Environment align undefined line 11, all I can see to do is to retype the line and it still isn't working

\documentclass [12pt]{article} \oddsidemargin=0pt \topmargin=0pt \textwidth=6.5in \textheight=8.5in \begin{document} \begin{center} {\large\bf\LaTeX\ Example 8} \end{center} Sometimes we have to ...
Britney Wiggins's user avatar

1
2 3 4 5
108