Skip to main content

Questions tagged [kpathsea]

kpathsea is the path searching library for texlive

Filter by
Sorted by
Tagged with
3 votes
1 answer
56 views

Apparently \IfFileExists not working with otf?

Using TeXlive 2023, Linux, lualatex. To my surprise, \IfFileExists does not seem to find any *.otf file, regardless of whether the file is installed into texmf-dist or my texmf home directory. MWE: % !...
user avatar
0 votes
0 answers
44 views

how to set alternative pk fonts destination on texlive

By default, TeXLive places metafont generated bitmap fonts in $TEXMFHOME: how do I change that to, say, $TEXMFVAR, without changing the whole $TEXMFHOME settings? Besides, I believe this change won't ...
jarnosz's user avatar
  • 4,346
0 votes
1 answer
35 views

warning: kpsewhich: Ignoring unknown file type `ttf'

when I using the kpsewhich to find the system font like this: /app # kpsewhich --format="ttf" Kaiti.ttf warning: kpsewhich: Ignoring unknown file type `ttf'. is it possible to use kpsewhich ...
Dolphin's user avatar
  • 895
3 votes
2 answers
348 views

What is kpsetool, kpsexpand, and kpsepath?

When trying to manage my on LaTeX distribution, I frequently come across the commands kpsetool, kpsexpand, and kpsepath. They seem to have a similar purpose. What is it?
Rubem Pacelli's user avatar
0 votes
1 answer
191 views

Re-configuring Latex path after switching from distribution-provided Texlive to native Texlive

I run an Arch system and used the Texlive-distribution provided by the distribution package manager. However, now I encountered a bug and decided to switch to a native Texlive installation, which I ...
Alexander Praehauser's user avatar
2 votes
0 answers
292 views

TEXINPUTS, TEXMF and other variables

While investigating some things about TeX, I stumbled across TEXINPUTS, which one can use to tell (La/pdf/..?)TeX where to find it's files. I decided to look into it a bit closer and learned about ...
Marc Miller's user avatar
0 votes
0 answers
116 views

Non-free-font (garamondx) is not being rendered anymore after upgrade to macOS 13

I have been creating PDFs with garamondx for a while without a problem on my Mac with M1 chip. After upgrading to macOS 13 (Ventura) garamondx as a non-free font cannot be rendered anymore. The error ...
Daniel Aldus's user avatar
0 votes
1 answer
131 views

How can I make dvisvgm calling kpathsea find the texmf.cnf file in a nonstandard directory?

dvisvgm calling kpathsea cannot find the texmf.cnf file, but this does exist, though at a presumably nonstandard directory location. What to do to let the texmf.cnf file be located? To convert a .dvi ...
zylitoL's user avatar
  • 149
1 vote
0 answers
328 views

Fonts not found

As I told in a previous question, I'm migrating from Scientific Linux 6.2 to Slackware Linux 15.0. I anticipated some problems but there are some I'm unable to solve myself. My present question ...
Elio Fabri's user avatar
0 votes
1 answer
182 views

Problems after installing TexLive in a non-standard location (and how to uninstall it)

Background My main goal is to compile my thesis in latex under POP-OS 22.04. (I used to use Miktex on Windows or Ubuntu). Now I have installed TexLive in a non-standard location (passing --texdir=/...
Maverick's user avatar
  • 313
1 vote
0 answers
527 views

Tex Live Updater suddenly broke

I have used Tex Live GUI to update packages. Suddenly it does not work. When I run TLShell TeX Live Manager, I get the following message: C:/texlive/2022 warning: kpathsea: c:/texlive/texmf-local/ls-r:...
quis1938's user avatar
0 votes
0 answers
55 views

EPS inclusion from texmf-tree not working

Introduction I have a project-specific texmf tree, which I use for package development, which is called texmf-project. This tree is correctly registered as an auxtree in texlive on debian 11. In my ...
marc's user avatar
  • 701
0 votes
1 answer
339 views

kpsewhich doesn't find package but should be as indicated by debug output

currently I'm experimenting a bit with installing packages manually (not prepackaged from the repositories (I'm under Linux)). I use tllocalmgr (see this wiki post here and this package here), but I ...
atticus's user avatar
  • 587
1 vote
1 answer
414 views

Extending the OSFONTDIR environment variable on Win 10 to include user fonts

I am trying to use some fonts I have installed as a user on Windows 10, but XeLaTeX cannot find them. The fonts have been installed in C:\Users\<My User>\AppData\Local\Microsoft\Windows\Fonts. ...
AkaAkane's user avatar
  • 153
1 vote
0 answers
86 views

How do I tell pdflatex where to find a .600pk file

I have a letter template areletter.tex file, which loads a style file called areletter.cls. My template requires a seal in order for the letterhead to compile. The seal file is ucseal60.600pk and ...
Leo Simon's user avatar
  • 2,209
1 vote
1 answer
134 views

Font problem, TEXMFHOME

I have a brand new TeXLive vanilla installation on my Debian system. Before installing it I had removed all Debian TeX packages. The texmf.cnfin the installation only contains comments, I did not ...
Nobody-Knows-I-am-a-Dog's user avatar
1 vote
0 answers
753 views

TeX Live cant find packages that were installed via tlmgr

Sorry if this has already been answered but I couldn't find a solution that works. I'm on arch Linux and after a long and painful install of texlive, I managed to download packages with tlmgr. To give ...
Joshua A's user avatar
0 votes
1 answer
298 views

Which environment variables are needed for kpsewhich to discover *.ini files?

I'm trying to use --custom-bin switch of install-tl. I've moved the TexLive's kpsewhich to my custom_bin directory. But kpsewhich fails to discover *.ini files and *.cnf files (kpsewhich -progname=...
Vadim Kantorov's user avatar
2 votes
2 answers
101 views

TeX Live ignores TEXINPUTS, maybe kpathsea problem

for a long time my TeX files imported the file ~/lib/tex/mylib.tex, using the assignment TEXINPUTS=".:~/lib/tex:" and referencing this file with \input{mylib}. after changing from Suse linux ...
TeX4fun's user avatar
  • 41
4 votes
2 answers
718 views

Avoiding kpathsea: Running mktexpk

I'm running pandoc in a docker container based on the FROM pandoc/ubuntu-latex image, and it's working fine. However, each time it runs, I get the kpathsea: Running mktexpk ... step which seems to ...
Fuhrmanator's user avatar
1 vote
0 answers
46 views

bootstrapping a kpathsea-like package -- finding TEXMF roots

I am in the process of writing a Go-based TeX engine. (it's working well and I should have a first version based off the tex.web -> Pascal -> Go pipeline (with DVI output) ready shortly. TRIP ...
sbinet's user avatar
  • 41
1 vote
2 answers
753 views

Access and use $HOME environment for setting the path for a new font

I want to use a font I just downloaded for a document class I created. This document class will be used on other workstations so I would like the path of the font not to be "hardcoded" but ...
Victoria's user avatar
0 votes
0 answers
30 views

Finding XML files with kpsewhich

What is the right way to store XML or DTD files in a texmf tree and to configure my system so that kpsewhich will be able to find them? Running kpsewhich -help-formats shows nothing about xml files, ...
Vincent Beffara's user avatar
0 votes
0 answers
147 views

What use-cases show the consequentiality of MiKTeX's not using Kpathsea?

Unlike texlive, MiKTeX does not use Kpathsea. From a user perspective, it seems to me this makes the choice between MiKTeX and texlive (and other Web2C implementations of TeX and friends) far more ...
Danny Quah's user avatar
1 vote
1 answer
438 views

Error running (foo)tex on Linux: "undefined symbol: kpathsea_cnf_line_env_progname"

G'day, I have just installed tex on a fresh install of Fedora 32 via the command: dnf install texlive I prefer to manage my tex installation via dnf, and have had success with this command on ...
Stephen Searle's user avatar
3 votes
1 answer
5k views

Missing dll's for Texmaker/Miktex - The code execution cannot proceed

I have Texmaker and MiKTeX installed. I downloaded all available MiKTeX packages. When building the doc in Texmaker, I get: The code execution cannot proceed because MikTeX200629-png.dll / ...
Daniel von Eschwege's user avatar
1 vote
1 answer
199 views

kpathsea-warning when using filenames containing $&?

The MWE, test.tex: \documentclass{article} \begin{filecontents*}{A$&1file.tex} Hello, World! \end{filecontents*} \begin{document} \input{A$&1file.tex} \end{document} The MWE does not ...
Ulrich Diez's user avatar
  • 29.8k
0 votes
0 answers
202 views

Cant get own style document to work on ubuntu in devops with texlive

I am trying to setup a pipeline in DevOps using a Linux distribution to build LaTeX documents using texlive. I got the texlive installed and has also confirmed that it is working. However, my latex ...
evilfish's user avatar
  • 101
0 votes
0 answers
67 views

Latex cannot find my Beamer sty file [duplicate]

On Linux, I've downloaded the "diepen" Beamer theme to my ~/texmf folder. I've run texhash ~/texmf, which happily creates an ls-R file containing this: % ls-R -- filename database for kpathsea; do ...
oz1cz's user avatar
  • 1,606
1 vote
1 answer
581 views

Why won't TEXINPUTS work?! (And how do I fix it?)

This is frustrating me to no end. I'm trying to use TEXINPUTS to look inside a parent directory (I don't know how else to). It refuses to do so no matter what I do. A minimal example to illustrate the ...
user541686's user avatar
  • 9,727
38 votes
2 answers
8k views

What does kpsewhich stand for?

I often have trouble remembering the name of the kpsewhich command. Maybe it would be easier for me to remember it, if I understand where the name come from, so the question is: What does the kpse ...
muxoveji's user avatar
  • 649
3 votes
0 answers
488 views

Set a relative search path for fontspec within a package (.sty file)

I have a small .sty file for beamer, where I need to specify a particular title font (that's a TTF file). I can do this thus: \RequirePackage{fontspec} \newfontfamily{\WellcomeBold}[Path=fonts/]{...
mcv21's user avatar
  • 43
0 votes
1 answer
323 views

How to disable `mktexpk` in `dvips`?

Consider this ex-14-5.mf: mode:=ljfour; % 600dpi for dvips (you must run "gftopk") mode_setup; beginchar("e",10pt#,7.5pt#,2.5pt#); pickup pencircle scaled (.4pt+blacker); draw ...
Igor Liferenko's user avatar
0 votes
3 answers
375 views

How to use "Kpathsea" to open a sty file for users modifications

I have a package to create exam paper sujet.sty, in this package I have defined some commands like school which expand to the name of school. \def\school{name-of-school} I thought about using a ...
Salim Bou's user avatar
  • 17.1k
2 votes
2 answers
1k views

\input@path and load path priority?

I have a project structure . ├── includes │   ├── apxproof.sty │   └── somecustommodule.sty └── tex └── document.tex including a bugfix version of apxproof.sty and setting \input@path in ...
kdb's user avatar
  • 1,929
1 vote
1 answer
708 views

pdflatex cannot find file but kpsewhich does

I have a header.tex file sitting in $TEXMFHOME/tex/latex/ and I tried using \input in another .tex file in some other directory. Note that kpsewhich is able to find header.tex, printing its full path, ...
Japorized's user avatar
  • 158
13 votes
2 answers
760 views

How to check from LaTeX whether a pfb file exists?

I need to write a tex file which checks whether certain files can be found by kpathsea library. It is easy to check whether a sty or an `fd file can be found: \IfFileExists{hyperref.sty}{Hyperref ...
Boris's user avatar
  • 38.3k
6 votes
1 answer
788 views

Where do I place my own .sty or .cls files, to make them available to all my .tex files? - empowerment (kpathsea basics)

In order to have a non-TeXlive .sty file available, I followed the recommendations of this question : Where do I place my own .sty or .cls files, to make them available to all my .tex files?. I did ...
user1771398's user avatar
3 votes
1 answer
761 views

How can I use a central .bib-file for alle my LaTeX documents which is shared between Mac and Windows?

I already know how to use a central .bib-file on my Mac or on Windows. I just use the absolute path to the file (which I can store in a Dropbox folder). On my Mac I use for example something like this:...
Philipp L.'s user avatar
1 vote
2 answers
407 views

maxidiagram found by kpsewhich, but not pdflatex

I'm trying to \usepackage{MaxiDiagram} on Arch Linux, but pdflatex complains: ! LaTeX Error: File `MaxiDiagram.sty' not found. Running kpsewhich MaxiDiagram reports that the file exists at /usr/...
nishantjr's user avatar
  • 111
5 votes
1 answer
650 views

change default metafont's mode/resolution (as when called directly from pdflatex)

When I use a metafont font, pdflatex calls mf to generate the pk font files. I would like to change the resolution at which the pk files are created. If I'm correct, the call stack is: pdflatex → ...
Matteo Gamboz's user avatar
4 votes
2 answers
2k views

TeXlive 2016 error with literat (Literaturnaya) font

It is so strange that no questions on the whole website are dedicated to the Literaturnaya font (despite its frequent use in Russian documents 10 years ago or so), and only two questions reference it! ...
Andreï V. Kostyrka's user avatar
8 votes
2 answers
5k views

How do I load a texlive font with fontspec?

This is a XeLaTeX question. It seems really silly to ask after many years of using fontspec and XeLaTeX. I suppose I have always found a workaround. This time, I'd like a definitive answer. ...
Jonathan Komar's user avatar
2 votes
0 answers
264 views

How does LaTeX resolve path to .sty files?

I use TeX Live (on a Debian system), and I'm having a new issue with style files. For many years, I've used a style file I've written called handout.sty; it's in my ~/texmf/tex directory, and I've ...
Janet's user avatar
  • 421
3 votes
1 answer
3k views

Why does kpsewhich fail to find this file?

I'm trying to compile a file with context, and I get an error: I couldn't open style file cont-no.bst ---line 2 of file dissertation.aux : \bibstyle{cont-no : } I thought I would ...
Twey's user avatar
  • 133
2 votes
1 answer
590 views

mktextfm fails when pdflatex is invoked by cgi-bin script under www-data (apache)

I'm starting pdflatex from a shell-script invoked as cgi-bin application on Ubuntu (running under default www-data user) and from time to time I have the following kind of error preventing compiling: ...
Ilya V. Schurov's user avatar
2 votes
0 answers
315 views

Symbolic link in ~/texmf mystery [closed]

I have TeX Live 2013 installed on Ubuntu 14.04 with kpathsea and I have a rather curious situation. I created a new beamer theme that I work on at ~/code/git/beamer/mytheme and then I created a ...
bibliolytic's user avatar
0 votes
0 answers
181 views

Fonts not found in local .texmf-var but thy are in /usr/share

I'm having trouble using Droid Sans, and other fonts from the LaTeX font catalogue. Using the following MWE: \documentclass[]{article} \usepackage[defaultsans]{droidsans} \renewcommand*\...
Supernormal's user avatar
1 vote
1 answer
568 views

Latex doesn't recognize cntformats.sty [duplicate]

I downloaded manually cntformats.sty and put it in the directory exsheets. But Latex still doesn't recognize it and asks if I want to download it. I tried several times to download it by changing the ...
Rafiq's user avatar
  • 255
10 votes
1 answer
316 views

How to incorporate a TEXMF tree managed by distro's package manager when using TeX Live from upstream on a GNU/Linux system?

I am using upstream's TeX Live on a GNU/Linux system with default paths except for the use of symbolic links to facilitate switching between different versions of TL. So, for example, TEXMFMAIN is /...
cfr's user avatar
  • 208k