Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [listingsutf8]

The tag has no usage guidance.

2
votes
1answer
75 views

How to avoid problems with diacritics once and for all

I work with Rnw, and I type in Catalan, so there are diacritics I wouldn't encounter in English. I just want two things: That when I compile my PDF, all diacritic letters are as they should be. That ...
1
vote
0answers
43 views

Create custom Lists i.e. Abbreviations and add these to the TOC

I'm currently encountering the problem that, I need to create Lists of Abbreviatings and Code Listings ( yes Listings List is in Lyx, but it wont compile if I add it ). Is there a possibility to ...
0
votes
1answer
105 views

How to properly use UTF8 with latexdemo package

I want to have Umlauts in a latexdemo environment. MWE: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{textcomp} \usepackage{latexdemo} \begin{document} \begin{filecontents*}{\...
0
votes
1answer
149 views

How to put cloud message on Code Listings fragment on LaTeX

I make a presentation 'beamer' with several slides of code using 'Code Listings', I would like to put cloud messages in some reserved words of the code for its explanation. I have searched and I have ...
1
vote
0answers
399 views

Problem with utf8 and \maketitle [closed]

I have the following master document: \documentclass[tesi,english]{editorialupv} \input{preambulo} \bibliography{referencias} \graphicspath{ {../figuras/} {../logos/} {./figuras/} {./...
4
votes
1answer
114 views

Listings: hide some code (first encoding line)

In this code, I would like automatic hide the first line (in my complete example, the code is inserted from an external file). A solution is to use firstline=2, but then it will hide the first even ...
2
votes
1answer
95 views

Encoding problem AFTER using listings

I'm trying to insert some code in a document, and I'm using the package listings for that. I'm well aware that inserting special utf8 characters requires some precautions that can be set with \lstset ...
1
vote
1answer
2k views

List of Currency Symbols in Listings

I'm getting unicode errors when using currency symbols in a listing environment. I tried to add \usepackage{textcomp} but then I'm getting other (bibtex) errors. So maybe there is a cleaner option? \...
1
vote
1answer
418 views

How to use non ASCII chars

How to compile a tex file with this kind of chars (note that they have the same width): ██╗███████╗█ I tried to find about non ASCII chars but no success (I found no related with this chars).
0
votes
1answer
224 views

Char encoding problem in listlisting

I would like to use listlisting and post commented source code in french. This is the complete document : \documentclass{article} \usepackage{listings,xcolor} %% Langage et police utilisée \...
2
votes
1answer
113 views

Getting listings style to show Spanish accents like these: É é

So I'm trying to include a Literate Haskell (.lhs) code into my Latex thesis, but I'm having some trouble with the encoding of the listings style. This is how my test.lhs files looks like, which I ...
2
votes
0answers
726 views

Swedish letters ÅÄÖ do not show using listings package

Problem I am using the listings package to produce HTML-code and everything works except that the letters åäö do not format in accordance to the defined colors. Minimal Working Example \...
2
votes
1answer
123 views

Suppress BOM in HTML output of UTF-8 listings

I include some listings into my LaTeX code using \lstinputlisting[inputencoding=utf8/latin1]{listing.txt} The listings are taken from files which are encoded using UTF-8 (with BOM). The LaTeX file ...
3
votes
1answer
566 views

How to use the section sign § as a comment delimiter in listings?

I tried to define a custom language in listingsutf8 (The file's inputenc is utf8), which uses the section sign § as comment delimiter. I defined the language like this (I'll only paste the important ...
4
votes
2answers
575 views

An error appears saying that utf8 and listing are not compatible

If I compile the next code the following error appear. ! Package inputenc Error: Unicode char \u8:�\expandafter\lst@FillFixed@\fi not set up for use with LaTeX. See the inputenc package ...
1
vote
0answers
106 views

If I use listing package, I cannot use listing environments, how could I use both? [closed]

If I use listing package, I cannot use listing environments. How could I use both? In the next code Im using UTF8 and listing, but an error appears. This is my code: \documentclass{article} \...
5
votes
2answers
525 views

Only one specific character missing when compiling with biber and xelatex

I'm having trouble showing proper reference list - one letter just does not appear. I googled possible solutions, and updated the fonts, packages, but still can't resolve this. Here's MWE: \...
0
votes
1answer
301 views

Encoding Issue while Export from JabRef to .CSV [closed]

I am trying to export bib to .csv and there are many issues being faced but most important is encoding: special symbols are not converted properly to the same symbols e.g. " " changing to different ...
1
vote
2answers
1k views

listingsutf8's option inputencoding=utf8/latin1 leads to latin1.def to be read each time a listing is used

Edit: inputencoding=latin1 option initially written should have been inputencoding=utf8/latin1 If the listingsutf8's option inputencoding=utf8/latin1 leads to latin1.def file to be read each time a ...
0
votes
0answers
35 views

How to get Unicode in code listings? [duplicate]

I want to use Unicode text (a mixture of cyrillic and japanese characters) in a code listing that uses default LaTeX fonts (in other words, source code fonts are left to default). However, for all non-...
4
votes
1answer
550 views

How to have free accents in `lstlisting`

There are quiet some questions about getting accents like è into the lstlisting environment. But I actually want to have a free floating accent. However, Latex always changes it to some other symbol ...
4
votes
1answer
844 views

Getting Swedish letters to work in LaTex

Problem: Issue 1 (solved): The Swedish letters ÅÄÖ/åäö do not print out correctly when used with listings package. Issue 2: How can it be solved so that the Swedish letters also get orange color like ...
0
votes
0answers
61 views

beamerarticle and minor problems with caption

I have a major and some minor problems with the MWE below. The major one: when I uncomment \usepackage{beamerarticle}, my macro definition starts to contain some extra '}', probably some macro ...
4
votes
0answers
196 views

listingsutf8 in XeLaTeX [duplicate]

In order to cope with utf8 listing files, I want to use listingsutf8. However on XeLaTeX i receive the warning: Package listingsutf8 Warning: Package loading is aborted because of missing \pdf@...
1
vote
1answer
201 views

AUCTeX error with utf8 package recognizing “ \%CW”

I'm in AUCTeX in a 32-bit Win7 machine. When compiling the master file with pdflatex I'm getting the error msg given below. Can you help me understand the error and correct it? ERROR: Package ...
2
votes
1answer
766 views

Reading code from external file in tcolorbox and getting pdflatex> ! paragraph ended before \tcb@set@label was complete

I want to read code from external file in tcolorbox in new defined \texexptitled environment but could not succeeded (See MWE). Without this my MWE also throws two other errors pdflatex> ! ...
4
votes
1answer
678 views

listings using tcolorbox for beamer documentclass

I'm trying to get listings using tcolorbox for beamer documentclass. My MWE is given below but could not get it working. Any help will be highly appreciated. Thanks MWE \documentclass{article} \...
3
votes
1answer
311 views

listings using tcolorbox package without Chapter and Section environment effects

I want to get listings using tcolorbox package but without counting Chapter and Section environments. See in MWE, I used section environment withing listings which effects the counter for following ...
1
vote
1answer
2k views

lstlisting environment with UTF-8 encoding [duplicate]

I have a problem using lstlisting environment with utf8 encoding. I got this error Package inputenc Error: Unicode char \u8:�\expandafter not set up for use wit MWE \documentclass{article} \...
1
vote
1answer
162 views

LaTeX: utf8 and \phantom

I'm sorry if this is already answered, but I'm way out of my league. I'm using a custom style package and it uses \phantom to keep stuff(like the toc) of the title page, but for other reasons I need ...
1
vote
0answers
130 views

how to insert comment in lstlisting [duplicate]

I have a problem with inserting a comment in lstlisting environment. LaTeX says: ! Package inputenc Error: Unicode char \u8:�\expandafter not set up for use with LaTeX. See the inputenc ...
1
vote
1answer
145 views

Index sorting problem with Vietnamese

I use Texmker 4.1 and Texlive 2013 in my Xubuntu. I use this system to write my teacher's book with the AMS package (gsm in fact), which is in Vietnamese. There is a problem in sorting the index, it ...
2
votes
1answer
516 views

Easylist failure with utf8 characters

When trying to compile the following example document: \documentclass[a4paper,12pt]{article} \usepackage[utf8]{inputenc} \usepackage[swedish]{babel} \usepackage[ampersand]{easylist} \begin{document} ...
5
votes
1answer
667 views

How to make listings display characters special characters

I am trying to show a directory structure of a tree using the listings package like so: ├── controllers │   ├── application_controller.rb what I get looks like this: controllers ...
4
votes
1answer
659 views

How to print HTML entities in Latex using pdflatex

I've string of HTML entities containing characters in devnagri font. Sample HTML Entity String is : <h1>&#2311;&#2344;&#2346;&#2369;&#2335; &#2360;&#2366;&#2343;...
13
votes
1answer
3k views

UTF8 for listings

With German umlauts I have to define these characters (Typesetting UTF8 listings with German Umlaute) and the following MWE is working: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[...