Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [tlmgr]

The tag has no usage guidance.

0
votes
1answer
17 views

How to install executable latex using tlmgr?

OS: Ubuntu 18 If one decides to use install-tl to install only the most minimal scheme , then how can one install the executable latex ? Apparently doing tlmgr install latex is not enough, because ...
0
votes
1answer
21 views

pdflatex not seeing tlmgr packages

I have a feeling that the version of pdflatex that I'm using is not seeing the packages installed by tlmgr, though it might also be that tlmgr is not installing packages correctly. I don't know how to ...
0
votes
0answers
32 views

Unable to connect via tlmgr

Recently, when I want to use tlmgr, I get the following connection error. C:\Windows\system32>tlmgr install tablefootnotes No connection to the internet. Unable to download the checksum of the ...
1
vote
0answers
41 views

tlmgr: Remote repository is newer than local (2017 < 2018), No it is not

Ok, one more regarding this apparently pervasive issue with tlmgr and Texlive and Linux and .... sigh. So, I installed texlive on Ubuntu 18.04. So far so good. Attempted to compile an article, I get: ...
0
votes
0answers
38 views

texliveonfly preamble.sty not found

I'm trying to use texliveonfly to automatically install my dependencies. However, most of the packages I used are located in a preamble.sty file which is in the same folder as the main.tex file for my ...
1
vote
2answers
78 views

Virtual environment as in python

I've read this question about doing what I'm asking, however for it to work, one needs to have texlive preinstalled (or texlive-base). I was searching for a way to be totally (or nearly) independant ...
0
votes
0answers
92 views

Just installed texlive-full and it is outdated

I just did sudo apt install texlive-full Now I am running into some trouble getting packages to work. I encountered this error: tlmgr: Remote repository is newer than local (2017 < 2018) see ...
1
vote
0answers
91 views

tlmgr update --self fails with a weird error message (Windows 10)

I have TL2018 on windows 10. When trying to update packages with tlmgr, it said that tlmgr itself needs to be updated. However, the command tlmgr update --self failed for me with the following error ...
0
votes
0answers
21 views

PerlTk with MacTex BasicTeX

I have the BasicTex version of MacTeX installed on my machine. I would like to use the gui for tlmgr, but when I try to run it, I'm informed I need perl/tk. After some Internet searching it seems like ...
0
votes
1answer
76 views

tlmgr shows wrong package installation status

I am using a portable XeTeX installation installed via TexLive parallel with a normal PdfLaTeX installation. I do not want to mix them up. I wanted to install some more packages for XeTeX which did ...
0
votes
0answers
90 views

reinstall all packages with missing in TeX Live

Let's suppose that tlmgr check files shows that some files are missing, because I accidentally removed some files. How do I reinstall all packages with files missing? I have no clue which files are ...
3
votes
2answers
245 views

How to install font Tex Gyre Termes

I installed TexLive 2018 from https://www.tug.org/texlive/quickinstall.html Consider this script: \documentclass{article} \usepackage{fontspec} \setmainfont{Tex Gyre Termes} \begin{document} \end{...
2
votes
1answer
178 views

How to run tlmgr in Ubuntu

I installed TexLive from https://www.tug.org/texlive/quickinstall.html in Ubuntu 18.04. I have tlmgr which tlmgr /usr/local/texlive/2018/bin/x86_64-linux//tlmgr I try tlmgr install tex-gyre and ...
2
votes
0answers
89 views

What's the correct non-downgraded repository?

I had the same error as this question: tlmgr: Remote repository is newer than local (2017 < 2018) Namely, I was trying to install helvet and had the following error $ tlmgr install helvet (...
0
votes
1answer
294 views

`tlmgr: Remote repository is newer than local (2017 < 2018)` but I just did a fresh install?

First time I saw tlmgr: Remote repository is newer than local (2017 < 2018) I was surprised because my OS is less than a week old, but sometimes the repositories are out of date so did sudo apt ...
1
vote
0answers
80 views

How change my TEXMFHOME directory config

I use Texlive 2018 on Ubuntu 18.04 LTS. I wanted to change my TEXMFHOME directory to hide it. I did it just creating a usertree in "~/.texmf" I've tried if [ -d ~/.texmf ] ; then export TEXMFHOME=...
1
vote
0answers
35 views

tlmgr user mode tree

This is a very bizarre question, so I'll explain the aetiology. I'm a longtime \LaTeX andknitr user, which is trying to augment his repertoire by converting to Rmarkdown. This R package allows the ...
0
votes
0answers
217 views

Unable to install package with tlmgr: Unknown directive

I wanted to install a package with tlmgr by sudo tlmgr install XCharter but I got the error Unknown directive ...containerchecksum ...
0
votes
0answers
494 views

Revisited: tlmgr: Remote repository is newer than local (2017 < 2018)

I have the same problem as this guy, but the answers there do not help me. » tlmgr install scrartcl (running on Debian, switching to user mode!) tlmgr: Remote repository is newer than local (2017 <...
6
votes
0answers
315 views

compressed data corruption with tlmgr (TeXlive 2018)

I installed TeXlive 2018 on Windows 8.1 a few months ago (when it just came out). I updated the installation a few times since that initial install, without any problems. Today I wanted to get the ...
2
votes
1answer
337 views

tlmgr thinks local repo is 2017, but was installed from TeXLive 2018

I am trying to get LaTeX working on a fresh Ubuntu 18.04 installation. When I install texlive using apt-get, I get an extremely minimal (and insufficient) set of packages (not even Tikz!). Trying to ...
-1
votes
0answers
42 views

tlmgr gui claims bizarre TeXLive dist #, cl updates fine

TeXLive Utility launched for its weekly update and provides a list of packages updated at the repository. When I give the update all command, after the notice of the number and combined size of the ...
0
votes
0answers
206 views

Problem with tlmgr initial and update

That is the first time that i try to initial the tlmgr: jigao@jigao-CW35S:~$ tlmgr init-usertree (running on Debian, switching to user mode!) Cannot determine type of tlpdb from /home/jigao/texmf! ...
7
votes
1answer
325 views

So many updates on TL2018

I've just fully installed TL2018 few days ago. After that, I updated some packages with tlmgr. Just now, I observed again within tlmgr that there are so many packages to be updated, more precisely, ...
24
votes
4answers
10k views

tlmgr: Remote repository is newer than local (2017 < 2018)

I'm not able to get past this error. I do not wish to do a fresh install of texlive. Why is texlive so frickin annoying? Why does it force me too fresh install? Why can't I just upgrade texlive like ...
0
votes
0answers
88 views

problems installing package [duplicate]

I tried following these instructions to the best of my (limited) ability. I'm on Ubuntu 16.04. I'm sure that I'm doing something very basic that is wrong, but I can't figure out what. I'm just ...
1
vote
1answer
612 views

Install package from CTAN which is not available in TeX Live

The texdef package was recently updated to fix a critical bug. The package is updated on CTAN, but because TeX Live is in its "freeze" period, attempting to update the package via tlmgr update does ...
4
votes
1answer
928 views

how to Install new packages during freeze period

Apparently TeX Live 2017 is now in the freeze period in anticipation of Tex Live 2018, because I tried running sudo tlmgr install tikz (for a re-install of TeX Live I was doing), and I hit this error: ...
1
vote
1answer
222 views

tlmgr install document class package (refman)?

I'm trying to install refman class package via tlmgr (Ubuntu 14.04, non-system locations). So I did: $ tlmgr install refman TeX Live 2015 is frozen forever and will no longer be updated. This ...
2
votes
1answer
115 views

Archived 2014 repository not contains sha512 file

I have installed Latex 2016 on Debian Stretch (ruby 2.5 docker image) and I would like install packages from 2014 repository (ftp://tug.org/historic/systems/texlive/2014/tlnet-final), but when I tried ...
0
votes
0answers
120 views

How do I install pdf crop via tlmgr in texlive 2015?

I don't have time to install a new Texlive, so I'm trying this: $ tlmgr install pdfcrop Useless content call in void context at /usr/share/perl5/LWP/Protocol/ftp.pm line 379. TLDownload::get_file: ...
2
votes
1answer
582 views

How to install a latex editor with “native” TeXLive installation already in place on Ubuntu?

After hours wasted trying to work with the Ubuntu repository version of TeXLive (tlmgr wasn't working), I installed the "native" version of TeXLive (2017, via "Quick Installer" from the official site) ...
1
vote
0answers
167 views

Tex Live Utility via wget.x86_64-darwin is not signed

I installed the 2017 Tex package earlier this year and I have managed to update using Tex Live Utility without any issues thus far. I just lately installed Little Snitch and it flagged the mirror via ...
0
votes
0answers
522 views

Trouble tlmgr Ubuntu 16.04 and TexLive

Hi so I am trying to get latex running through sublime text on Ubuntu 16.04. I have sublime text set up, and I have installed Texlive 2015/debian according to the command tex --version I've been ...
0
votes
0answers
68 views

Enforce https when using tlmgr to install packages

Is there a way to enforce https when using tlmgr to install packages?
0
votes
1answer
548 views

Generate List of Installed Packages with TeX Live

I've been trying to generate a list of all packages that can be accessed using the \usepackage command in LaTeX & others (so it can be autocompleted by my text editor). Specifically, I've been ...
1
vote
0answers
127 views

Using tlmgr inside a Linux nspawn container

I am trying to install TeXLive into a Linux chroot environment using a systemd nspawn container. The installation seems to go fine. I am installing from a local repository using a custom profile to a ...
14
votes
1answer
440 views

How to get latest version of xii.tex?

In the latest TUGboat (v38, no. 3) David Carlisle presented XII take II saying that the plain TeX file xii.tex could be downloaded from https://ctan.org/pkg/xii. On going there one statement was that ...
5
votes
1answer
2k views

How to use `tlmgr` to install all available babel language packages?

I can install single additional language packages with tlmgr install babel-german babel-french for example. However, how can I just install all available languages?
2
votes
1answer
8k views

How to install current, stable version of TeX (2016/2017?) on Ubuntu 16.04? [duplicate]

Background: I was working on a LaTeX document but getting errors about 'newtxtext.sty' and 'newtxmath.sty'(similar to what's described here, although that solution didn't work) That led me down the ...
2
votes
1answer
586 views

Use tlmgr to install only packages - no source or doc

Running texlive2017. When installing, I chose not to install source and doc trees choosing to depend on tlmgr install --reinstall --with-doc option when needed. But if I need to install a package ...
1
vote
0answers
371 views

Can not install xzdec by tlmgr

I installed texlive by script so I can have the latest version. When using xetex it gives the following error message: I can't find the format file `xetex.fmt'! sudo fmtutil-sys --all did ...
8
votes
1answer
802 views

includegraphics image resolution stopped working

Using texlive 2016 and TeXstudio 2.12.6, the following example worked: \documentclass{article} \usepackage{graphicx} \begin{document} \includegraphics[resolution=300]{figure.png} \end{document} Then ...
3
votes
1answer
376 views

Has TeX Live stopped signing the public repository?

Recently it appears to me that the TeX Live repository is no longer signed with the release PGP key. When using the tlmgr update command, it always reports tlmgr: package repository [mirrored repo ...
13
votes
0answers
155 views

What is the recommended way to protect a TeX Live file from updates with no changes or to auto-patch it on such updates?

Many package managers allow users to prevent certain packages from being updated. Often this is called 'pinning'. A pinned package is protected from automatic updates. This is useful, for example, if ...
1
vote
1answer
716 views

“luaotfload.sty not found” and tlmgr “running on debian” issue

I've just installed Linux Mint 18.2 and TeX Live 2017 (I'm pretty sure; see below). I actually have two separate issues masked into one, so I will present them both. I have the following minimum ...
4
votes
1answer
1k views

Cannot install package in tlmgr

sudo tlmgr install shading Password: tlmgr: package repository http://ctan.mirrors.hoobly.com/systems/texlive/tlnet (verified) tlmgr install: package shading not present in repository. tlmgr: action ...
0
votes
1answer
684 views

Where does tlmgr store the packages?

As given on https://www.tug.org/texlive/doc/tlmgr.html , tlmgr can be used to install packages. Where does it store these packages? Because then I can copy them to another machine for installation ...
1
vote
1answer
641 views

How to install tlmgr and texliveonfly in Amazon linux machine / CentOS?

I want to install full latex on my AWS environment which uses Amazon machine image. They provide only texlive-2012 which not upto date. With tlmgr and texliveonfly I can install the missing packages ...
0
votes
0answers
561 views

tlmgr update now require wget

I've tried to install beamer on mac using tlmgr, but it asked me to update tlmgr, so I did it. Now when I try to install a package it complains saying that wget is not installed (and it is not, I'm on ...