Skip to main content

Questions tagged [ubuntu]

Ubuntu is a Linux distribution based on Debian. It includes TeX and Friends in the form of the TeX Live distribution. Note that http://askubuntu.com is specifically dedicated to Ubuntu questions.

Filter by
Sorted by
Tagged with
1 vote
1 answer
139 views

Installing LyX 2.4.0 on Ubuntu 22.04.4 LTS (Jammy)

The latest version of LyX, 2.4.0, was released on May 31, 2024. I attempted to install this version on my system running Ubuntu 22.04.4 LTS (Jammy) by following the steps provided in the official LyX ...
MYaseen208's user avatar
  • 8,589
0 votes
0 answers
23 views

ubuntu terminal emulator: how to remove horizontal translucent lines

I was using this from Alan Xiang's Blog to emulate an ubuntu terminal in latex. However, with multiple lines, some translucent horizontal lines appear, that make it less attractive to look at. I would ...
Pedro's user avatar
  • 1
0 votes
1 answer
591 views

texlive miktex conflict - texhash

I'm working with Ubuntu 22.04 and texlive (I'm using the Ubuntu texlive from tug.org). I tried to install miktex but gave up because I could not finalize the installation of the miktex console, which ...
Régis FDS's user avatar
0 votes
0 answers
40 views

Bibliography not showing up using biber 2.17 [duplicate]

I had written my bibliography and it was fine until yesterday. Yesterdday, I added a source then compiled in texstudio (biber 2.17, biblatex 3.17, ubuntu 22.04, default bibliography program in options ...
Νικολέτα Σεβαστού's user avatar
0 votes
1 answer
127 views

how to quickly install packages from CTAN locally in standard ubuntu installation

Ubuntu (22.04) with texlive-full installation uses tkz-euclide 4.03 Even after manually installing additonal packages I get plenty of errors. Which packages should I install and what to install where ...
Thierry Blanc's user avatar
1 vote
0 answers
47 views

VS Code chooses wrong Texlive version in second window although PATH is properly defined [duplicate]

I have two installations of Texlive: the newer "native" installation and an outdated "distro" installation. The first window of VS Code uses the "native" Texlive, all ...
babajabba's user avatar
0 votes
0 answers
22 views

Tell Texmaker's internal/embedded pdf viewer to use "build" subdirectory

I've recently discovered the "use 'build' subdirectory" option within Texmaker to get every compilation file neatly into one folder so it doesn't cluster the main folder. When I did that, ...
Epii's user avatar
  • 11
0 votes
1 answer
898 views

TeX Live 2023 + Ubuntu 2022.4.04 LTS + tlmgr =?

I have a new HP laptop. It's just for me; I am not a system administrator for multiple users. I wiped out Windows and replaced it with Ubuntu 22.04.4 LTS, using an ISO file from a thumb drive. Using ...
richardson's user avatar
1 vote
0 answers
3k views

Latex Workshop error: Cannot find LaTeX root file

I recently changed from Windows to Ubuntu because I'm learning to code. I used to write my class assignments in LaTeX using vscode and Latex Workshop. However, I've tried to set it up in Ubuntu and I'...
Alex Moreno's user avatar
0 votes
0 answers
40 views

Tex Live does not show section title

Here is a very simple latex example I copied online. \documentclass{article} \usepackage{amsmath}% For the equation* environment ...
YAC's user avatar
  • 1
0 votes
3 answers
613 views

Setting up Latex Workshop to work with flatpak version of VS Code (Debian)

My question concerns a specific VS Code setup I chose within my Debian 12 distro -- I basically went with the flatpak route in order to avoid installing VS Code from a proprietary/unofficial package ...
dash-dot's user avatar
0 votes
1 answer
36 views

pdflatex stops at \vec when using many packages lubuntu 23.04

I have a very strange error on my lubutu (23.04 Lunar Lobster) using pdflatex: 3.1412592653-2.6-1.40.24 (TeX Live 2022/Debian) Using $\vec{a}$ leads to the following error: ! Missing number, treated ...
iGeeks's user avatar
  • 19
0 votes
0 answers
22 views

Compilation errors after re-installation

I re-installed my OS (Ubuntu 20.04) and Latex (package texlive-latex-extra), and I get compilation errors for my previously working documents. The documents still work fine on Overleaf, but not on my ...
reloh100's user avatar
0 votes
0 answers
270 views

Biber/Biblatex mismatch after fresh installation of texlive

I'm on Ubuntu 20.04, and I needed some more updated latex packages, so I manually installed texlive 2023 (after uninstalling the apt-get version, at least so I thought). I correctly set that up in ...
FooBar's user avatar
  • 993
1 vote
2 answers
689 views

Latex compilation very slow

I have a recent installation of Ubuntu 22.04 on which pdflatex takes around 50 secs to compile a document. The exact same document on another computer but with 18.04 takes less than 2 secs to compile. ...
user137846's user avatar
1 vote
0 answers
75 views

Is there a reliable guide for installing non-apt TeX Live on Ubuntu, detailing different procedures for global vs user installations?

The TeX distribution provided by apt on Ubuntu is not the latest (2023 at the time of this question). So one may want to install directly from TeX Live. At this point an important choice is whether ...
pglpm's user avatar
  • 311
0 votes
0 answers
1k views

Installation of texlive packages ubuntu 20.04

I'm kindly asking for your help. I'm trying to install texlive on Ubuntu 20.04. I tried to find information on how to install it, but I found out there are several packages: texlive-full,texlive-latex-...
fany's user avatar
  • 1
1 vote
0 answers
859 views

newtxtext package error: realscripts.sty not found

I'm attempting to use the mnras package to compile a file, but I keep getting the error: TraditionalBuilder: Engine: lualatex. Invoking latexmk... done. Errors: /usr/share/texlive/texmf-dist/tex/...
Gabriel's user avatar
  • 2,233
0 votes
0 answers
177 views

Still getting a "Restricted shell escape" on Kile

In order to add gnuplots in my documents, I'm using this basic code to verify my system (Ubuntu 22.04.2 LTS + Kile 2.9.93) \documentclass{standalone} \usepackage{shellesc} \begin{document} \...
JJ Henry's user avatar
  • 473
2 votes
0 answers
33 views

Amalgamating a second texmf-local tree with my current texlive installation

I have a tarball of a texmf-local folder from a friend's ubuntu installation, that I'd like to amalgamate with my own texlive installation (presumably to texmf-local too). I imagine I can amalgamate ...
welch's user avatar
  • 191
0 votes
0 answers
77 views

Backward search not working in LyX with Okular

Backward search not working in lyx 2.3.6 and okular 22.08.2 (in Ubuntu 22.04). I've implemented steps from https://wiki.lyx.org/LyX/SyncTeX: [Settings]->[Configure Okular]->[Editor] has LyX ...
Apogentus's user avatar
  • 131
0 votes
0 answers
85 views

lyx export fails due to ubuntu updates. !pdfTeX error: pdflatex (file tcrm1000): Font tcrm1000 at 600 not found

I have removed and re-installed lyx, and added all the fonts I can find. The document has not changed but now cannot generate output. With added preamble stuff \usepackage{ae} I was able to get dvi ...
stuartmacg's user avatar
0 votes
0 answers
162 views

LaTeX Error: File `ubuntu.sty' not found

I am running Winedt10.3 on miktex under windows 10. I like to use the ubuntu font for my project report. I have installed the ubuntu fonts family from Ubuntu Font for windows. However when I am trying ...
Bukaida's user avatar
  • 627
0 votes
0 answers
75 views

Installing TeX Live from source breaks manpages

When I install the latest TeX Live in Linux Mint 21 64-bit, and add the binaries to my $PATH, my manpages break, but when I rm them using the following commands: rm -rf /usr/local/texlive/2022 rm -rf ~...
applecuckoo's user avatar
2 votes
1 answer
117 views

How to remove zeroes before decimal numbers in tables with siunitx -- revisited

Due to style guidelines for a journal, I need to remove the zeros before the decimals. Apparently, the option add-integer-zero=false provided in this answer was removed from siunitx. Is there an ...
jay.sf's user avatar
  • 509
1 vote
1 answer
393 views

How do I install TeX Live on Ubuntu 20.04 in order to use Gregorio

I wanted to install TeX Live on Ubuntu 20.04 in order to use Gregorio in Scribus, and used apt-get to do a full install, but it seems as though that may not be the best way to install it (for example, ...
Francophone's user avatar
1 vote
1 answer
480 views

Setting up Geany to Use LuaTeX or XeTeX

I have installed "texlive-full" on my "ubuntu 22.04" and I use "Geany 1.38" as the editor to edit latex documents. Everything has been fine until I needed to work with a ...
Sinooshka's user avatar
  • 123
0 votes
0 answers
343 views

can't set path of texlive on ubuntu

I installed a full texlive by sudo apt-get install texlive-full then i added the fallowing code to ~/.bashrc, ~/.zshrc ~/.profile export PATH=/usr/share/texlive/2019/bin/x86_64-linux:$PATH enter ...
Mohammed jaidi's user avatar
0 votes
0 answers
261 views

Cannot install texlive 2022 - falls back to 2019

I used to have texlive 2019 installed on my system but I uninstalled it following these instructions in order to upgrade to texlive 2022. For some reason, every time I try to install texlive using ...
Clerni's user avatar
  • 177
0 votes
1 answer
132 views

Lyx: share/sync personnal dictionary among computers?

I am using Lyx and would like that the words saved with Add to personal dictionary can be re-used on two different (Ubuntu) computers. One solution I can think of would be to have my personal ...
Matifou's user avatar
  • 742
0 votes
3 answers
5k views

How to install a specific version of TexLive on Debian/Ubuntu systems via apt-get?

I'm using the following command to install texlive-full on my PopOS! 22.04 LTS: sudo apt-get instal texlive-full It installs the following version: TeX 3.141592653 (TeX Live 2022/dev/Debian) kpathsea ...
Ciniro Nametala's user avatar
0 votes
1 answer
357 views

problem with xetex after updating to ubuntu 22.04.01 LTS

Xetex doesn't work if I try to use tex->pdf. I suppose the problem comes from compatiblity issues. I have no idea what "L3 programming layer" is. This is XeTeX, Version 3.141592653-2.6-0....
Yelle38's user avatar
1 vote
1 answer
177 views

LaTeX and pdfLaTeX stop on using the 'fancy' package

I am preparing a document for a conference (APSIPA 2022); the template is available here. For the camera-ready version, we must use that paper kit to comply with IEEE requirements (adding header and ...
sugab's user avatar
  • 113
0 votes
0 answers
33 views

How to properly install Tex Live on Ubuntu? [duplicate]

When I search for installing Tex Live on Ubuntu, the recommended way is to use the apt install texlive-..., unfortunately this method does not allow any package install from tlmgr: tlmgr update --all (...
nowox's user avatar
  • 1,417
0 votes
2 answers
364 views

MiKTeX crashed on Ubuntu 20.04 (Focal Fossa)

I installed MikTeX from their official website on my Ubuntu 20.04 using shared settings and auto-installation. After opening the console for updates my system turned off due to a power failure and the ...
VT22's user avatar
  • 1
0 votes
1 answer
1k views

LaTeX file works on Windows 11 but not on Ubuntu 22.04, why?

I have one file which can run on Windows 11 successfully but fails to run on Ubuntu 22.04. What is the reason for that? Ii might be about the tabularray package. \documentclass{article} \usepackage{...
Y. zeng's user avatar
  • 2,115
1 vote
1 answer
1k views

How to install MikTex on Linux Mint 21?

I was trying to find ways to install MikTex on Linux Mint 21 (which is based on Ubuntu 22.04 LTS) but could not find any solution yet.
Jahurul Islam's user avatar
1 vote
1 answer
173 views

Okular 20.12.3 does not open pdf after compilation in LyX

After updating okular from version 1.3.3 to okular 20.12.3 on Ubuntu 18.04.6 it can can't open pdf after it's compiled in LyX 2.3.6.1 (after clicking View button). Error message: "Could not open ...
Apogentus's user avatar
  • 131
1 vote
1 answer
161 views

texindy does not run (ubuntu 20.04, texstudio)

I'm trying to run texindy on a document. I need it because I'm writing in french and makeindex doesn't understand how to sort some words with diacritics. Unfortunately, after several tryings, I don't ...
Malo's user avatar
  • 213
1 vote
3 answers
406 views

Metric (TFM) file not found when using the initials package in LaTeX

I have installed the initials package from CTAN, using these steps on Ubuntu. I want to use the Acron font, but when I run the following code: \documentclass{article} \usepackage{lettrine, Acorn} \...
Shayan's user avatar
  • 178
1 vote
2 answers
227 views

Which texlive (ubuntu) package contains a given tlmgr package?

I'm using a GitHub action https://github.com/DanySK/setup-texlive-action to install TexLive, and it works via ubuntu packages. My problem is that I know what tlmgr packages I need, but I'm not sure ...
Fuhrmanator's user avatar
0 votes
0 answers
180 views

Cannot compile bold text with specified font

I'm trying to do a title page so I can reuse it for multiple works in my University. I'm obligated to use Times New Roman (which explains the usage of Nimbus Roman as an alternative). It almost works, ...
fefff's user avatar
  • 101
0 votes
0 answers
188 views

Texmaker crashes when typing any word with the letters d-a in sequence

I am experimenting a weird crash on Texmaker. I am using Ubuntu 20.04 and, surprisingly, I experience the same issue on my old computer (Ubuntu 18.04). Whenever I am typing a word containing the ...
guilla87's user avatar
6 votes
1 answer
7k views

tlmgr tells me my Local TeXLive (2019) is older than remote repository (2022) despite running TeXLive version 2022

Hellou I'm running Ubuntu 20.04.4 LTS x86_64. I previously had a TeXLive 2019 install on my machine via apt. But because of a problem with tlmgr (the Native TeXLive manager) concerning incompatible ...
Klaus Rucksack's user avatar
0 votes
2 answers
802 views

Unicode character ✰ (U+2730) not set up for use with LaTeX

I faced the error "Unicode character ✰ (U+2730) not set up for use with LaTeX." in my latex document. However, I didn't find the "shadowed star" in my code even though I didn't ...
MissKoala's user avatar
0 votes
1 answer
710 views

LaTeX-vim live preview using Ubuntu vm on windows - what's your setup?

Question is pretty self explanatory. I'm using a virtual machine on my pc - either the Ubuntu app on the windows store or wsl through windows terminal, and I'm looking for a setup guide with live ...
ChasingUG's user avatar
0 votes
0 answers
2k views

slashbox.sty not found error

When compiling with Kile I get the error LaTeX Error: File 'slashbox.sty' not found.
Imane's user avatar
  • 1
0 votes
0 answers
21 views

Issues with libertine package [duplicate]

I would like to print a file (in Linux) and I get the following error I have tried manually installing libertine but I have failed to do so. When I dowloaded the zip folder, I extracted it, and then ...
Maths Wizzard's user avatar
0 votes
0 answers
135 views

luatex doesn't stop on error on Windows, but does on ubuntu

I use TeXworks on Win7 (Version 0.6.5, MikTex 21.1) and TeXworks on Ubuntu (Version 0.6.5, "launchpad"). And I have a tex file with an error (undeclared control sequence). Running luatex (1....
altesCoon's user avatar
0 votes
0 answers
1k views

Siunitx qty in TexStudio not working

I try to use the siunitx package in TeXstudio, as far as I know \si is the old version and \qty is the new version. I tried following: \documentclass{article} \usepackage{siunitx} \begin{document} \...
Basti 's user avatar
  • 23

1
2 3 4 5
13