Questions tagged [update]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
48 views

Older than remote repository but 2022 had been installed and now need to update packages

I had installed TeX Live 2022 on Debian 11 with cd /tmp # working directory of your choice wget https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz # or curl instead of wget zcat ...
  • 767
2 votes
0 answers
63 views

Updating tlmgr itself gives error about wrong repository

I've recently upgraded macOS to 13.1. When upgrading TeXLive, the error indicated I need to fix my repository. How? $ tlmgr update --self /Library/TeX/texbin/tlmgr: TLPDB::from_file could not ...
  • 313
2 votes
0 answers
149 views

Not loaded \selectlanguage*{spanish}

I have installed the recent version of MiKTeX on OS Windows 11, last update: 12/02/2022, last week and I have a problem. It had never happened to me before. If I write this minimal working example ...
  • 48.9k
2 votes
1 answer
64 views

Polyglossia \setotherlanguage after update of TeXLive conflicts with luatextra

I am using LuaLaTeX at Mac (LuaHBTeX, Version 1.15.0 (TeX Live 2022) restricted system commands enabled). After yesterdays update Polyglossia started to conflict with luatextra when \setotherlanguage ...
0 votes
0 answers
96 views

tlmgr didn't install packages after self update on windows 10

I have a problem to install package. I found that I need to install update-tlmgr-latest.exe and the it will work but not. If I try to tlmgr install polski I had: tlmgr itself needs to be updated. ...
  • 1
0 votes
1 answer
154 views

Problem with `tlmgr` in WSL2

Infos The installation was done on a new computer . Platform : Windows 10 WSL2 Ubuntu 20.04 texlive2022.iso mirror : https://mirrors.ctan.org/systems/texlive/Images/texlive2022.iso Problem I ...
  • 31
0 votes
1 answer
493 views

Installing and switching to new distribution

I installed the new texlive 2022 distribution and removed the old 2021 texlive distribution with tlmgr uninstall --all (after verifying I was on the right distribution with tex version and it returned ...
  • 143
0 votes
0 answers
391 views

Will an "old" MiKTeX version receive the "new" LaTeX?

I just moved from Mac to Windows and have to adjust a little bit. I am forced to use MiKteX 21.2 now (even though 22.3 is out already). Will this distribution install the new 2022 version of LaTeX ...
0 votes
0 answers
223 views

No longer able to compile LuaLaTeX after MikTeX update

I just updated MikTeX from the console. Even with the following MWE (I guess MNWE in this case) \documentclass[a4paper,11pt]{article} \begin{document} I hate it here \end{document} I get the ...
1 vote
1 answer
76 views

A way to prepare a manual for update

I am writing a manual for my students and I use as resource many blogs posted by the community. I am aware of how fast links to websites can turn obsolete. Every semester I want to make sure the links ...
2 votes
1 answer
368 views

Change or add updmap paths for installing fonts

After an exhausting search, I've seen that default path for installing new fonts manually is /usr/local/texlive/texmf-local (TEXMFLOCAL). But when I put my files under the tree structure of that path ...
1 vote
1 answer
88 views

Fresh install of TeXLive 2021 didn't set system variables Linux

After installing texlive2021 I noticed that "tex" still referred to the 2020 version which I have removed after installing texlive2021. I thought a restart would help, but now it just offers ...
  • 135
0 votes
1 answer
114 views

Issues with macro expansion/lstlisting after updating to LuaLaTeX Version 2021-12-31

I am using Archlinux with texlive. After updating my installation on 2022-01-02 to the newest Archlinux texlive-packets, some features of LuaLaTeX seem to have changed significantly. For example, tex....
  • 105
1 vote
1 answer
285 views

How to make TeXLive download and install the necessary files?

I am working with TeXLive 2021 in Linux Mint (English version). I need to work with Russian texts. I started from the file like this: \documentclass{article} \usepackage[T2A]{fontenc} \usepackage[...
  • 515
0 votes
1 answer
229 views

TeX Live Utility on Mac OSX error: installing gpg appears to have failed

I am trying to update my current version of TeX on Mac OS X 10.15.7. I don't think I've ever updated it before but I was told that to use my university LaTex thesis template, I should install "...
  • 193
0 votes
1 answer
329 views

Updating siunitx to v3 on Mac (MacTex)

How can I update siunitx to v3 using MacTex? Currently I am using v2b. It took me half an hour to figure out the solution. Therefore, I'd like to share it with everybody.
  • 139
0 votes
0 answers
79 views

No pstricks output using xelatex after recent update [duplicate]

I recently updated my miktex packages. When running Xelatex after the update I noticed that my pstricks output was either missing or completely messed up. Is this a bug in one of the updates? How can ...
0 votes
0 answers
623 views

Trying to update packages using TexLive utility, "unable to find valid update server"

I'm trying to update my packages on a Mac using TexLive Utility. I get an error message: ``Unable to find a valid update server. Either a network problem exists or the TeX Live version on the server ...
  • 407
0 votes
0 answers
500 views

TexStudio does not seem to recognize the updates to the latest versions

I hope the title is understandable enough. So I work with MiKTeX 2.9 and TexStudio editor on a Win 10 Home computer. I just realized that for almost a year now, every time I ran the installer for the ...
0 votes
1 answer
166 views

How long does it usually take until package updates on CTAN can be downloaded via MiKTex console?

I am using a package that has received an update on CTAN yesterday (3rd of June 2021). I wanted to download the most recent version of this package via MiKTeX console, but according to MiKTeX console, ...
  • 139
1 vote
0 answers
479 views

MiKTeX can not update

I'm trying to install MiKTeX on a windows 10 machine. While updating after installation it stuck on package miktex-zzdb1-2.9 and says package="l3backend", arhiveFile="C:\Users\portable\...
7 votes
1 answer
248 views

Are the latest TeXLive updates failing to provide backwards capability?

I have noticed that there have been several posts on TeX-SE saying that after updating to the latest TeXLive that documents that used to be processed OK now report errors. I haven't updated so all is ...
  • 26.9k
5 votes
2 answers
510 views

Memoir and tcolorbox A <box> was supposed to be here

After installing the new updates I get these errors while compiling my documents A <box> was supposed to be here. A <box> was supposed to be here. \setcounter deleting as much as possible ...
  • 51
1 vote
1 answer
142 views

how to update font?

I'm using LaTeX with a ubuntu distro (auctex) and used the following command \fontfamily{augie}\selectfont to set a augie calligraphic font. Everithyng goes fine but... it seems that the ì character ...
4 votes
1 answer
3k views

How to update TeXstudio and Texlive 2021? [duplicate]

since I did not find recently solution (only questions that are asked few years ago) I want to ask again. When I opened TeXstudio today it told me there is a new version to download. My questions are: ...
user avatar
0 votes
0 answers
164 views

Lyx does not recompile the PDF in any PDF viewer

I am running Lyx 2.3.6 for Mac, combined with TexStudio and Adobe Acrobat Reader DC as pdf viewer, under macOS Catalina, version 10.15.7. The problem is that when I change something in the Lyx ...
0 votes
0 answers
99 views

Issues with Texlive 2019

I stayed on perfectly working earlier versions until now when I decided to give TL 2019 a try. My documents did not compiled, raining thousands of errors on me, and fired up Tlmgr, to update, but I ...
1 vote
1 answer
648 views

tlmgr does not work at all

Here's the problem: As i was writing an essay on my computer using latex i noticed that the editor was giving me an error for the packages tikz and cancel( i'm using kile') error: the file [tikz or ...
0 votes
0 answers
397 views

Installed texlive 2020 but still cannot install latexmk due to the 2019 local TeX Live

Summary: I cannot install/update latexmk because it says the local tex live (2019) is older than remote (2020), but in fact I already installed texlive 2020 from the official source. Notes: The ...
  • 135
1 vote
1 answer
561 views

Labeling and referencing subsequent equations after adding a new equation before them

I have a finished document with labeled equations and their respective references. If I update this document by adding a new equation in the middle of the text, would there be a way of both labels and ...
5 votes
1 answer
162 views

biblatex-chicago problem after update

After updating my TeXLive 2020 distribution today, biblatex-chicago has stopped working for me. The following MWE: \documentclass{article} \usepackage[authordate]{biblatex-chicago} \usepackage{...
  • 7,895
2 votes
1 answer
2k views

Listing failed - TeX Live Utility

From a couple of days when I try to update the packages with the TeX Live Utility I get the message: Listing Failed. The Repository's URL is http://ctan.mirror.garr.it/mirrors/CTAN/systems/texlive/...
0 votes
0 answers
577 views

How to update a LaTeX package?

I have the Tex Live 2017 in Trisquel, I installed from the compact disc. I need to update the tkz-euclide package, for that I entered the tlmgr window: When I order the update, I get this result: ...
0 votes
0 answers
710 views

/usr/bin/tlmgr: unexpected return value from verify_checksum: -5

I recently updated from Ubuntu 19.04 to Ubuntu 19.10 and it seems that I have lost a number of Latex packages, including colophon and enumitem. TeXLive came bundle with Ubuntu but I reinstalled it ...
  • 1
1 vote
1 answer
89 views

How can I upload an updated LaTeX package?

I've modified a LaTeX package I created some years ago. Now I would like to upload the modified package. I tried to use http://www.ctan.org/upload, but I don't understand to which subdirectory to ...
3 votes
1 answer
863 views

How to update a specific package in MikTex console?

In MikTex Console (Windows), I go to its Packages tab, and there's no way to search for a package to install, or update an installed package. When I go to the Updates tab, it says that all packages ...
0 votes
0 answers
135 views

Can't update TexLive to 2020, but Update Repository is for 2020 Version

Recently tried to update a package through TexLive, but I found out that the default repository for updates has switched to the 2020 version, while my TexLive is 2019. Unfortunately, when I went to ...
1 vote
0 answers
66 views

Formal Letter with distinct header - footer look depending on page length

I am trying to write a formal letter. The issue I am having is utilising fancyhdr properly. I would like to achieve the following: If only a single page: The header and footer only - without page ...
0 votes
0 answers
59 views

tlmgr failed (lack of space?)

I tried tlmgr update -all and it reached 177/509 jadetex then failed on japanese-otf-uptex (due to lack of space?). I deleted some (non-TeX) files to increase the available space and tried again. This ...
  • 26.9k
1 vote
0 answers
77 views

tlmgr does not update binary

I have MacTeX 2019 installed and I am trying to update dvisvgm to the latest version. If I run tlmgr info it says: installed: Yes revision: 52851 sizes: doc: 149k, bin: 5061k relocatable: ...
0 votes
1 answer
483 views

Use 'sudo apt autoremove' to remove them

I am trying to remove TexLive 2018 in order to do a fresh install of TexLive 2019 after a failure to upgrade Cannot find TeX Live root using kpsewhich --var-value=SELFAUTOPARENT I try the first ...
  • 7,263
2 votes
1 answer
52 views

Dealing with updates issues

I have stumbled several times after an update to the LaTeX core, either 2e or 3. Isn't there a procedure that announces to developers or maintainers of affected packages to check their compatibility ...
  • 1,311
1 vote
1 answer
1k views

svg package failing to work after update

I can't compile the book I've been working on anymore after a general package update. I restricted the issue to a recent version of the svg package (Oct. 10). In this MWE: % !TeX spellcheck = it_IT % ...
  • 159
3 votes
0 answers
424 views

MikTeX issue after update: initexmf.exe

I have the same problem as stated in this post. After updating MikTeX I am unable to compile LaTex files that contain \includegraphics{}. The temporary fix from Joseph Wright solved the problem. My ...
2 votes
1 answer
272 views

The error occurred after the last update

After latest update of TeXLive2019 I get an error with my code, thet previously worked fine. I associate this error with the latest update, possible some conflict of hyperref and answers packages, or ...
  • 5,286
0 votes
0 answers
239 views

Table of contents starting in the middle of the page

I'm writing my dissertation and everything worked fine until I upgraded to texlive 2019. Now my table of contents suddenly starts in the middle of the page. It worked fine before, please help! \...
  • 161
1 vote
0 answers
67 views

Tracking package changes on CTAN

If I download a CTAN package, I would like to receive email notifications whenever a change is made to that software. I know that I can automatically receive the updates themselves, Updating Packages, ...
1 vote
0 answers
797 views

Miktex won't connect to repository server [closed]

i've tried to install some new packages, but it failed. Then I tried to update my miktex manually from the console and got this error: Wehen i had a look at the www.miktex.org website, there was no ...
2 votes
0 answers
3k views

How to deal with the Package lipsum Package expl3 too old error without losing my work?

I was compiling a template and I got this error: ! Package lipsum Package expl3 too old. so I was wondering if there is a way to update the expl3 package but without losing my previous work, since ...
  • 111
1 vote
1 answer
768 views

texlive 2018 install without update

I wonder if there is some workaround for the Texlive 2018 to be able to install any package, as right now everything is returning the error related to the new 2019 version. There was this answer, for ...