Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [updating]

questions to do with updating distributions

1
vote
1answer
85 views

Upgrade to 2019 gone wrong on a Debian System

I followed the advice at tlmgr: Remote repository is newer than local (2017 < 2018) and upgraded my TeX installation following the tutorial at https://www.tug.org/texlive/upgrade.html. When I ran ...
0
votes
0answers
84 views

Update TexLive 2018

I work with TexLive2018 However, some of my packages seem to be old: (/usr/local/texlive/2018/texmf-dist/tex/latex/tools/array.sty Package: array 2018/04/30 v2.4h Tabular extension package (FMi) ...
3
votes
2answers
7k views

Updating TeX on Linux

I am trying to use the algorithm, algorithmicx, and caption environment. In the log file I have Release 2.5 -- March 13 1995 -- and I have compiling errors which other people don't have. So I would ...
0
votes
0answers
213 views

texmaker does not recognize the new package

(See my working and system context below) I have downloaded a package (genealogytree) and added it to the texmf folder in MikTex 2.9 in the appropriated subfolders. Have run initexmf --update-fndb ...
2
votes
1answer
529 views

problem with MiKTeX after updating

I use Windows 10 Pro and I updated MiKTeX for solving that problem. The problem now is that when I select: MiKTeX package manager, system says that mpm_mfc_admin.exe can't be found, MiKTeX settings, ...
300
votes
6answers
258k views

How do I update my TeX distribution?

I'm trying to compile a document that only works with an up-to-date distribution, so I'd like to know: how do I update my distribution? Please provide screenshots where appropriate. List of answers ...
4
votes
0answers
428 views

File revtex4-1.cls is missing… overwritten by 4-2 after update?

I updated my TeXLive and lost the revtex4-1.cls class. The package revtex contains now revtex4-2.cls. Old version 4.0 is accessible by installing revtex4 package. There is a new package revtex4-1 ...
14
votes
1answer
597 views

What happened to \luatextextdir?

As of today, the command \luatextextdir does no longer seem to work. I employ the command in order to be able to typeset Arabic. To that end I created the following commands: \newcommand{\arabtext}[1]...
0
votes
1answer
394 views

`tlmgr: Remote repository is newer than local (2017 < 2018)` but I just did a fresh install?

First time I saw tlmgr: Remote repository is newer than local (2017 < 2018) I was surprised because my OS is less than a week old, but sometimes the repositories are out of date so did sudo apt ...
3
votes
1answer
933 views

MikTeX update packages

How to update MikTeX please? In the second picture I tried this opportunity and the update not succed. I read that admin update help, but I cannot it open. I have nothing ticked and select all is grey....
0
votes
0answers
84 views

How to update local TeXLive repository created by rsync?

How can I install texlive after running rsync with a CTAN mirror? rsync -a --delete rsync://mirrors.shu.edu.cn/CTAN/systems/texlive/tlnet/ /home/alhelal/Downloads/TeXLive I make the local repository ...
5
votes
1answer
313 views

How to update LuaTeX binary (TeXLive on GNU/Linux)?

MikTeX provides access to the latest binaries through the miktex-nxt update channel. While being windows-only all these years, in 2018, it looks like Mr Schenk is extending his distribution to certain ...
17
votes
8answers
19k views

tlmgr error: perl.exe has stopped working

I have been using TeX Live 2010 on my Windows 7 computer for some time now, without problems. Recently I decided to use the TeX Live Manager to check for updates, which were successfully installed. ...
8
votes
2answers
21k views

How to install PGF/TikZ 3.0 in MikTeX?

Currently, the MiKTeX package manager does not know of the latest stable version of PGF/TikZ. I have made an attempt at installing it manually, following Stephan Kottwitz’ answer to question How can I ...
2
votes
2answers
90 views

tlmgr installs files outside /usr/local during update --all in TL2016

texlive 2016 was installed locally in /usr/local/texlive/2016/ on a gentoo Linux system by the install-tl -gui installer. An update with tlmgr returns: /usr/local/texlive/2016/bin/x86_64-linux# ./...
0
votes
1answer
234 views

What happened to MiKTeX GUI based update tools?

Are they all gone and replaced by the Console? I am very used to the "Update" GUI from the Start menu and other links. I can't seem to find them now.
1
vote
1answer
286 views

Error with \textsubscript

I am seeing this in the body of the latex format for a journal I want to publish with. But it's prompting an error. What does this mean CO\textsubscript and which package do I have to include to be ...
5
votes
1answer
294 views

Problem with installation: cannot determine release!

My Windows 10 system has just started acting like and usual Windows system: every now and then, it suddenly stops by itself. Unfortunately, it happened while I was updating TeX Live (2017). Now, if ...
45
votes
6answers
1k views

What have been the most important changes to LaTeX in the last five years? (2011–2016)

I spent the last two years out of the loop and came looking for information about the recent advances within the (La)TeX ecosystem, basically to see whether the issues I found frustrating enough to ...
3
votes
1answer
58 views

Dealing with background spacing in different versions of beamer

In some versions of the beamer class (e. g. the one in TeX Live 2016, v3.36), space with the height of the footline is inserted in the background layer before the background content for plain frames. ...
0
votes
0answers
419 views

MiKTeX failed to update, now files won't compile

Well, since the MiKTeX support site suggests filing bug reports here, here's the log file for today's update run. I don't really understand what the error messages are telling me. What can I do to ...
28
votes
2answers
3k views

What does “skipping forcibly removed package xxx” mean? Should I care about it?

I got the following messages when updating TeX Live 2012 using the provided GUI. What does "skipping forcibly removed package xxx" mean? Should I care about it?
1
vote
1answer
3k views

Automatic package install in linux? [duplicate]

In Windows, I run TexWorks, and when I include a package that I do not already have installed, it asks me if I want to install that package. In linux (Ubuntu), I have tried this in TexWorks, and ...
1
vote
1answer
250 views

Where is the right place for .tfm, .mf and .sty file?

I want to to install esvect.sty on my texmaker, I have ubuntu 14.04 and tex live from Ubuntu software center. I downloaded esvect.zip from this https://ctan.org/pkg/esvect. I follow the README ...
3
votes
0answers
378 views

Can't compile .tex file after MacTeX 2017 last packages update

Till last update of MacTeX my files were compiled nice. After update I can't compile them. Example code: \documentclass[a4paper,12pt]{article} \usepackage[T1,T2A]{fontenc} \usepackage[utf8]{inputenc} ...
1
vote
0answers
431 views

User and admin MiKTeX Update [closed]

I like to be updated. So from time to time I do an update of MiKTeX. I did it some days ago and just to see I do it again today. If I do the update with MiKTeK Update (admin) I got nothing to update (...
2
votes
1answer
439 views

Bibliography does not update

I am using WinEdt to write my thesis and JabRef for the bibliography and encounter the following problem: Whenever I change or add something to my list in JabRef and use the "PDFTeXify" button to ...
0
votes
1answer
222 views

Where to put the files of package 'karnaugh-map' when installed manually?

I have just installed the package 'karnaugh-map' with the commands: pdflatex karnaugh-map.ins pdflatex karnaugh-map.dtx Now, I have a installation directory C:\Users\User\Desktop\karnaugh-map with ...
10
votes
3answers
10k views

TeX Live issue after update - `fmtutil.cnf` not found

I recently updated TeX Live to following version TeX 3.1415926 (TeX Live 2013/Arch Linux) and cannot compile any file anymore, it fails with error $ pdflatex blab.tex This is pdfTeX, Version 3....
1
vote
0answers
144 views

Transfer installed packages when installing a new TexLive release

Currently I have TexLive2016 with some packages installed via tlmgr. Now I would like to switch to the 2017 release and I was wondering if it is possible to somehow install the same packages in the ...
0
votes
0answers
571 views

tlmgr update now require wget

I've tried to install beamer on mac using tlmgr, but it asked me to update tlmgr, so I did it. Now when I try to install a package it complains saying that wget is not installed (and it is not, I'm on ...
0
votes
0answers
360 views

Problem Updating MiKTeX [duplicate]

Today I installed MiKTeX on my PC then went to updated as recommended, but I am facing an error, can anyone help please ? Here is the error message here is the update log : 2017-02-26 17:03:56,937+...
9
votes
4answers
15k views

MiKTeX209-jpeg.dll is missing

After installing MiKTeX 2.9 on Windows 7, I can open TeXworks but only if I do not use the MiKTeX updater. After updating MiKTeX after installation and whenever I try to open TeXworks, I get the ...
2
votes
0answers
687 views
1
vote
1answer
513 views

“Installation of new version of xxxx failed, trying to unwind” messages when I update TeX Live 2016

This morning I've updated TeX Live with the GUI for Windows 10, as usual, but Im getting some messages I've never seen before. Here is the log shown in the GUI. First attempt: Executing action ...
12
votes
1answer
4k views

Update / Install the newest version of LaTeX3

The developing of LaTeX3 goes on. However some feature will be improved or added. The LaTeX3 team can't upload every day a new version to CTAN. How can I install the newest version LaTeX3?
1
vote
0answers
562 views

Issue after TL update, february 9, 2017, \RequirePackage{expl3} [closed]

Before update TL was working fine. After update got the error: Package l3sort Error: This package is obsolete --- use 'expl3' instead. use 'expl3' instead}\@ehc l3* packages were updated. How ...
10
votes
4answers
7k views

Problem With updmap-sys

I ran the TeX Live 2012 update this morning on my 64-bit Kubuntu 12.04 linux system (tlmgr update --all) and received the following error: tlmgr: package log updated at /usr/local/texlive/2012/texmf-...
35
votes
5answers
20k views

A MiKTeX update removed amsmath as obsolete – can I use another package or get it back?

I have a problem with amsmath package. After an update this package was removed because it was obsolete. But what package can use instead of amsmath?
3
votes
1answer
1k views

How to install the development version of BibLaTeX (using MiKTeX on Windows)?

I know, this is most likely well documented and has been asked before, so probably I am just overwhelmed by the amount of available information on the issue. I'm trying to install the development ...
9
votes
2answers
310 views

How can I automate “regression testing” for LaTeX documents, when updating packages?

I recently asked a related question about how often one should update LaTeX packages. Supposing that I update a bunch of packages in one go, or regularly update with only a few packages changing, how ...
5
votes
1answer
4k views

Error in Updating FNDB after last update [closed]

After updating packages this morning nothing works anymore (I am working under Windows 8). Particularly, compiling files with TeXWorks returns the message: running 'initexmf --quiet --update-fndb' to ...
1
vote
0answers
71 views

Cannot compile after manually update a package

I decide to manually update a package {because of freezing texlive 2015} (xepersian-from 16.1 to 16.5) I follow these steps: Download zip file from ctan Extract generate .sty by running cmd: Copy ...
0
votes
1answer
132 views

`pdftex-def` obsolete - When updating MikTeX, I can't compile

When I updated MikTeX through the automatic update program, I could not compile afterwards. It could not find pdftex-def. I then uninstalled MiKTeX and reinstalled it again. Now it is working again. ...
1
vote
0answers
2k views

The remote package repository is not online. You have to choose another repository

After updating MikTex last night I am getting the error message in subject when trying to install or update the packages. By default I was using http://ctan.mirror.rafal.ca/systems/win32/miktex/tm/...
0
votes
1answer
149 views

Path Problems Again with El Cap 10.11.6?

Last year I updated my mac to El Capitan, and followed the instructions here to fix the path issues. It was easy! Today I updated to 10.11.6. The preferences in TeXMaker (my GUI of choice) reverted ...
15
votes
4answers
13k views

MacTeX - TeX Live Utility broken after 2015 update

I have the following strange message. The repository at ftp://ftp.oleane.net/pub/CTAN/systems/texlive/tlnet has TeX Live 2015, but you have TeX Live 18446744073709551615 installed. You need to ...
2
votes
0answers
558 views

Identifying a fix for an Undefined control sequence (\pgfdeclareplothandler) error [closed]

I would like to identify a fix for the following error: "C:\Program Files\MiKTeX 2.9\tex\generic\pgf\libraries\pgflibraryplothandlers. code.tex" ! Undefined control sequence. l.24 \...
74
votes
4answers
77k views

MikTeX 2.8 Update Error “Windows API error 87”

I was happily updating packages when the following error appeared: Error: Windows API error 87: The parameter is incorrect. The full update report with this error at the very end is as follows: ...
17
votes
2answers
475 views

Any effort towards a rolling release of TeX Live?

This is a follow on, in a way, from my question a couple of years ago about Why does TeX Live "require" yearly updates? One of the answers suggested that there was some discussion about ...