Hot answers tagged

12

The apacite package supports two sorts of citation commands, its own version, or the natbib versions (loaded with the natbibapa package option.) The citation commands support both a pre-note and a post-note. The basic syntax is: \cite<pre-note>[post-note]{citekey} where \cite gives you (pre-note Author, Year, post-note), \citeA gives you pre-note ...


6

Three suggestions: Don't load both the apacite and the natbib packages; instead, run either \usepackage{apacite} or \usepackage[natbibapa]{apacite} (Use the latter if you wish to use the natbib-like citation commands, e.g., \citet and \citep). Do familiarize yourself with the user guide of the apacite package. In particular, the user guide provides ...


6

The apacite package implements a proper APA style bibliography which requires full citations on first mention for author lists up to 7 authors. Since you are loading the package with the [natbibapa] option, you can specify in the preamble a list of bib keys that you want to appear as "short citations". So schematically you can do the following: \...


6

Seems you have to delay the redefinition, at least this seems to work for me \AtBeginDocument{ \renewcommand{\BBAA}{and} \renewcommand{\BBAB}{and} \renewcommand{\BAnd}{and} } have not investigated further


6

To avoid inserting the literals if the last names are not unique, you have to change the apacite style: Search for the file apacite.bst in your TeX installation and copy it to your document directory as apacite-no-initials.bst. Then you can open apacite-no-initials.bst. At the end of the file there are about 30 lines with EXECUTE, ITERATE, REVERSE and SORT ...


5

When you load apacite with the natbibapa option it does not implement the extended citation commands that apacite uses. So the \shortcite command is not available, only the natbib supplied citation commands. Unfortunately natbib takes a different approach to this, and assumes that the short version is the default, and only provides citation commands to ...


5

The best current implementation of a true APA style is the biblatex-apa style. Here's a sample document using it. If you want to use the 'Retrieved from' field, you need to name it correctly, the biblatex field name is urldate and the formatting of the date has to be correct too: YYYY-MM-DDTHH:MM:SS (if you need exact times, although they won't be printed ...


5

The problem is that your url field contains underscores, which is a mathmode character. So solve this you need to tell apacite to deal with URLs properly. To do this, add load the url package: But there is a second problem: the [BCAY] option should not be used unless you are working with an old document. It was included for backwards compatibility purposes, ...


5

With a local TeX distribution If you have a TeX distribution on your computer, the easiest way to find the location of a file in your distribution is to use the command line command kpsewhich. Open a Terminal window (or equivalent) and type: kpsewhich apacite.bst This should return the full path of the copy of apacite.bst which TeX will load. If you don't ...


5

apacite uses macros to localise strings like "et al.", so you just have to redefine the relevant macros. This needs to happen in \AtBeginDocument after apacite has done its language selection. \documentclass{article} \usepackage[natbibapa,apaciteclassic]{apacite} \AtBeginDocument[apacite-localisation]{% \renewcommand{\BOthers}[1]{\emph{et al.}\...


4

Here's the apacite version of what you want to do. The localization strings are found in the french.apc file that is part of apacite. They must be changed at the beginning of the document, not in the preamble. % !BIB TS-program = bibtex \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \begin{filecontents}{\jobname.bib} @...


4

(I rewrote the answer more or less completely after the OP provided an important piece of information, viz., that the bibliographic items of his/her document must be formatted according to APA guidelines.) If your bibliography has to be formatted according to current APA guidelines, you should be using the apacite bibliography style, along with the apacite ...


4

For the commonly used packages, the documentation of the packages should list any such requirements. The order matters as soon as two packages change or create the same macro, or one of them changes a macro the other relies upon on loading/setup. Sometimes that means you cannot use those two packages together, sometimes you have to decide which comes ...


4

You can make a new macro to output the translator for an article and then patch the article driver to include it. \documentclass{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @article{Surname2018, author = {Surname, A.}, date = {2018}, title = {Article Title}, translator = {Translator, B.}, journaltitle = {Journal}, ...


4

This is again a feature of the APA style, the documentation of apacite alludes to this first with There are some special cases, where some of the authors and the year are the \shortcite same, but not the whole author list, in which more names are retained on subsequent citations as well. Because "Cohen et al." might be ambiguous as to which ...


4

LaTeX generally already typesets its bibliography without extra space after periods. Indeed apacite is no exception, its redefinition of thebibliography has \sfcode`\.=1000\relax, which means that a full stop/period will not trigger the behaviour of \nonfrenchspacing to add a bit of space afterwards. Bibliographies do, however, have the additional command \...


4

The version of apacite currently available on CTAN (v6.03 2013/07/21) implements the requirements of the 6th edition of the APA manual. I am not aware of any BibTeX implementation of 7th-ed. APA style. You can of course try and contact the author of apacite about that and ask for 7th-ed. APA style as a feature request. For the time being biblatex-apa is the ...


4

If at all possible I would try to avoid using manual \addcontentslines in the document body: If not used carefully, they may end up adding entries with wrong page numbers to the table of contents. Often it is possible to avoid \addcontentsline by using certain package options, with additional packages or with preamble code. apacite has a very clever ...


3

This behaviour is expected if there is another author with different first name but same last name in the bibliography. Otherwise authors with the same last name would not be unique. The OPs bibliography contained works of both "J. Nielsen" and "L. Nielsen". LaTeX quoted with the initials to make them distinguishable. This behaviours also occurs, if there ...


3

You need to load babel after apacite. (And apacite needs to be loaded after hyperref; see below.) ... \usepackage{hyperref} \usepackage[apaciteclassic,sectionbib]{apacite} \bibliographystyle{apacite} \usepackage[english]{babel} \addto{\captionsenglish}{% \renewcommand{\refname}{Bibliography}% \renewcommand{\contentsname}{Table of Contents}} ... ...


3

Here's how to do it with biblatex: \documentclass[a4paper,10pt]{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{setspace} \setstretch{1.2} \renewcommand{\arraystretch}{1.2} \usepackage{url} \title{Drug Business} \author{Andre Resius} \date{} \usepackage[style=apa, backend=biber]{biblatex} \DeclareLanguageMapping{english}{...


3

The bibtex style inserts \BBA for "and" and apacite.sty defines the macro, ultimately depending on these definitions \newcommand{\BBAA}{\&} % between authors in parenthetical cites and ref. list \newcommand{\BBAB}{and} % between authors in in-text citation \newcommand{\BAnd}{\&} % for ``Ed. \& Trans.'' in ref. list so for example you could ...


3

You can modify the internal \@cite command so that it changes the brackets in just those cases. \documentclass{article} \usepackage{apacite} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @book{Knu86, author = {Knuth, Donald E.}, year = 1986, title = {The {\TeX{ book}, }}} \end{filecontents} % \makeatletter \usepackage{...


3

The following seems to work. I've added a negative kern to the redefinition because the ~ itself seemed to add too much space. \documentclass{article} \usepackage{filecontents} \begin{filecontents*}{\jobname.bib} @article{Landau2007, Author = {Landau, Idan}, Doi = {10.1162/ling.2007.38.3.485}, Journal = {Linguistic Inquiry}, Number = {3}, ...


3

You already identified \BAstyle yourself, but you can't use a macro such as \textbf for it, you need to use a switch \renewcommand{\BAstyle}{\bfseries}


3

For the citation <cite>, you can add \nocite{<cite>} to your document. This would be similar to \cite{<cite>} without setting the actual citation within the text. It'll appear in the bibliography. \documentclass{article} \usepackage{filecontents} \begin{filecontents*}{references.bib} @article{glashow, author = {Glashow, Sheldon},...


3

The problem is the _ in the url, which can normally only be used in math mode. In order to use them in a url, either use the url or the hyperref package. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[natbibapa]{apacite} \usepackage{url} \usepackage{filecontents} \begin{filecontents*}{\jobname.bib} @misc{sharelatex, title={ShareLaTeX,...


3

Here's a way to do this with plain apacite (it won't work if you use the [natbibapa] option; that would require a different method.) You can adjust the two lengths \bibleftmargin and \bibindent to your liking. For example, if you don't need the hanging indent, you can set \bibleftmargin to 2.5em and \bibindent to 0em. You can change the formatting of the ...


3

I don't see any option for turning this off selectively. The following is a bit of a hack but it works. It redefines the apacite URL environment to be empty, and then in that environment only redefines the \url command to be empty. I've also added some code to keep the doi: prefix attached to the actual DOI. This will not work if you have online resources ...


Only top voted, non community-wiki answers of a minimum length are eligible