127

By default biblatex will truncate name lists exceeding maxcitenames to one author plus "et al." (mincitenames=1). However, biblatex will (also by default) not truncate if doing so would cause ambiguous citation keys, which I suspect is the case in your document. Compare the output of the following two examples: \documentclass{article} \usepackage[style=...


50

If you are using BibTeX, place and others after the main authors and the compiled file should show et. al, e.g.: Author="H. Morgan and others"


28

tohecz is right, you need to set minbibnames=6 as well. Here is an excerpt from the documentation (section 3.1.2.1): maxnames=<integer> default: 3 A threshold affecting all lists of names (author, editor, etc.). If a list exceeds this threshold, i. e., if it holds more than <integer> names, it is automatically truncated according to ...


26

The number of names in labelname is determined (in part) by the counter maxnames. In citations, this is just equal to whatever you specify for the maxcitenames option. To avoid name list truncation at the first citation, you can change maxnames locally using etoolbox's \defcounter command inside the \AtEveryCitekey hook. \documentclass{article} \usepackage[...


19

It seems like you didn't include all of the fields needed to make this work: CTLuse_forced_etal is required to indicate that you actually want to shorten author lists. CTLmax_names_forced_etal Gives the maximum number of authors before it shortens the list. CTLnames_show_etal Allows you to specify how many names will be given when it does shorten. Your ...


18

To change maxnames for one citation only you may use the counter: \AtNextCite{\defcounter{maxnames}{99}}\fullcite{Reference:1994} This sets both maxcitenames and maxbibnames but in your case this is not probably the problem. Unfortunately there is no maxcitenames counter in biblatex. You may also define a dedicated command for such citations: \newcommand{...


17

With biber this can be handled by the following option settings. maxcitenames=3,minnames=1,maxalphanames=4,minalphanames=3 With BibTeX you can define variants of existing citation commands in your document preamble. \newbool{cbx:resetnames} \AtEveryCitekey{% \ifbool{cbx:resetnames} {\defcounter{minnames}{1}\defcounter{maxnames}{3}} {}} \let\...


16

If you want to achieve: One author name if there is only one author Two author names if there are two authors First author name + et.al if there are more than two authors then \usepackage[maxcitenames=2,style=authoryear]{biblatex} is correct already, while if you want to achieve: One author name if there is only one author Two author names if there are ...


15

Either make a new command: \newcommand{\printpublication}[1]{\AtNextCite{\defcounter{maxnames}{99}}\fullcite{#1}} Or modify \fullcite globally: \preto\fullcite{\AtNextCite{\defcounter{maxnames}{99}}} MWE: \documentclass{article} \usepackage[maxbibnames=99,maxcitenames=1]{biblatex} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @misc{A01, ...


14

If you are going to populate your "List of Publications" through \fullcite commands, you can issue the command \AtNextCitekey{\defcounter{maxnames}{99}} just before each \fullcite in the "List of Publications". MWE: \documentclass{article} \usepackage{biblatex} \usepackage{currvita} % just for demonstration %\ExecuteBibliographyOptions{maxnames=3} \...


13

For (1) use the package options maxcitenames=3,maxbibnames=99. See also my updated answer to biblatex: displaying all authors of multi-author works in the bibliography. For (2) add the following to your preamble: \DeclareFieldFormat[article,periodical]{volume}{\mkbibbold{#1}} For (3) see Suppress "In:" biblatex.


13

You may change the definition of the \fullcite and \footfullcite cite macros so that they locally use the value of maxbibnames. \documentclass{article} \usepackage[maxbibnames=99,maxcitenames=1]{biblatex} \makeatletter \DeclareCiteCommand{\fullcite} {\defcounter{maxnames}{\blx@maxbibnames}% \usebibmacro{prenote}} {\usedriver {\DeclareNameAlias{...


13

I believe that you need to set the number of authors before et al. in the .bst itself, rather than from the LaTeX. I think the below does what you want, I have adapted it from a .bst I created using makebst. Just replace format.names in your .bst. FUNCTION {format.names} { 's := "" 't := #1 'nameptr := s num.names$ 'numnames := numnames 'namesleft :...


12

The default in biblatex is to use the uniquelist option. APA style also uses this. This option dynamically changes the maxnames/minnames settings in order to make citations unique. This is required by APA. APA style also applies APA rules regarding citation list truncation after the first cite within a paragraph. You are probably noticing the effects of ...


12

Insert this piece of coding just before the \begin{document} like so... % \def\sharedaffiliation{% \end{tabular} \begin{tabular}{c}} % \begin{document} and then adjust your particular 'author block' like so (example shown for 3 authors)... \title{Alternate {\ttlit ACM} SIG Proceedings Paper in LaTeX Format\titlenote{(Produces...}} \numberofauthors{3} ...


11

This is, in fact, the correct disambiguation behaviour. When you cite the 2004 paper, the biblatex "uniquelist" feature (which APA requires) expands the name lists to the point of minimum ambiguity which is: Stroebe & Nijstad et al. Strobe & Nijstad However, since "et al" is plural and should not replace only one name, the hidden name is printed ...


10

What about name lists for editors or translators? If you want to apply the same truncation throughout, just use the package option maxnames=2. The rest is achieved by redefining \finalnamedelim - a macro that sets the delimiter before the final item in a name list. \documentclass{article} \usepackage[T1]{fontenc} \usepackage[american]{babel} \usepackage{...


10

Sometimes you don't get the expected result because biblatex is trying to be smart about disambiguating the labels, e.g., if you are citing two different four-author papers in your document that would be cited as "Cotton et al. 1999" and "Cotton et al. 2001". To deactivate this behavior entirely, use uniquelist=false. You can also set it so that it ...


9

Unfortunately I don't know what style you are using, but for the standard ones you may try to patch 4 macros (I hope I didn't forget any): \usepackage{xpatch} \xpretobibmacro{author}{\defcounter{maxnames}{2}}{}{} \newcommand*{\defeditorcounter}{\defcounter{maxnames}{3}} \xpretobibmacro{editor}{\defeditorcounter}{}{} \xpretobibmacro{editor+others}{\...


8

Based on an answer from These guys, I have managed to work out that this behaviour is achieved by changing the \usepackage in the preamble to: \usepackage[style=authoryear, maxbibnames=99, mincitenames=1, maxcitenames=2, backref=true, hyperref=true, dashed=false, firstinits=true, backend=biber, bibencoding=utf8, uniquename=false, uniquelist=false]{biblatex} ...


8

maxcitenames is the option that affects the maximum number of authors that appear in citations. It's set initially to the same value as maxnames, which defines the maximum number of authors both in the bibliography and in citations (as stated in Tobjørn T.'s comment to Dror answer). So, if you want to globally set citations to print only one author, this is ...


7

You have an additional pair of braces in your author field that makes impossible for Biber to count the number of authors: you're specifying, according to the syntax rules, only one author. For setting the maximum number of authors shown there are various options; here's how you can limit the number of authors shown in citations to three. The file contents* ...


7

This is correct APA 6th edition style, see section 7.01, example 2.


7

Yes, it's possible. You can redefine \blx@maxbibnames for the desired refsection; using the \Setmaxbibnames command, you can locally specify the desired value: \documentclass{article} \usepackage[maxbibnames=99,style=authoryear]{biblatex} \addbibresource{biblatex-examples.bib} \makeatletter \newcommand\Setmaxbibnames[1]{\renewcommand\blx@maxbibnames{#1}} \...


7

To change the truncation criterion for using "et al." in a citation callout, from a piece having three or more authors to it having four or more authors, it is necessary to modify the function format.lab.names in the bibliography style file. I suggest you do the following: Make a copy of the version of jf.bst you've been working with so far. Name the copy,...


7

According to authors instructions for Lecture Notes in Computer Science, you must use \email{<email address>} within \institute{} and therefore you should not obtain the style that you are looking for(*). Compile llncs.doc (in spite of the extension, is really a LaTeX file) with pfdlatex to see the instructions for authors. This is a MWE extracted ...


6

Here's one more MWE showing a solution. Note especially a) that the problem is not related to Xe(La)TeX b) how I used the filecontents package/environment to add a .bib file and make the exampe compilable. Your desired citation format boils down to turning off name list disambiguation (uniquelist=false). See section 4.11.4 of the biblatex manual for details....


6

Like @mico said, a sure way to do this is to create the .bst file with makebst.tex. For those who use natbib, I created a file on my own with the folloowing features: in the list of references, for every entry the list of authors is truncated after the third one in a citation, the list of authors is truncated to first author et al. for three or more ...


6

You can use \makeatletter \numdef\blx@maxbibnames{99} \makeatother \printbibliography \makeatletter \numdef\blx@maxbibnames{1} \makeatother \printbibliography The line \numdef\blx@maxbibnames{x} is the command executed by the option maxnames=x. Thus in the first case, it will print 99 names before switching to et al, in the second case, it will do the ...


6

If you want to be able to make full use of all of biblatex's features for \fullcite, namely pre- and postnotes, you might want to try this version. We temporarily set maxcitenames to maxbibnames; apparently, there is no need to re-set the counter, because everything is wrapped in a group, so the assignment is locally. A simpler solution than the below ...


Only top voted, non community-wiki answers of a minimum length are eligible