Hot answers tagged

4

There are actually two issues to solve: There's a problem with latexmk so that it fails to call bib2gls if the .glstex file doesn't exist; this is the situation where the .glstex file needs to be created from scratch. The problem is latexmk doesn't recognize the message in the .log file about a missing file. (The message isn't in one of the formats ...


4

I recommend a different approach that uses a custom entry type and fields. This makes it more flexible so you can use the same .bib file across different documents, and with a different set of aliases you can get different results according to particular document requirements. For comparison, I've also added a Brazilian abbreviation: @acronym{ABNT, short =...


3

Most of the resource options aren't cumulative. That is, if used multiple times the last option usually overrides the previous option of the same name. This means that: entry-type-aliases={symbol=symbols}, entry-type-aliases={notation=notation}, is equivalent to just: entry-type-aliases={notation=notation}, You need to have all the aliases in ...


3

On windows I had to inform java that utf8 is wanted by setting an environment variable JAVA_TOOL_OPTIONS="-Dfile.encoding=UTF8" After this setting bib2gls reports: Picked up JAVA_TOOL_OPTIONS: "-Dfile.encoding=UTF8" bib2gls version 2.7 (2020-07-11) Reading test-utf8.aux Reading test-gloss.bib and the glstex contains the correct utf8.


3

This bug is now fixed in version 1.33 of glossaries-extra (2018-07-26). A patch for older versions is to redefine \ifglsused as follows: \renewcommand*{\ifglsused}[3]{% \glsdoifexists{#1}{\ifbool{glo@\glsdetoklabel{#1}@flag}{#2}{#3}}% } The base glossaries package just defines this command as: \newcommand*{\ifglsused}[3]{% \ifbool{glo@\glsdetoklabel{#...


2

You need at least glossaries-extra version 1.36 and bib2gls version 1.7. File entries.bib contains: @entry{sample, name={sample}, description={an example} } or (if you don't want a description) just: @index{sample} File test-supp1.tex: \documentclass{report} \usepackage[colorlinks]{hyperref} \usepackage[record % requires bib2gls ]{glossaries-extra} ...


2

Load the glossary later so that the callback has a chance: \documentclass{article} \usepackage{filecontents} \begin{filecontents}{glossary.bib} % Encoding: UTF-8 @entry{replacement, name = {Replacement of dark in name field}, description = {Replacement of dark in description field.}} \end{filecontents} \usepackage{luacode} \begin{luacode} function ...


2

The same problem can be demonstrated with a much smaller example: \documentclass{article} \usepackage[colorlinks,linkcolor=blue]{hyperref} \usepackage[ocgcolorlinks]{ocgx2} \usepackage{graphicx} \newcommand{\myfmt}[1]{\scalebox{.35}{#1}} \begin{document} \hypertarget{test}{Test Target}. \hyperlink{test}{Test Link}. \hyperlink{test}{\myfmt{Test Link}}. ...


1

The bib2gls manual mentions the following on the first page: Note that bib2gls is a Java application, and requires at least Java 81. [...] 1 The List.sort method used to sort the entries was only introduced to Java 8. The error message Unsupported major.minor version 52.0 is a check that the Java interpreter performs to see if the version set as a target ...


1

Exception in thread "main" java.lang.NoSuchMethodError: java.util.Vector.sort(Ljava/util/Comparator;)V This indicates that the Java library java.util.Vector doesn't have the sort(Comparator) method. This method was apparently introduced to the Vector class in Java 8, so is unavailable for older versions. You therefore need to update your version of Java.


1

set-widest looks for the widest name (bib2gls documentation, page 86). However, acronyms have no name field. One solution is to copy the short field to the name field by adding replicate-fields={short=name} to the \GlsXtrLoadResources[…] that adds your acronyms. So, it would read: \GlsXtrLoadResources[ src={no-interpret-preamble,acronym},% bib files ...


1

You should find some warnings in the transcript: Package glossaries-extra Warning: Glossary type `acronyms' doesn't exist on input line 65. Package glossaries-extra Warning: No entries defined in glossary `acronyms' on input line 65. The label for the acronyms glossary is acronym not acronyms so you need: \printunsrtglossary[type=acronym,style=alttree,...


1

I won't claim that the docu is very clear here. But it seems to work if you set the sort-field to group and perhaps a second field as sort-suffix. The bib2gls-call was bib2gls --group file (the --group option isn't really needed in this example, but if you have entries without group field, it will create a title for them). \documentclass{article} \...


1

Ok, I found the problem: wenn running the bib2gls command, there was a space character between the % and the .aux. So the complete command to convert the .tex is now: lualatex.exe -synctex=1 -interaction=nonstopmode %.tex bib2gls %.aux lualatex.exe -synctex=1 -interaction=nonstopmode %.tex and it works ;) Thanks and greetings!


1

With ocgx2 package option ocgcolorlinks, portions of the link text that are scaled or put in frameboxes, as well as graphics included with \includegraphics need special treatment. Just put \ocglinkprotect{...} around them. In the present case: \newcommand{\myfmt}[1]{\ocglinkprotect{\scalebox{.35}{#1}}}


1

This should now be fixed in version 1.6 (2018-07-07), which I've just uploaded to CTAN (so allow a few days for it to reach the TeX distributions).


1

There was a bug in earlier versions of glossaries-extra that meant that commands like \glsxtrlong weren't writing the record to the .aux file correctly. This was fixed in version 1.30, so make sure you have the latest version.


1

Abbreviation styles must be set before the abbreviations are defined. Since they are defined in the .glstex file input by \GlsXtrLoadResources they need to be set before that command: \documentclass{article} \usepackage{polyglossia} \setdefaultlanguage{spanish} \usepackage[svgnames]{xcolor} \usepackage{filecontents} \usepackage[spanish]{varioref} \...


Only top voted, non community-wiki answers of a minimum length are eligible