15

This is caused by a change in the biblatex test for an old system. The previous conditional was called \ifblx@load@version@one and is used in the biblatex-chicago style. The new conditional is called \ifblx@load@version@legacy. You can temporarily solve the problem in the following way by adding the following to your preamble, after loading biblatex. \...


13

If you are looking for a one-shot solution, you could add execute={\expandafter\def\csname abx@lstr@byeditor\endcsname{Herausgegeben vom}} to your bib-entry. A more general solution would need some switches in the language strings (\ifwhatever{vom}{von}) and some bib field to set this switches -- possible but unclear if it is really worth the time ...-...


9

editor roles can be defined by defining three bibstrings for standard biblatex (see Create new editorial role "organizer" in biblatex, biblatex: Adding an editor as a series editor, not general editor) and an additional fourth string for biblatex-chicago (see biblatex-chicago: Change translator and editor description in the bibliography, Expand new ...


8

This is one of the limitations of biblatex's localisation system. As a dirty fix you can include 'dem' into the editor field editor = {{dem Fachverband Latexology} and Doe, John}, This will give good output only if the editor is used in the 'herausgegeben von ' position. If it is used as in ' (Hg.)' this will not work correctly. Since the citations give ...


7

This is possible with biber's tool mode. Suppose your .bib is "test.bib" and you have the following in "test.conf" (this is just the config file version of the "nyt" sorting scheme - see the biblatex/biber PDF docs about this). <config> <!-- nyt SORTING --> <sorting> <presort>mm</presort> <sort order="1"> ...


7

You are looking for \DefineBibliographyExtras{english}{\stdpunctuation} biblatex-chicago maps both english and american to cms-american.lbx. cms-american.lbx inherits its bibliography extras from american.lbx which does \DeclareBibliographyExtras{\uspunctuation}. \uspunctuation turns on the American quoting style where punctuation always goes inside the ...


7

Update Here's a version that keeps the author and title separate. It copes with different languages OK. I've also kept your source map and used the source map to set the sortkey to title so that entries are sorted by title rather than author. The relatedoptions={dataonly,useditor=false,usetranslator=false} ensures that the related entry does not appear in ...


6

In biblatex 3.3 the name formatting code changed quite dramatically, see Biblatex 3.3 name formatting. In your case that means that we need \forcsvlist{\listadd\nameaffixlist}{Junior,Senior} \newcommand{\ifnameaffix}[1]{% \ifboolexpr{ test {\ifrmnum{#1}} or test {\xifinlist{#1}{\nameaffixlist}} }} % Based on definitions from biblatex.def \...


6

Unless you have a very good reason not to, you should load the biblatex-chicago styles via the dedicated biblatex-chicago package. Use \usepackage[notes,backend=biber]{biblatex-chicago} instead of \usepackage[backend=biber,style=chicago-notes]{biblatex}. If you load the style via its package, some options are set for you; amongst those are the options for ...


6

We can define two new cite commands \ppracite and \pprbcite. \DeclareCiteCommand{\ppracite} {\usebibmacro{prenote}} {\ifciteindex {\indexfield{indextitle}} {}% \printfield[citetitle]{labeltitle}% \setunit{\addspace}% \printtext[parens]{\usebibmacro{cite}}} {\multicitedelim} {\usebibmacro{postnote}} \NewBibliographyString{pprby} \...


6

While biblatex has made its fair share of backwards incompatible changes (prime example: Biblatex 3.3 name formatting, but I don't think there have been many incompatible changes w.r.t. the input in the .bib file) I think it is fair to assume that year will continue to be supported in .bib files for the foreseeable (and unforeseeable) future. Still using ...


5

You can use biblatex's related features. For that you create a separate entry for the original work with the option dataonly, so it doesn't appear in the bibliography itself. You then refer from the translated to the original work with related = {levi-strauss1964}, relatedtype = {origpubas}, or relatedtype = {translationof},. @book{levi-strauss1968, ...


5

According to the biblatex-chicago documentation this is actually expected and intended behaviour and can be turned off with the preamble option noibid. noibid At the request of an early tester, I have included this option to allow you globally to turn off the ibidem mechanism that biblatex-chicago-authordate uses by default. This mechanism doesn’t ...


5

All you need to do is add an aswellas bibliography string (with definitions) then change the definition of \textcitedelim to use aswellas instead of and for the delimiter before the final citation if the final citation has more than one name in it. Add this to the preamble of your MWE above: \NewBibliographyString{aswellas} \DefineBibliographyStrings{...


5

Given discussion in the comments, substituting Year = {2010} by date = {2010} should be enough.


5

Here's what I get from a slightly modified bib entry. \begin{filecontents*}{\jobname.bib} @Book{thompson1972fearandloathing, author = {Hunter S. Thompson}, title = {Fear and Loathing in {Las} {Vegas}}, year = {1972}, editor = {Ralph Steadman}, subtitle = {A Savage Journey to the Heart of the {American} Dream}, ...


5

You could locally set giveninits=false for Arabic names. We only need to define giveninits as an entry option for this to work. \documentclass{book} \usepackage[notes,backend=biber,giveninits=true]{biblatex-chicago} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @book{ghazali1999, title = "Ihya Ulum al-Din", author = "Abu Hamid ...


5

As it turns out this is a bit more complicated than I initially thought. It is possible to sort this out for the standard style authoryear-comp as shown below, but I'm a bit more sceptical about biblatex-chicago. Since version 0.5 biblatex-ext includes the styles ext-authoryear-ecomp and ext-authoryear-iecomp with native compression of extradate lists ...


5

In the standard styles you could turn off the dash with the option dashed=false, see Get full name twice in Bibliography. The styles of biblatex-chicago do not know that option and do not allow you to turn the dash off easily. It is a feature of the Chicago Manual of Style bibliography styles that they replace subsequent mentions of the same author list ...


4

The biblatex-chicago package has been updated to version 0.9.9h 2016-03-22. According to the package documentation, this update specifically addresses incompatibilities with biblatex, version 3.3. The biblatex-chicago package is now available through CTAN: http://www.ctan.org/pkg/biblatex-chicago


4

There is both a global and facultative solution available. The global solution is to use the noibid option at package load time: \usepackage[backend=biber,authordate, noibid]{biblatex-chicago} The ad hoc solution is to precede your citation commands with \mancite: second citation \mancite\autocite[4--8]{denning2010computation} (Note that there is also ...


4

The trick is cmsdate=both, no macro needed: \documentclass{article} \usepackage[authordate,backend=biber]{biblatex-chicago} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @Book{hume1739, author = {David Hume}, editor = {David Fate Norton}, title = {A Treatise of Human Nature}, publisher = {Oxford University Press},...


4

The macro \biburlsetup sets \Urlmuskip to 0mu plus 3mu, which is responsible for the space stretching. Here's a way for reverting the choice, but of course you'll get an underfull line. \documentclass{article} \usepackage[margin=1in,paperheight=3in]{geometry} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @Book{Example, author={Authorson, ...


4

TeX Live keeps backups of packages by default so that you can revert changes in case an update causes problems. tlmgr restore biber will list available revisions for biber Available backups for biber: 42078 (2016-12-22 15:30) I have the number of backups made automatically set to 1. I don't recall whether this is the default or not. Similarly, tlmgr ...


4

biblatex-chicago's date handling is very complicated to make sure it conforms to CMS standards, so it is not at all easy to change that. The following seems to be the safest and shortest redefinition - in very few cases it could lead to undesirable results though, but I have yet to come across one of those cases. \begin{filecontents*}{\jobname.bib} @...


4

You can do this via \defbibcheck, but I'd think it rather a fragile/unreliable way of separating primary and secondary sources. What will you do with (e.g.) a 1995 edition of Cicero? Anyway, the following example is taken straight from the documentation \defbibcheck{late}{ \iffieldint{year} {\ifnumless{\thefield{year}}{1900} {\skipentry} {}} ...


4

An alternative to setting date=year is to delete the month and date info in the date field via Biber sourcemapping \DeclareSourcemap{ \maps[datatype=bibtex]{ \map{ \step[fieldset=month, null] \step[fieldsource=date, match=\regexp{([0-9]{4})-([0-9]{2})(-[0-9]{2})?}, replace={$1}] } } }


4

Here is a solution, with xpatch and a hack: to avoid a spurious space for a techreport without number, set number={\unskip}. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @techreport{johndoe1_techreport, title = {first report}, author = {Dow, John}, year = {2017}, institution = {...


Only top voted, non community-wiki answers of a minimum length are eligible