Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

New answers tagged

1

As David Carlisle has already pointed out in a comment, URL-1 is followed, in the ASCII table, by URL-10 and URL-11, not URL-2 and URL-3. There is a well-established device for overriding the default sorting order in a bibliography that's processed by BibTeX: prefix the actual author's name with a suitably chosen \noopsort directive. Here, \noopsort should ...


0

A wild guess: the space you see before 'and' is not a space, but the unicode unbreakable space U+00A0. Try to delete the character and insert a real space.


1

Well, following your given link one get the following screen: For me it is very clear that this bibliography is/was build for bibtex and not for biblatex and/or biber. Now it seems that this 8 MB (sic!) great bibliography contains error as you can see in your cited error message in your comment: syntax error: found ";", expected end of entry ("}" or ")")...


2

You can split your bibliography and then append keywords to identify different bibliography entries. A MWE: \documentclass{article} \usepackage[american]{babel} \usepackage[backend=biber, bibencoding=utf8, style=apa, natbib=true]{biblatex} \DeclareLanguageMapping{american}{american-apa} \usepackage{filecontents} \begin{...


0

The culprit here is the combination of author-year style and bst file model1a-num-names.bst, which is usually used with numbered labels ... But there is the following workaround: %% Numbered without titles % <========================================== \bibliographystyle{model1a-num-names}\biboptions{authoryear} % <======== So with the following ...


0

We know that et al. is Latin, and should thus appear in italic. Thing is author={Alpher, R. and others} generates et al. as a normal font and not italic. A quick, also dirty fix, modified from the above is the following: author = {Smith {\textit{et al.}}, Fred}


-1

I had the same problem that you are describing, and didn't have '\nocite{*}' anywhere in my document either. I managed to fix this by deleting the files with the same name as the .tex file but with the following extensions: .aux .bbl .blg .log .pdf .synctex.gz


1

See documentation of endfloat for more optional arguments. You can change the bibliography to your simple use of the environment thebibliography \documentclass{book} \usepackage{biblatex} \addbibresource{biblatex-examples.bib} \usepackage[nolists,nomarkers]{endfloat} \usepackage{blindtext} \begin{document} \blindtext \begin{table} \centering \caption{...


1

Your question and desired output are not quite clear, but this might get you started. The example output is taken from https://sblhs2.com/2017/03/02/separating-multiple-series/. I'm not sure if things should be different for a sub-category as you've asked about here. But you could ask a question on the SBL Blog. \documentclass{article} \usepackage{...


0

Try \documentclass[review]{elsarticle} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @INCOLLECTION{Debreu, author = "Debreu, Gérard and Doe, J. and Doe Dor A.", title = "On the use in economic theory of some central results of mathematical analysis", booktitle = "Advances in mathematical economics", volume = "1",...


1

Load xurl (after biblatex): % arara: pdflatex % arara: biber % arara: pdflatex % arara: pdflatex \documentclass{report} \usepackage{filecontents} \begin{filecontents*}{sample.bib} @online{lovelace2015low, author = {Lovelace, Will}, title = {{Low SCR Wind Integration and Mitigation}}, url={http://www.cce.umn.edu/documents/CPE-...


1

In a comment, you wrote that the objective is to make sure that the URL is not underlined or otherwise appear as a hyperlink An easy way to achieve this objective is to set urlcolor=black in the hypersetup instruction, i.e., to change \hypersetup{citecolor=DodgerBlue3, urlcolor=Blue1, colorlinks=true} to \hypersetup{colorlinks, citecolor=DodgerBlue3, ...


1

Replacing \url with \nolinkurl in the field macro: \begin{filecontents*}{samplea.bib} @misc{CIGREConnection2016, title = {{Connection of Wind Farms to Weak AC Networks}}, howpublished = {CIGRE Brochure}, year = {2016}, month = {Dec}, url = {https://e-cigre.org/publication/671-connection-of-wind-farms-to-weak-ac-networks}, urldate = {...


1

Just write author = {Lovelace, Will}, The double braces in author = {{Lovelace, Will}}, stop Biber (and BibTeX) from parsing the name as the name of a person with family and given names. Instead the name is just interpreted as consisting of the family name "Lovelace, Will". This is desirable for corporate authors (see Using a 'corporate author' in ...


3

Well, I have only \bibliographystyle{model5-names} installed on my system (so please check the available bibliography styles by your own for the needed display of informations they want -- or better ask them which bibliography style you should use -- they should know best!), but the real culprit in your case is that you have to use command \citep{...


3

As @Bernard has already suggested in a comment, you should replace \usepackage[hyphens,spaces,obeyspaces]{url} with \usepackage[obeyspaces]{xurl} Loading the xurl package instead of the url package allows URL strings to be line-broken not just a hyphen and space (and slash) characters, but at any character. I would still specify the option obeyspaces, ...


2

Well, based on the class cta-author.cls of IET and the included file iet.bst there I created the following mwe for testing purposes: \RequirePackage{filecontents} \begin{filecontents*}{\jobname.bib} @misc{MatlabSignalAnalysis, author = "Mathworks", title = "Practical Introduction to Time-Frequency Analysis", howpublished = "https://...


1

Don't have the reputation to post as comment to the above. Stumbled upon this post with a similar problem (in my case a leading .). I discovered that by changing the .bib file keys (i.e. lammps, lammps_manual_fix_langevin in your case) such that they differed in their first letter (i.e. a_lammps, lammps_manual_fix_langevin) resulted in complete removal. \...


2

I propose a much more flexible approach: \begin{filecontents}{\jobname.bib} @article{article1, title={Title 1}, author={Author1}, journal={Journal1}, year={2019}, keywords={Red} } @article{article2, title={Title 2}, author={Author2}, journal={Journal 2}, year={2019}, keywords={Blue} } \...


1

same technique as in https://tex.stackexchange.com/a/228333/190358 also works here: \documentclass[a4paper,10pt]{article} % \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @article{article1, title={Title 1}, author={Author1}, journal={Journal1}, year={2019}, keywords={Red} } @article{article2, ...


1

\documentclass{article} \usepackage{biblatex} \addbibresource{biblatex-examples.bib} \defbibentryset{aristotle}{% aristotle:anima,aristotle:physics,aristotle:poetics,aristotle:rhetoric} \begin{document} foo.~\cite{aristotle}. bar.~\cite{set}% defined in the biblatex-examples.bib \printbibliography \end{document}


2

Your example document yields a number of error messages pointing to the line after \begin{thebibliography}. The correct usage of his command is \begin{thebibliography}{<width of widest label>}, so you can see that the second option is missing in your example. \documentclass{article} \begin{document} \begin{thebibliography}{11} \bibitem{Alpha} Alpha, ...


1

A comment up front: I don't use Overleaf, I don't even have an account there. Hence, I cannot access the URL you provided in a comment. If you wish people to see the code you work with, you should provide it as ASCII text in the body of your query rather than as a link to a site that's not easily and immediately accessible. To retrieve the complete bibtex ...


1

It makes more sense to use the package biblatex together with biber: \RequirePackage{filecontents} \documentclass{book} \begin{filecontents*}{\jobname.bib} @article{Shaffer2004, author = {Shaffer, David Williamson and Squire, Kurt R and Gee, James P}, journal = {Phi Delta Kappan}, pages = {104--111}, number = {2}, title = {{Video games and the ...


0

There are quite a few good answers here, but I wanted to share what I do. First, I use this site as a reference for what each entry type is intended to be used for. Here are useful excerpts: incollection: A part of a book having its own title. inbook: A part of a book, e.g., a chpater, section, or whatever and/or a range of pages. book: A book ...


0

There are no dots in your example, but to remove the page number: \documentclass[a4paper,12pt]{book} \begin{document} \tableofcontents \renewcommand\bibname{Bibliographie} \chapter*{Bibliographie} \addtocontents{toc}{{\bfseries Bibliographie}} \renewcommand{\bibname}{} \begin{thebibliography}{99} \end{thebibliography} \end{document}


1

Name fields are special and can not be tested with \iffieldequalstr. In my opinion the best way to test for a certain name is by testing with name hashes, see Highlight an author in bibliography using biblatex allowing bibliography style to format it. There are some subtleties if we do that, though, we can test for the full author list or just for one name ...


2

In your example the \end{document} is missing. If I insert this, it seems to work. This report provides the results blah blah blah.\cite{edgeRRef} outputs This report provides the results blah blah blah.[1]


1

The error message would show where the problem is, but you have not shown it, normally it is due to math-only character such as _ which tries to start a math subscript rather than using \_ to produce _.


0

Well, it seems you copied several parts of your shown code from several internet documents not understanding what they do. Please do not do that, use only code you understand! Otherwise you will get results you can not correct! That is very problematic, because you used commands which can not work together. See for example the code snippet: \usepackage[...


1

The following worked for my natbib-powered document (it's the code OP used on How to show Not cited and Cited i times on pages ..., in the bibliography when using biblatex?). Just paste this somewhere in the preamble and you can easily see in the references which entries are the most and least cited. \usepackage[pagebackref=true]{hyperref} \renewcommand*{\...


3

Use xurl package. \begin{filecontents*}{sample.bib} @online{savitsky1976procedures, title={Procedures for hydrodynamic evaluation of planing hulls in smooth and rough water}, author={Savitsky, Daniel and Brown, P Ward}, journal={Marine Technology}, volume={13}, number={4}, pages={381--400}, year={1976}, url={https://www....


0

There are several issues with the shown .bib file. Some of them are fatal. The journaltitle of 2 has two closing curly braces. It reads journaltitle = {Journal of Economic Dynamics & Control 23 (1999) 1517}1543}, but was probably intended to be (this is still not correct, see the next point) journaltitle = {Journal of Economic Dynamics & Control ...


1

The apacite package has the option numberedbib for that. Load the package as \usepackage[numberedbib]{apacite}


1

With an current tex distribution you can use package xurl like this (see marking <==== in the code): \begin{filecontents*}{sample.bib} @online{lovelace2015low, author = {{Lovelace, Will}}, title = {{Low SCR Wind Integration and Mitigation}}, url = {http://www.cce.umn.edu/documents/CPE-Conferences/MIPSYCON-PowerPoints/2015/...


1

The following solution is virtually identical to the one recommended for the chicago bibliography style. See natbib: combining chicago style and sorting by appearance and the associated answer [shameless self-citation alert!]. Locate the file agsm.bst in your TeX distribution. Make a copy of this file and name the copy, say, agsm-unsrt.bst. Open the file ...


0

Firstly, If you do not know how to generate website citation, use any online generator citation (for example, http://www.citationmachine.net). Secondly, create your your_ref.bib file (if you do not know, you can use mendely to export your_ref.bib file). Thirdly, replace ( \bibliography{your_ref.bib} instead of \bibliography{your_external_BibTeX_file}


0

The typographic behavior you've noticed occurs because you didn't provide an author field for the entry, forcing the apacite package and associated bibliography style to display the title field in the citation call-out. And, as you've "discovered", the title field is set to be typeset in italics. An inspection of the contents of https://www.tagesschau.de/...


1

You are looking for shortauthor. The shortauthor field can contain a 'shorter' (abbreviated) version of the author field. There is also shorteditor, which does the same thing for editor. \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{csquotes} \usepackage[style=authoryear, backend=biber]{...


1

It works with an additional set of {} around the inner \cite: \documentclass{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @article{angenendt, author = {Angenendt, Arnold}, title = {In Honore Salvatoris~-- Vom Sinn und Unsinn der Patrozinienkunde}, journaltitle = {Revue d'Histoire Eccl{\'e}...


2

If your TeX distribution features the xurl package, you should use it. \documentclass[conference]{IEEEtran} \IEEEoverridecommandlockouts \usepackage{xurl} \title{my title} \begin{document} \maketitle \section{Section 1} Paper~\cite{Nsight18} shows \dots \begin{thebibliography}{00} \bibitem{Nsight18} NVIDIA Nsight Visual Studio Edition, \url{https://docs....


1

I would like to make the following suggestions: Don't use a "fancy" file name -- meaning, no embedded space characters and no TeX-special characters such as & -- in the name of the tex file. Thus, rename the file groups & representations.tex to, say, groups.tex. Don't use a fancy file name for bib file either. groups & representations ref.bib is ...


Top 50 recent answers are included