4

xscale and yscale are both simply scaling factors. While I haven't looked at the code, it looks like bodegraph has as default 1 unit between the major gridlines on the x-axis (each order of magnitude). And as your diagram covers five orders of magnitude, xscale=7/5 will give a diagram that is 7 units wide, plus the width of the axis labels. The default ...


4

Don't change the .sty file. bodegraph sets up a series of styles that can be used to modify how things look, for example \documentclass{article} \usepackage{tikz} \usepackage{bodegraph} \begin{document} \begin{tikzpicture}[ gnuplot def/.append style={prefix={}}, % Fixed the issue (prefix was 'gnuplot/\jobname/' before) ] \begin{scope}[ ...


4

Example compiles on my distribution (miktex2.9, gnuplot and windows 7 and texworks as editor). I compile with pdflatex - enable-write18 But, you have to choose xscale and yscale (default unit is cm) for x you have to draw 3 decades, if the desired width is 10cm then xscale=10/3 the same thing for yscale, here you can choose yscale=10/110 (110dB) \...


3

you must not make a single factor decomposition (parfrac) but a factorization of the numerator and denominator then normalize all functions of the first order denominator are programmed with \ POamp {K} {tau} those of the denominator - \ POAmp {K} {tau} If root is specified \ POAMP {K} {-} tau and with bodegraph and the code \documentclass[10pt]{article}...


3

To set the distance between ticks on the y-axis, add \OrdBode{<value>} before \semilog.... In your case, \OrdBode{20}. Then change the last two arguments to the \semilog macro, which sets the lower and upper limit of the axis. To maintain the same overall height, reduce the yscale of the tikzpicture to half. bodegraph also has a \UnitedB macro that ...


2

So the problem is due to the gnuplot software, just installing it won't be enough, it needs to be on Windows PATH. It can be done by checking the box Add gnuplot to PATH during the install procedure or add it manually like shown here


2

For me the answer was to use -shell-escape or -enable-write18. If I understood correctly, this allows PdfLaTeX to run commands on the terminal (in this case to run gnuplot). Since commands could be harmful, this option is disabled by default. To activate it, make sure to pass the option before %.tex (pretty obvious but took me a while)! Finally, my ...


2

If I run your example, named test.tex, with pdflatex test I indeed get no picture, but four files called 1.gnuplot, 2.gnuplot, 3.gnuplot and 4.gnuplot are written out. You need to run gnuplot over them and rerun pdflatex. Or, more easily, run pdflatex -shell-escape test so gnuplot will be called during the LaTeX run. Note that you need gnuplot on your ...


2

A little background: what is PDFTexify? PDFTexify is a WinEdt command and not the name of a compiler. It mimics the behaviour of MiKTeX's texify.exe accessory by running a LaTeX compiler, whose default value is pdflatex.exe as can be seen in the picture below: together with other programs that take care of bibliographies, indexes, glossaries, etc., to get a ...


1

The comments from @koleygr pointed me to the solution. As XeLaTeXify runs Biber and PDFTeXify with with the XeLaTeX engine, by putting in the --shell-escape under the PDFTeXify tab helps fix the issue. Building on what @koleygr said, we also need to include \usepackage{polyglossia} \setmainlanguage{english} \usepackage{avant} \usepackage{microtype} ...


1

if you use bodegraph, you have to use Bodegraph's specific commands to plot the functions. Bodegraph can only trace elementary functions (first order, second order, integrator) in your case, it is enough to remember that your 4th order function is built in a logarithmic diagram like the sum of four first order and two derivations (in log integrations with a ...


Only top voted, non community-wiki answers of a minimum length are eligible