Hot answers tagged

7

The linked answer is still the correct way to do this and still works. We don't get the expected output in the MWE shown in the question because of the .s at the end of the postnote. biblatex does a lot of work to avoid unintentional double punctuation. Firstly, there is the punctuation tracker (\setunit) that only prints punctuation in bibmacros and ...


5

This question was already answered here: How to change "url" to "Available at" for citing a website in BibLatex? I could change the DOI format by using the same process: \DeclareFieldFormat{doi}{Available at\addcolon\space\url{#1}} For the "no italic" part, I was inspired by the question described here: How to put & symbol in ...


4

You should use urldate for this. You are just using the wrong format. All dates in biblatex need to be in the format YYYY-MM-DD (more complex dates are also permissible). Then you just need to change the urlseen string and the urldate format. I also used australian language since you seem to want Australian style dates and (from your other question) ...


4

For future readers of this question, please note that biblatex-ext offers an easier solution to moving around names that does not involve having to patch entry drivers. See the already linked Move names of editors followed by (Ed./Eds.) and a comma before title in biblatex. The name format of the editors after the in is controlled by editorin, you just need ...


3

With the biblatex-ext styles this only needs two lines \renewcommand*{\volnumdelim}{} \DeclareFieldFormat[article,periodical]{number}{\mkbibparens{#1}} then \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{csquotes} \usepackage[style=ext-authoryear-comp, backend=biber]{biblatex} \...


2

natbib defines \cite with \DeclareRobustCommand\cite which causes a problem here. The definition of \cite is now \protect\cite␣ where the name of the internal macro \cite␣ includes a trailing space which I've indicated with ␣. A solution is \expandafter\AdaptNoteOpt\csname cite \endcsname\multcite where the blank after cite is crucial. \documentclass{...


2

The same answer as @Oleg Domanov but also adding a hyperlink to the citation: \documentclass{article} \usepackage[backref=true]{biblatex} \usepackage{hyperref} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @misc{A01, author = {Author, A.}, year = {2001}, title = {Alpha}, } @misc{B02, author = {Buthor, B.}, year = {2002}, title = {Bravo}, } \...


2

My original answer was incorrect as pointed out by @leandriis. I have changed the answer to reflect @leandriis comment. Use the optional argument to \caption \caption[hydro power potential]{\cite{...} hydro power potential} If the optional argument is given then this is what appears in the LoF but not in the caption. The required argument always appears ...


2

The linked question and answer contain the lines \DeclareFieldFormat[article, incollection, unpublished]{pages}{#1} \renewcommand{\bibpagespunct}{\ifentrytype{article}{\addcolon}{\addperiod\addspace}} as you can easily test yourself in \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{...


2

There are a few different ways you can do this: You can change your language to british (or australian) which uses single quotation marks for outer marks. i.e., \usepackage[british]{babel} \usepackage{csquotes} \usepackage{biblatex} Bear in mind that this will also change other language related things like date formats. The other option is to specify the ...


2

The postnote format (page prefix or not etc.) is controlled with the field format postnote. The punctuation between the postnote and the rest of the citation is controlled by postnotedelim. In biblatex 3.13 and above postnotedelim is a context-sensitive delimiter and can easily be switched between \textcite and \parencite. \documentclass[british]{article} \...


2

Getting the delimiter right is a bit tricky, because the punctuation tracker usually prints the last punctuation it gets and the drivers add \newunitpunct after executing the bookauthor bibmacro. We can use \printunit instead of the normal \setunit to work around that. \documentclass{article} \usepackage[style=verbose-trad1]{biblatex} \renewbibmacro*{...


2

If you look at the error message carefully you can see that the exact command LaTeX complains about is \mknormrange. (Usually the offending command is the last in the first line of the error message.) This means you are using an older version of biblatex that doesn't support that command. Replace \DeclareFieldFormat{postnote}{\mknormrange{#1}} \...


2

Future readers of this question, please note that biblatex-ext offers an easier solution to moving around names that does not involve having to patch entry drivers. See the already linked Move names of editors followed by (Ed./Eds.) and a comma before title in biblatex. The parentheses are added (quite clumsily, I must admit) in the bibmacro byeditor:in. A ...


2

This string is hardcoded in biblatex.def: \DeclareFieldFormat{url}{\mkbibacro{URL}\addcolon\space\url{#1}}. So you need to change it in your preamble like this: \DeclareFieldFormat{url}{Available at\addcolon\space\url{#1}} Result:


2

You want author = {{Conflict Memory Displacement}}, to tell the software that this name shouldn't be treated normally, but used as is.


1

(I'm on support staff at Overleaf.) The first step to try is to unlink and re-link your Mendeley account in your Overleaf account settings. Sometimes the connection between Overleaf and Mendeley can be interrupted, and re-linking your accounts can restart the syncing process. If that doesn't work, please write to us at support@overleaf.com. The problem ...


1

The presence of an _ (underscore) character in the URL throws off BibTeX and LaTeX. You should (a) change HOWPUBLISHED = "https://lehrerfortbildung-bw.de/st_kompetenzen/weiteres/projekt/projektkompetenz/methoden/index.htm [11.10.2019]", to HOWPUBLISHED = "\url{https://lehrerfortbildung-bw.de/st_kompetenzen/weiteres/projekt/projektkompetenz/methoden/index....


1

biblatex does not sort name lists. In some disciplines it is common to list authors alphabetically, but this is not always the case and biblatex never meddles with the order given in the .bib file. You can't easily tell biblatex who is the main author in a way that would make biblatex use the main author as the first author, but you can sort of trick your ...


1

I tested this way and seems to work: \DeclareFieldFormat{postnote}{\printtext[bibhyperref]{#1}} MWE: \documentclass{article} \usepackage{xpatch} % \usepackage[style = authoryear-comp, maxnames = 99]{biblatex} \usepackage[backend=biber, % style=authoryear, style=authoryear-comp, % citestyle=authoryear, dashed=false, maxcitenames=2, maxbibnames=99, ...


1

The required modifications are very similar to the ones in Biblatex: How to automatically make in-text citations bold given a condition?, but the basis for the cite macro is the definition from alphabetic.cbx and not from numeric.cbx. Furthermore, we need to redefine labelalphawidth for the bibliography and not labelnumberwidth. \documentclass[british]{...


1

As you mentioned in your question, this is due to the italic shape. This is simply how the & symbol renders in the selected font in italic. Solution You can force the use of upright shape this way: journal={NMEDIAC: Journal of New Media {\upshape\&} Culture}, Here is a comparison using this solution: Opinion You should probably not modify the ...


1

Just Ctrl-F for & in your code and you'll find the line \renewcommand{\compcitedelim}{\addspace\&\space} Indeed if you comment out this line you get back to Smith (1992, 1993) \renewcommand{\compcitedelim}{\addsemicolon\space} Smith (1992; 1993) \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[...


1

The code in the linked question and answer contains the line \renewcommand*{\intitlepunct}{\space} As you can see in the following reduced MWE \documentclass[british]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \usepackage{csquotes} \usepackage[style=authoryear, backend=biber]{biblatex} \renewcommand*{\intitlepunct}{\...


1

With \renewcommand*{\finalnamedelim}{\addspace\&\space} you explicitly request "&" instead of "and" between the last two names in a list. If you don't want the "&", I suggest you just remove this line since the default output is "and" already (the default definition is slightly more complicated than \renewcommand*{\finalnamedelim}{\addspace\...


1

If you are using BibLateX, you can just use the \fullcite command. for example: \fullcite{kumar_exploiting_2010} produces from the bibtex: @inproceedings{kumar_exploiting_2010, title = {{EXPLOITING} {N}-{GRAM} {IMPORTANCE} {AND} {ADDITIONAL} {KNOWEDGE} {BASED} {ON} {WIKIPEDIA} {FOR} {IMPROVEMENTS} {IN} {GAAC} {BASED} {DOCUMENT} {CLUSTERING}}, ...


Only top voted, non community-wiki answers of a minimum length are eligible