New answers tagged

3

I suggest you use the ext-authoryear-comp style, which has an option to do this. ext-authoryear-comp is a drop in replacement for authoryear-comp but with extra features. The option is called innamebeforetitle. See the biblatex-ext manual for details. Also, rather than putting edition = {2nd edn} in your bib file, you should just use edition = {2} and ...


2

The code in your uorbib.sty looks as though it came from Audrey's answer to hyperlink name with biblatex authoryear (biblatex 1.4b). That answer was written with style=authoryear (specifically citestyle=authoryear) in mind. If you want to use style=authoryear-comp, things may not work as expected. Indeed the definition of \textcite is quite a bit more ...


3

There are at least three ways to go about this. Delete fields you don't want to see in \AtEveryCitekey{...} with \clearfield, \clearlist and \clearname. Use a different style (style=authortitle) and patch its cite command to add more fields to citations. Define a new custom cite command that prints only the info you want to see. 1. Delete fields in ...


1

Very common problem. You're adding spaces at every article: \AtEveryCitekey{% \ifentrytype{article}{%<--- \clearfield{title}% \clearfield{publisher}% }{}%<--- } By the way, a4wide is deprecated and should not be used. Use geometry instead, with its easily settable parameters.


3

I think this does what you want in a reasonably robust way: We can declare some new formats to colour the sortname and date: \DeclareNameWrapperFormat{coloursortname}{\textcolor{red}{#1}} \DeclareFieldFormat{colourparens}{\textcolor{blue}{\mkbibparens{#1}}} \DeclareNameWrapperFormat needs at least version 3.12 of biblatex. If you don't want the ...


2

This is because you have two style options and end with the citestyle option in your biblatex set up. style sets both citestyle and bibstyle. Remove them all and just leave style=authoryear-comp: \usepackage[% style=authoryear-comp, maxcitenames=2, giveninits, dashed=false, ]{biblatex} Also, backend=biber is the default and not needed. Using ...


2

The general feature responsible for this is BibTeX's crossref functionality. Not all styles implement this feature in the exact way you envision, but a great many do it in a way that comes close. btxdoc explains crossref as follows (pp. 2-3) BibTeX has a new cross-referencing feature, explained by an example. Suppose you say \cite{no-gnats} in your ...


2

As discussed in the comments I will only tackle issue 1 for now. Since this issue is only about footnotes and not really about biblatex at all, the MWE can be simplified quite a bit. In the standard classes the command \@makefntext can be redefined to modify the output of footnotes. Its standard definition in article.cls is \newcommand\@makefntext[1]{% ...


2

The package mcite (like most other citation or bibliography packages) is incompatible with biblatex, I'm afraid. You can't load both packages together in the same document, biblatex will issue an error about it sooner or later (even if you ignore the error, there is zero chance that biblatex will be able to make use of mcite's interface). biblatex offers ...


1

This uses a similar approach to LokiRagnarok's answer and assumes you'll always end your myEnv environment with an \autocite (or similar; change as necessary). \documentclass{article} \usepackage{biblatex} \newenvironment{myEnv} {\let\oldautocite\autocite \renewcommand{\autocite}{\unskip ''~\oldautocite}% ``\ignorespaces} {\par} \addbibresource{...


1

You can exploit regular expressions: \documentclass{article} \usepackage{biblatex} \usepackage{xparse} \ExplSyntaxOn \NewDocumentEnvironment{myEnv}{b} { \tl_set:Nn \l__razorhall_myenv_tl { #1 } \regex_replace_once:nnN { (.*) (\s\c{autocite}.*) \Z } { ``\1''\c{nobreakspace}\2 } \l__razorhall_myenv_tl \begin{quote} \tl_use:N \...


2

You can add \DeclareDelimFormat{postnotedelim}{\addcolon\space} to your preamble, then use \textcite[postnote]{key}. MWE \documentclass{article} \usepackage[authordate]{biblatex-chicago} \addbibresource{biblatex-examples.bib} \DeclareDelimFormat{postnotedelim}{\addcolon\space} \begin{document} \textcite[112]{bertram} \printbibliography \end{document}


0

Updated for the version where the environment invocation cannot be changed: \documentclass{article} \usepackage[ngerman]{babel} %grqq \usepackage{xpatch} \newenvironment{myEnv}{% \let\oldcite\cite %save original macro \xpretocmd{\cite}{\makebox[0em][r]{\grqq}}{}{}% %prepend grqq to every cite and gobble a bit of space to the left % prepend grqq to your ...


1

By far the best way to do this is to use the ext-authoryear style from the biblatex-ext package. ext-authoryear is a drop in replacement for authoryear style with extra features for customisation. For a similar example not using LyX, see here. Then you just need three lines in your preamble: % load biblatex in preamble because LyX loads it after the ...


3

The biblatex style authortitle is close to what you want. We can make three small changes: Add the date into the citation macro \renewbibmacro*{cite}{% \iffieldundef{shorthand} {\printnames{labelname}% \setunit{\addspace}% \printtext[parens]{\usebibmacro{date}}% \setunit*{\printdelim{nametitledelim}}% \usebibmacro{cite:title}}% ...


2

Removing the "et al." in citations is as easy as removing \usebibmacro{name:andothers} from the labelname name format. But simply suppressing the "et al." in citations without taking care of sorting and the name hashes can lead to problematic results with the disambiguation letter (or rather the lack of a disambiguation letter). The recently released ...


0

Note that typesetting conventions do vary from language to language. E.g. in Spanish a paragraph starts with an indented line, quotes are written '<< ... >>'. Writing English in a template for Brazilian won't come out right.


2

Please have a look at the biblatex documentation, §2.1.1 (Entry Types) Regular Types, as it reads Required fields: author, title, number, year/date Optional fields: holder, subtitle, titleaddon, type, version, location, note, month, addendum, pubstate, doi, eprint, eprintclass, eprinttype, url, urldate It means that the supported fields for @...


1

I solved the first error, and, consequently the second one, the english template encoding was on latin1. I just changed it to utf8x


1

To achieve no color in the hyperlinks use: \usepackage[hidelinks]{hyperref} or: \usepackage{hyperref} \hypersetup{hidelinks} Reference


2

Here's an example document using Arabic as the main language with Polytonic Greek, Hebrew, Coptic, Syriac, and English as additional languages. It also shows how to set up font support for Egyptians Hieroglyphs (this doesn't need language support). biblatex doesn't include support for any of these languages. So if you need references and citations in their ...


1

I finally found the way out. By using {} in the author field in addition to the regular brackets, the full name is displayed. @misc{tur_working, author = {{US Department of Energy}}, title = {How Do Wind Turbines Work?}, journal = {Department of Energy}, year = 2019, url = {https://...


2

You can add the option mergedate=false to your biblatex options. I'd probably be inclined to use \usebibmacro{date} instead of \printfield{year} to be more consistent with the default macro and allow for more flexibility. \RequirePackage{filecontents} \begin{filecontents*}{biblatextest2.bib} @Book{Gali2015, author = {Galí, Jordi}, title = {...


1

Just add the option maxbibnames. \usepackage[% style=authoryear, backend=biber, maxcitenames=2, maxbibnames=99, giveninits ]{biblatex}


1

To get what you want you need to add the following code to your preamble: \DeclareCiteCommand{\citeyear} % <====================================== {} {(\bibhyperref{\printdate})} {\multicitedelim} {} \DeclareCiteCommand{\parencite} % <===================================== {\usebibmacro{prenote}} {\usebibmacro{citeindex}% \...


0

I think I found the solution by trial-and-error by myself. The combination of uniquename=mininit and uniquelist=minyear does only show one author and et al. when the year is different, but does add a,b,c etc. when the authors and the year are identical. So the whole bibtex include is: \usepackage[backend=biber,style=authoryear,mincitenames=1,maxcitenames=2,...


2

Well, you have some errors in your given code I corrected in the following MWE. To solve your issue add the code \DeclareCiteCommand{\citeauthor} {\boolfalse{citetracker}% \boolfalse{pagetracker}% \usebibmacro{prenote}} {\ifciteindex {\indexnames{labelname}} {}% \printtext[bibhyperref]{\printnames{labelname}}} {\multicitedelim} ...


Top 50 recent answers are included