17

The quotes of the font looks like this. That's the font design. \documentclass[english]{article} \usepackage{babel} \usepackage[T1]{fontenc} \usepackage[autostyle]{csquotes} \usepackage{mathpazo} \begin{document} \enquote*{Test} \end{document}


14

You simply have to tell biblatex to use the "American punctuation" for the nynorsk language, that is add the following lines in your preamble: \DefineBibliographyExtras{nynorsk}{% \uspunctuation% } MWE: \documentclass{article} \usepackage{filecontents} \usepackage[nynorsk]{babel} \usepackage[style = american, norwegian = quotes]{csquotes} \usepackage[...


14

Your first example and your second are actually quite different errors. The first is your fault (see Davids answer), but the second is a bug in lilyglyphs lua code. But the problem is not the quote in \directlua. As the command is defined in lilyglyphs the catcode of the " is frozen there and so not problematic. lilyglyphs uses tex.sprint to print the ...


13

You need to pass the autostyle=true option to csquotes: \documentclass{memoir} \usepackage{xifthen, ifpdf, ifxetex} \ifxetex \usepackage{polyglossia} \setdefaultlanguage{spanish} \setotherlanguages{greek, english} \else \usepackage[greek, english, spanish, es-lcroman]{babel} \fi \usepackage[autostyle=true]{csquotes} \begin{document} \enquote{Quoted ...


13

You can use csquotes: \documentclass[spanish,french,ngerman,american,british]{article} \usepackage[autostyle]{csquotes} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{babel} \begin{document} \enquote{UK English} \selectlanguage{american} \enquote{US English} \selectlanguage{spanish} \enquote{Spanish} \selectlanguage{french} \enquote{...


13

It is not csquotes fault, it is a problem in the OT1-fonts: The kerning is missing if the quote symbol is entered directly and not through a ligature: \documentclass{article} \begin{document} of'' of\char"22 of\textquotedblright \fontencoding{T1}\selectfont of'' of\char"11 of\textquotedblright \end{document} So this is another reason not to use OT1-...


12

The package csquotes can be responsible for deciding when it is necessary to switch from an in-line quotation to a 'block' or 'display' format. For this to work, you need to use the quotation commands it provides that are designed to to this --- notably those commands that have block in their name: \blockquote \foreignblockquote \hyphenblockquote \...


12

I find this way is very convenient: package: \usepackage[frenchb]{babel} in text: \og text \fg{}


12

The problem comes from csquotes. Either set the quoting style on loading, via \usepackage[style=english]{csquotes} or if this is only a problem in the bibliography itself, issue \setquotestyle{english} just before \printbibliography. \documentclass[12pt,a4paper]{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[style=english]{...


11

I don't actually think blockquote is an environment, it's meant to be used as a macro, i.e. \blockquote{the quote}. csquotes defines a displayquote environment for this sort of thing, and redefining \mkbegdispquote to include \itshape makes it italic. \documentclass[paper=a4, fontsize=11pt]{scrartcl} \usepackage{csquotes} \renewcommand{\mkbegdispquote}[2]{...


10

For the Harvard citation style I'm using something like this right now: \blockquote[{\cite[109]{key}}]{Some interesting quote.} For me it delivers the desired result: Quote (Name + Year, p. 109) It should also work for \textquote, but mind the extra {} inside the [cite] option from the standard form: \blockquote[cite][punct]{text}tpunct Without them it ...


10

Although the csquotes package allows you to define certain characters as "active" quotes, as your sample document does for the " character, the single quote character cannot be so used, since it is a reserved character in TeX. Since you mention that you are using text from an MSWord document, a better solution in this case would be to encode your source ...


10

Sorry but since you ask, I'd say it was your fault:-) Having made a character active you should have known to make it safe before passing to Lua. For example: \documentclass{article} \usepackage{csquotes} \MakeOuterQuote{"} \EnableQuotes \begin{document} \directlua{print(\string"hello\string")} \end{document} See Ulrike's answer for the second example.


9

The csquotes manual suggests to redefine \mkblockquote, see section 8.7 Hooks for Quotations and Citations. One possibility would be \renewcommand\mkblockquote[4]{\enquote{#1#2#3}#4} which gives the same effect as in this answer. The four arguments of \mkblockquote refer to \mkblockquote{<text>}{<punct>}{<tpunct>}{<cite>} which ...


9

If you want to keep csquotes features, simply switch between the two styles with \setquotestyle[quotes]{german} and \setquotestyle[guillemets]{german} MWE: \documentclass{memoir} \usepackage[german]{babel} \usepackage[ german = guillemets,%quotes,<- I'd like to have both quot. marks in the same document autostyle = true, autopunct, ...


8

Note that the csquotes package allows to define an optional argument for citations in \blockquote and this one can be defined to be a footnote. So, you just have to add \renewcommand{\mkcitation}[1]{\footnote{#1}} in the preamble and use \blockquote[bla...]{\lipsum*[1]...} instead of \blockquote{\lipsum*[1]...}\footnote{bla...} Complete MWE \...


8

The quoting mechanism using " conflicts with the Babel shorthands that German polyglossia sets up. This actually happens also with pdflatex and babel, where the " used for quoting simply kills the babel shorthands without warning. So the method can be recommended neither with babel nor with polyglossia. If you really don't need the shorthands, do \...


8

csquotes has predefined styles based on the language setting. If your language is british, then you get single quotes. Otherwise you could define them manually. You can alter them using \DeclareQuoteStyle as described in the manual on pp. 14--15 (texdoc csquotes). \documentclass{article} \usepackage[british]{babel} \usepackage{csquotes} \begin{document} He ...


8

The characters you're mentioning show that the document is using the obsolete package aeguill. If you really want to get that shape, you can load the necessary fonts and change the definition of \guillemotleft and \guillemotright to use wncyr; but be aware of the fact that you're using guillemets in Cyrillic style. \documentclass{article} \usepackage[T1]{...


8

You can add csquotes end of argument marker to the xspace list of exceptions: \documentclass{article} \usepackage{csquotes} \usepackage{xspace} \makeatletter \xspaceaddexceptions{\csq@qclose@i} \makeatletter \newcommand{\test}{test\xspace} \begin{document} \test. \test, ``\test'' \test \enquote{\test} \test \enquote{\test}. \end{document} But note ...


8

You could change the french style. But be aware that \enquote could e.g. be used in the bibliography. \documentclass[12pt, a4paper, oneside]{book} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{lmodern} \usepackage[french]{babel} \usepackage[autostyle]{csquotes} \DeclareQuoteStyle[quotes]{french} {\itshape\mkfrenchopenquote{\...


8

Here's a solution you maybe have to adjust according to your fonts (the \hspace). \documentclass{beamer} \usepackage[style=british]{csquotes} \def\signed #1{{\leavevmode\unskip\nobreak\hfil\penalty50\hskip1em \hbox{}\nobreak\hfill #1% \parfillskip=0pt \finalhyphendemerits=0 \endgraf}} \newsavebox\mybox \newenvironment{aquote}[1] {\savebox\mybox{#1}\...


8

It is unrelated to csquotes, you see the same for \documentclass{article} \usepackage[obeyspaces]{url} \begin{document} \begin{itemize} \item --\path{C:\Users}-- \item \mbox{\path{C:\Users}x} \end{itemize} \end{document} \path tries to read its argument verbatim, but if it is already in the argument of another command that isn't possible so it ...


7

With \MakeOuterQuote (and \MakeInnerQuote) you can define a single character such as " that is use for opening and closing quotes. With \MakeAutoQuote you must define two distinct characters, such as > and < for opening and closing. In the latter case csquotes can find the quotation level itself. Here’s an example how to use \MakeAutoQuote. By default ...


7

The problem is that csquotes does not know Polish and Latin as you can see in the log file. Package csquotes Warning: No style for language 'polish'. So you will have to tell csquotes what kind of quotation marks you would like to see in a Polish text. You might issue \DeclareQuoteStyle{polish}% I looked it up on Wikipedia, no idea if it's right {\...


7

We can exploit the fact that \em is a switch: \documentclass[a4paper, 12pt,twoside, openright]{memoir} \usepackage{polyglossia} \setdefaultlanguage{french} \setotherlanguage{english} \usepackage{fontspec} \usepackage[autostyle=true,french=guillemets,maxlevel=3]{csquotes} \DeclareQuoteStyle{english} {\mkfrenchopenquote{\guillemotleft}\em} {\em\...


7

Maybe I'm missing something but why not define your active characters to use \MakeBlockQuote instead? I guess this doesn't allow you to specify inner/outer marks specifically but if csquotes is taking care of the nesting in any case, perhaps that is not too much of a problem. (I define both outer and inner but never actually use the inner ones for just this ...


7

You can just use \setquotesyle or more conveniently define a \catquote command: \documentclass{article} \usepackage[english]{babel} \usepackage{csquotes} \DeclareQuoteStyle{english}% {\textquotedblleft} [\textquotedblleft] {\textquotedblright} [0.05em] {\textquoteleft} [\textquoteleft] {\textquoteright} \DeclareQuoteStyle{...


7

The environment quote is not provided by the csquotes package, only blockquote is. With that being said, you can create a new environment itquote that applies italics to your text. Note that the use of fancyhdr with a KOMA-script class is not recommended. Output Code \documentclass[paper=a4, fontsize=11pt]{scrartcl} \usepackage{todonotes} \usepackage[T1]...


Only top voted, non community-wiki answers of a minimum length are eligible