80

The error you get is due to a "no-break space" character, according to what I can gather by copying an pasting your message. This character is not usually set up by the [utf8] option and it's invisible to many editors, so it can slip in a document without the typist knowing it. Solution: add in your preamble \DeclareUnicodeCharacter{00A0}{ } if you don't ...


60

As this is one of the top google hits for this error message, here's a more general answer with an example: The cause is a unicode character in one of your input files that isn't mapped to an output. This may -- especially if you're using the (unicode-supporting) biblatex/biber system -- be in your bibliography. This is a good place to look for errors as ....


40

For multilingual texts with pdflatex (as opposed to using the xelatex or lualatex engines), the best option is to use the UTF-8 encoding for the input and babel: \documentclass{article} \usepackage[T2A,T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[russian,english]{babel} \begin{document} Text in English \begin{otherlanguage*}{russian} Текст на ...


20

LaTeX Traditional fonts for LaTeX can have only 256 glyphs, which is clearly insufficient to cover multiple alphabets. This is a problem similar to legacy code pages for operating systems. However, LaTeX can use multiple fonts. The problem has been (not completely) solved with introducing font encodings. Leaving out old and outdated seven bit encodings, ...


20

for someone who wants to use just one or two cyrillic letters in math, in a computer modern setting, the old wncy fonts are still distributed in tex live as part of the amsfonts collection, in type 1 format. (but they don't require use of the amsfonts package.) this is the recommendation in the ams author faq. I want to use some cyrillic letters for ...


19

TeX fonts have only 256 slots. And you can't mix encodings without telling LaTeX to do it; \textcyrillic defined by babel with the russian option does this. The last specified encoding becomes the default one. This should be a complete list of sans serif fonts available also in T2A encoding (for cyrillic): \documentclass{article} \usepackage[T2A,T1]{...


19

Some OpenType fonts support also old Cyrillic letters; compile the following with XeLaTeX or LuaLaTeX: \documentclass{article} \usepackage{fontspec} \setmainfont{Old Standard} \begin{document} \raggedright абвгдежѕзиіклмнопрстѹф% хѡцчшщъꙑьѣюꙗѥѧѫѩѭѯѱѳѵ \uppercase{абвгдежѕзиіклмнопрстѹф хѡцчшщъꙑьѣюꙗѥѧѫѩѭѯѱѳѵ} \end{document} I know no way to get the most ...


18

\usepackage[utf8x]{inputenc} Ubuntu: You must install texlive-latex-extra before use it. Fedora: You must install texlive-collection-latexextra before use it.


18

Doing locate /t2a | grep 'texlive/2012/texmf-dist/tex/latex/.*\.fd$' outputs, on my updated TeX Live /usr/local/texlive/2012/texmf-dist/tex/latex/antt/t2aantt.fd /usr/local/texlive/2012/texmf-dist/tex/latex/antt/t2aanttc.fd /usr/local/texlive/2012/texmf-dist/tex/latex/antt/t2aanttl.fd /usr/local/texlive/2012/texmf-dist/tex/latex/antt/t2aanttlc.fd /usr/...


16

Edit 10/2017 Here is a new version of the Lua script. It generates the code for Luaotfload, instead of the font feature file, which is not supported anymore. It has also new option --back, which creates mapping in the opposite direction, like from Cyrillic to Latin in our example. The script is named maptolua.lua: kpse.set_program_name "luatex" local lapp ...


15

These characters are available in font encoding T2A, for example. They can be used without babel: \documentclass{article} \usepackage[T2A,T1]{fontenc} \begin{document} U+04B2: {\fontencoding{T2A}\selectfont\CYRHDSC} U+04B3: {\fontencoding{T2A}\selectfont\cyrhdsc} \end{document} In order to avoid PK-Fonts the package cm-super should be installed.


14

Some fonts don't advertise their features correctly, as far as Polyglossia can understand them. In your case you have to announce that Courier New can be used also for cyrillic monospaced bits: \newfontfamily{\cyrillicfonttt}{Courier New} Notice also that if you should enclose English passages in suitable environment, or hyphenation won't be even attempted....


14

You need to announce LaTeX the languages you intend to use (T2A is for cyrillic): \documentclass{article} \usepackage[T2A,T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[russian,french,english]{babel} \begin{document} In Dahl’s dictionary there is a similar sounding word “\foreignlanguage{russian}{дуван}”. \begin{otherlanguage*}{french} “C’est ...


12

You can use it directly. fontenc works well with XeTeX/LuaTeX. For example, \documentclass{article} \usepackage[T2A]{fontenc} \begin{document} \symbol{"C1} % produce Б \end{document} However, you can't use it with fontspec. A error will be produced: ! Corrupted NFSS tables. Moreover, it is a problem to input Cyrillic text. inputenc cannot be used in ...


12

The method is similar to that one used for Serbian. Prepare the following cyrillic-to-latin.map file: ; TECkit mapping for TeX input conventions <-> Unicode characters LHSName "Cyrillic-to-Latin" RHSName "UNICODE" pass(Unicode) ; ligatures from Knuth's original CMR fonts U+002D U+002D <> U+2013 ; -- -> en dash U+002D U+002D U+...


12

This is not a problem of cyrillic math characters; if the text were English, the correct input would be Letters only \[ \text{Memory: } M_{\textup{add}}(n) = \Theta(N) \] because Память and доп are not math. The difference becomes clear when comparing this with the output of \[ Memory: M_{add}(n) = \Theta(N) \] The bottom formula is clearly wrong. ...


12

this was typeset with luatex: \documentclass{article} \usepackage{fontspec} \usepackage{ifluatex,ifxetex} \setmainfont[Mapping=cyrillic-to-latin]{texgyreadventor-regular.otf} \begin{document} \ifxetex This is XeTeX \else\ifluatex This is LuaTeX \directlua{require("cyrtr")} \fi Hello, world Здравствуй, Мир \end{document} using a cyrtr.lua ...


11

Here is a method for XeLaTeX. Prepare a file ascii-to-serbian.map with the following content: ; TECkit mapping for TeX input conventions <-> Unicode characters LHSName "ASCII-to-Serbian" RHSName "UNICODE" pass(Unicode) ; ligatures from Knuth's original CMR fonts U+002D U+002D <> U+2013 ; -- -> en dash U+002D U+002D U+002D &...


11

Add the line \usepackage[T2A,T1]{fontenc} in the preamble so to have the right font encodings. Thus the MWE \documentclass{letter} \usepackage[utf8]{inputenc} \usepackage[T2A,T1]{fontenc} \usepackage[russian]{babel} \begin{document} \MakeUppercase{English Text. Русский текст.} \end{document} yields the desired result P.S.: The T1 option is not needed ...


11

The character maps of T2A and T1 are identical in the first 128 positions. So english texts should work fine with T2A. But if you want to insert umlauts and other accented chars from the upper part of the char table of T1-encoding you should consider to switch to T1 for such texts instead of relying on LaTeX to fall back to the correct definitions.


10

If you have installed the hyphen-russian and the ruhyphen TeX Live packages, then it can be a problem of non updated formats. From a Terminal window run sudo fmtutil-sys --all and supply your password (assuming you're an administrator of your own machine) when requested. This will recreate all format files and should fix the issue. A note: your example ...


10

There has been some discussion about Cyrillic in math but the issue is still open: https://github.com/wspr/unicode-math/issues/29 As Joseph mentioned you need fonts with the glyph. In case of math (if you don't switch to a text font with \text{..}) you also need to set mathcodes. E.g.; \documentclass[12pt]{book} \usepackage{unicode-math} \setmainfont{Arial ...


9

Your original problem is solved by avoiding Cyrillic in PDF bookmark names. The reason for this is that with inputenc UTF-8 characters are something more than just characters. Instead of \pdfbookmark[0]{Бытие}{Бытие} write \pdfbookmark[0]{Бытие}{Genesis} However, it is easier to use the higher level \addcontentsline command, which not only adds an entry ...


9

Adding to Heiko's excellent answer, one can also input the character directly, provided the file is UTF8 encoded: \documentclass{article} \usepackage[T2A,T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{newunicodechar} \newunicodechar{Ҳ}{{\fontencoding{T2A}\selectfont\CYRHDSC}} \newunicodechar{ҳ}{{\fontencoding{T2A}\selectfont\cyrhdsc}} \begin{document}...


8

Hmm seems like CJK package is making some definitions global when perhaps it shouldn't. You can reset the inputenc settings like so: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T2A,T1]{fontenc} \usepackage{CJK} \begin{document} {\fontencoding{T2A}\selectfont ф} \begin{CJK}{UTF8}{min} ル \end{CJK}% \sbox0{\input{utf8.def}}% {\...


8

Fixed in the inputenc shipped with LaTeX2e 2015/01/01 patch level 1. This isn't directly related to cm but looks like a bug in the core latex utf8 mapping, this fixes it for now \documentclass[varwidth]{standalone} \usepackage[utf8]{inputenc} \usepackage[T2A]{fontenc} \usepackage{xcolor} \makeatletter \AtBeginDocument{% \DeclareUnicodeCharacter{0403}{\@...


8

The more recent TeX distributions provide a Times-like font that supports the Cyrillic and Greek alphabets, loaded through the package tempora. \documentclass{disser} \usepackage[utf8]{inputenc} \usepackage[T1,T2A]{fontenc} \usepackage[english, russian]{babel} \usepackage[babel=true]{microtype} \usepackage{tempora} % Times for numbers in math mode \...


8

You're using the lmodern package, which sets the document fonts to Latin Modern, but it doesn't have support for cyrillic letters. There's Computer Modern Uncode for cyrillic and greek. For XeLaTeX, add \usepackage{fontspec} \setmainfont[ Ligatures=TeX, Extension=.otf, BoldFont=cmunbx, ItalicFont=cmunti, BoldItalicFont=cmunbi, ]{cmunrm} \...


8

In [russian]{babel} there is a mapping for cyrillic alphabetical numbering. Since the question asked for polyglossia I copied the definition of that mapping. Then you can redefine the subfigure counter to use the mapping. MWE: \documentclass[a4paper,oneside,12pt,serbianc]{article} % Serbian language and Cyrillic script \usepackage{fontspec} \...


7

This is a bug in babel, which appears when two cyrillic languages are chosen. I wrote about it in an article published in number 9 of ArsTeXnica, the journal of GuIT, the Italian TeX users group. You can get around the bug by correcting the behaviour of babel: \documentclass{article} \usepackage[T2A,T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[...


Only top voted, non community-wiki answers of a minimum length are eligible