8

You can use latex rather than pdflatex then dvips -E ... will try to generate an EPS file from the resulting dvi. Alternatively use pdflatex then there are several tools available to convert pdf to EPS (almost all wrappers around ghostscript) imagemagic convert for example.


6

{\graphicspath{{./subdir1/}} \input{./subdir1/test}} should work, setting the path in a local group. Note that always in graphicspath, the path components have to end with the directory separator (usually /).


3

Instead of letting LaTeX do it for you, I recommend generating a pdf file first, then convert it to eps file with cmd pdftops -eps filename.pdf If your cmd tells you -bash: pdftops: command not found You should then do the following $ brew update $ brew install poppler As for generating the pdf file, please refer to this answer.


3

If you want to do set encoding iso_8859_1 in the Gnuplot file, you must ensure it is Latin-1 encoded to begin with. I made my test with Emacs, adding the line # -*- coding: latin-1 -*- at the start, which is the incantation for setting the desired file encoding. Other editors have their own methods. I recommend you to switch to UTF-8 for the LaTeX files....


3

If you look at file trkyy.tex (line 114), it says \put(0,0){\includegraphics{trykk}}% which means that it's not enough to change file name, but also its contents. Change this line (in trkyy1.tex) to put(0,0){\includegraphics{trykk1}}% and it will work again.


2

This is a problem with the postscript terminal (which is used by the epslatex terminal). It uses relative coordinates when drawing the plot lines. Since this may give rounding errors, a moveto is issued every 100 points. This interrupts the path, which becomes visible when using dash patterns. The cairolatex eps terminal shouldn't have this problem (The ...


2

You could issue a direct gnuplot command as for example set size 1,0.825. Alternatively you can use something along the lines of \begin{gnuplot}[terminal=epslatex, terminaloptions={size 6cm,9cm}]. Both ways do not change the text size. Besides that note that the cairolatex terminal avoids eps output which can be nice if you use pdflatex anyway and the ...


2

The errors from the syntax checker are all spurious complaining about internal code constructs that probably should not be at the top of level of a document, but are fine (and in some cases necessary) in internal package (and generated) code. You can probably stop the syntax checker following the \input and checking the file by using a custom input command (...


2

In your multiplot you can unset key for the first plot to not get the legend, and for the second plot you can explicitly place the legend using at x,y where x,y are in the co-ordinate system of the plot. This may not be perfect as the resulting EPS bounding box does not seem to include the displaced legend, so you may need to edit the resulting PostScript. ...


2

The input file has \makeatletter which cannot do its work if it's absorbed in the argument to another command, in your case \scalebox. The situation changes if the file is input: the category codes are not frozen as they would when absorbed as an argument. The “solution” is to move the setup part before the \scalebox: \begin{figure} % GNUPLOT: LaTeX ...


1

The .tex file you show seems to be intended for inclusion with \input, as you tried. When you try that, you are getting output on the console and in the log. This is telling you useful stuff e.g. that you need to load things in the preamble such as color.sty. (But better to load \usepackage{xcolor} instead.) The first error I get is ! Package graphicx or ...


1

You're misusing gnuplottex. Run pdflatex -shell-escape on this example: \documentclass[a4paper,12pt,final]{article} % to tamplate \usepackage{gnuplottex} \usepackage{amsmath} \DeclareMathOperator{\erf}{erf} \begin{document} In figure~\ref{fig:erf} we see a plot done by \texttt{gnuplot}. \begin{figure}[htp] \centering \begin{gnuplot} set xrange [-3:3] set ...


1

I think, you are looking for the epslatex terminal. So begin your Gnuplot script with set terminal epslatex set output 'output.tex' then you can use latex notation like set xlabel '$\hat{x}/ \lambda_D$' this should output a .eps file with the plot and and the .tex file where the plot is embedded and the labels are set. You can use it with \input{output} ...


1

I found a solution to this problem in this blog post. You can first download the latest version of the Textext from here and then you should download and install the Eggbot extensions for Inkspace. Copy the two textext file into the extension file of inskspace. Extension directory is located at: /Applications/Inkspace.app/Contents/Resources/share/inkspace/...


1

In order not to have to change all your files, an easier way is to include this in your preamble: \graphicspath{Figures/} In this way, the command \includegraphics{graph} would by default be searching in the Figures path.


1

In order to better understand what's the problem, it's useful to create a standalone .tex file, instead of a file to be included in another document. This can be achieved by adding the standalone option to the set terminal line: set terminal epslatex ... standalone Regarding the problem with the font size, LaTeX supports by default font sizes from 10 to ...


1

For figures - try InkScape - you can save your figure in many formats (this can handle complex figures also). For simple figures try TpX a TeX based drawing programme. Still you can use TeXCad or LaTeX Draw. Choice is yours. For plotting data - R produces eps figures - which can be incorporated in your LaTeX documents. An excellent book on R and LaTeX (...


1

Load each package once only, and don't give the [miktex] option to the gnuplottex pacakge unless you really are using MiKTeX.


1

When the epslatex terminal is used, gnuplot produces an eps file and a separate file containing tex code. This tex code includes the image using \includegraphics, and adds labels etc. using the picture environment. If this code is used in a document that is compiled by pdflatex, the eps file will be converted to pdf before inclusion. If gnuplot creates plot....


1

You are supposed to use the name of the tex file for the output. That is: set output 'sample1.tex' Then the eps file will have the same name, but extension .eps. Also, in some circumstances, one needs to close the output file by adding set output (with no filename) after the plot command.


1

As far as I can understand, you have two options: Using \resizebox to scale the entire contents of the .tex file produced with the epslatex terminal, i.e. \resizebox{\linewidth}{!}{\input{epslatex-file.tex}}. Note that your fonts will also be scaled. Specifying the size of the plots in your gnuplot code, set terminal epslatex size a b where a and b may have ...


1

I don't think that it would be possible to do this easily using the current set of tools (gnuplot and epslatex). The reason is that depending on the dimensions and font size of the final LaTeX document, you would need to calculate manually the dimensions and the font size of the figures. What you require can be easily accomplished using pgfplots, which is a ...


1

As explained in the gnuplot manual When using the TeX or other terminals where formatting information is embedded in the string, gnuplot can only estimate the correctly exact width of the string for key positioning. So you have to manually adjust the legend width with set key width -5 Try different width values to get the best result. Example: set ...


Only top voted, non community-wiki answers of a minimum length are eligible