12

A short writeup of the comments if you use pdflatex T1 with fontenc is still relevant for better use of the fonts. as for utf8 it is now the default has has been for some time, so you ought to be able to drop it. Personally I tend to add it anyways just as a reminder (some editors actually scans the preamble) but also if the document later on might be sent ...


7

Neither the latex format nor the font package itself declares which subset of TS1-encoding the font supports, and so a rather conservative default (9) is used which means that the euro is faked with a C and an equal sign. You can set the subset number, but someone will have to check which one is actually correct (the 7 in the code below is rather ...


7

The problem is that hyperref redefines \textin to mean the symbol ∈ (U+2208), but only for the encoding used in the bookmarks. If you want to keep the name (and don't need the symbol), overwrite the definition again after hyperref: \documentclass{article} \usepackage{ebgaramond} \usepackage{hyperref} \DeclareTextFontCommand{\textin}{\initials} \begin{...


7

If you prepare these two files asking for no PDF compression (call them one.tex and two.tex): \documentclass{article} \usepackage[T1]{fontenc} \pdfcompresslevel 0\relax \begin{document} Gödel \end{document} and \documentclass{article} \usepackage[T1]{fontenc} \pdfcompresslevel 0\relax \begin{document} G\"odel \end{document} and compile them with ...


6

It's Caslon. \documentclass[12pt]{article} \usepackage[T1]{fontenc} \usepackage[french]{babel} \usepackage{librecaslon} \addtolength{\textwidth}{-15pt} \linespread{1.1} \begin{document} \spaceskip=0.4em plus 0.3em minus 0.1em La recherche des points a coordonnées rationnelles (en abrégé points rationnels) sur une variété algébrique est un problème ...


6

Here, I declare a math alphabet \oldmathrm to use OT1 encoding. Then I can access it for \Pi redefinition. \documentclass{beamer} \DeclareMathAlphabet{\oldmathrm}{OT1}{cmr}{m}{n} \usepackage[T1]{fontenc} \let\oldPi\Pi \renewcommand{\Pi}{\oldmathrm{\oldPi}} \begin{document} \begin{frame} $\Gamma\Pi$ \end{frame} \end{document} If you wanted access to both ...


6

Since you are loading fontspec, I presume you are using either xelatex or lualatex. In such a case, don’t load fontenc and declare the font for vietnamese in the following way: \documentclass{memoir} \usepackage[english]{babel} \babelfont[vietnamese]{rm}{TeX Gyre Pagella} \begin{document} Nguyen in English text. \foreignlanguage{vietnamese}{Nguy\~{\^{e}}...


5

You clarify in a comment, “I would prefer to get the same kind of text as in \log \sin \cos etc.” That’s the \operatorname command from amsmath, e.g. \operatorname{min}. You can also \DeclareMathOperator{\min}{min} and write \min. This gives the word you type the same spacing as sin, log and so on, which might not be what you want. Either \mathrm or \...


5

What you have looks fine actually (akthough you probably want to use OT1 not T1 in math as campa noted in comments). The 16 math group limit is 16 fonts per math version so adding two new math versions is exactly the right approach. The issue with the mis-aligned [] is not your fault, it appears to be an error in the txfonts setup that you should perhaps ...


5

You can use a clone of Times that supports ancient Greek and one is available in TeX Live as Tempora. \documentclass [11pt,a4paper,oneside]{book} \usepackage{fontspec} \setmainfont{Tempora} \usepackage{polyglossia} \setdefaultlanguage{italian} \setotherlanguage[variant=ancient]{greek} ...


4

This seems to be a bug in the package, which I'll mention to the author, but what you can do in the meantime is % !TEX encoding = UTF-8 Unicode \documentclass{report} \usepackage[TS1]{fontenc} \usepackage{cochineal} \renewcommand{\texteuro}{{\fontencoding{TS1}\fontfamily{Cochineal-LF}\selectfont \char191 }} \begin{document} Text in Cochineal font, and the € ...


3

It is defined in the LaTeX kernel, line 6834 (release 2020-10-01) \DeclareTextCommandDefault{\textthreequartersemdash}{\tc@check@symbol{9}\textthreequartersemdash} and comes from the formerly external textcomp package. Using lualatex and \showoutput we get ....\TS1/lmr/m/n/10 ^^V and we can also see, from showing the meaning of the font command, \TS1/lmr/m/...


3

You have to set the features for small caps in a boldface context. \documentclass{report} \usepackage{fontspec} \setmainfont{Latin Modern Roman}[ BoldFeatures = { SmallCapsFont = CMU Serif Bold Extended Roman, SmallCapsFeatures={Letters=SmallCaps}, }, SmallCapsFont = Latin Modern Roman Caps, ] \begin{document} Roman. \textbf{Bold.} \textsc{...


3

You want to look your symbol up in The Comprehensive LaTeX Symbols List, or one of the methods here. In this case, Ulrike Fischer found it for you and posted it in a comment: \fullouterjoin from stix (or also stix2). The first argument of \DeclareUnicodeCharacter should have letters capitalized, so 27D4. The second argument should be the command to produce ...


3

Sadly, T1 encoding and Libertine ligatures do not work together when using pdftex. Using the OT1 encoding will give you the nice ligatures but will suppress hyphenation and break kerning in any word containing an umlaut or a ß, and will prevent any possibility of copy/pasting or searching for text in the final PDF document. Note also that not all automatic ...


3

A couple of tools combine to figure out what's going on. First string-functions.com, converts your Ansi strings to the seemingly identical μ and µ respectively (set the input encoding to ISO8859-1 and the output to UTF-8). Copy-pasting from your quoted source also works, but I wanted to start from the known-different characters. Pasting those two mus into ...


3

You're using the text mode = instead of the math mode one. Here's a different implementation that also scales automatically in subscripts and superscripts. You don't need calc, because in the context of \resizebox you can use \width and \height to refer to the dimensions of the box being resized. \documentclass[12pt,a4paper]{article} \usepackage[T1]{fontenc}...


3

Until recently, the only established and typographically widely available way to uppercase an ß was SS, analogously for small caps. Uppercase variants (ẞ) have only been slowly gaining traction in German in the last two decades and only have been allowed as an alternative by the official German spelling rules in 2017 (the spelling rules never mentioned small ...


3

With this kind of Unicode input it is (much) easier to use one of the two Unicode engines, i.e., XeLaTeX or LuaLaTeX (and not pdfLaTeX), and select a font that contains these characters. Example with XeLaTeX and DejaVu Serif as font: \documentclass{article} \usepackage{fontspec} \setmainfont{DejaVu Serif} \usepackage{gb4e} \begin{document} \begin{exe} \...


2

The correct symbol is ` (the backtick). Most fonts render this as an open quote, and so does the font used for the package manual. \documentclass[12pt]{article} \usepackage{phfqit} \begin{document} \[\Hmin`\Big{\bigotimes_i A_i}[B]\] \end{document}


2

As with a great many questions about legacy 8-bit fonts, you can solve the problem by loading the font in a modern format from LuaLaTeX. \documentclass{report} \tracinglostchars=2 \usepackage{fontspec} \setmainfont{Cochineal}[Scale=1.0] \begin{document} Text in Cochineal font but € symbol is ugly 1,99€ \end{document}


2

Thanks to everybody for the quick responses! The problem is resolved now. There were two causes. I had installed MiKTeX using the "Install MiKTeX for anyone who uses this computer (all users)". The install guide recommends against this because it can be "complicated and error prone". They were right! This maintains two profiles and sets ...


2

In today's tex systems embedding is the default, and you need to actively disable it. If you do it, you can see it in the font list. E.g. here I forced helvetica to be not embedded and then it misses the "Eingebettete Untergruppe" keyword: If I switch back to embedding it looks like this (now a clone is used for helvetica):


2

The math fonts for Concrete are in the old-fashioned METAFONT format. Today, these compile to Type 3 bitmap fonts, which look pixelated. This is true even if you use the most up-to-date Concrete package for PDFTeX, ccfonts. (The concmath package has not been updated since last century.) One solution is to use the same fonts Donald Knuth himself did. The ...


2

Thanks for the code. In the future, you’ll be better off removing every part of the preamble that you can, while still demonstrating the bug, and also make sure it compiles (so it’s a Minimal, Working Example.) This helps both you and us: you actually found the location of the bug yourself by removing different parts of your preamble. Also, there’s a \...


2

Latin Modern Roman font does not include a bold small caps variant. You can use the CMR Unicode font. This should work with both xelatex and lualatex: \documentclass{article} \usepackage{fontspec} \setmainfont{CMU Serif} \begin{document} \scshape small caps \bfseries bold small caps \end{document}


2

For completeness, here is how you might do the same thing in the modern toolchain. The \versionsymbol code should work in any engine. \documentclass{article} \usepackage{unicode-math} \defaultfontfeatures{ Scale=MatchLowercase, Ligatures = TeX } \setmainfont{TeX Gyre Pagella}[Scale=1.0] \setmathfont{KpMath-Regular} \setmathfont[...


2

The accent position seems to be just a feature in the font (you see same position without lilygyphs) I shifted it a bit here (actually it is shifted too far I think). The \sharp goes as unicode-math delays all its definitions until begin document and TeX Gyre Termes Math does not have the character, you can re-instate the lilyglyphs version. \documentclass{...


2

You get the error also with the following document: The problem is that the first I is not an I but a Iota (U+0399). \documentclass[12pt]{article} \usepackage[greek, english]{babel} \usepackage[T1]{fontenc} \begin{document} Ι I \end{document} The error message shows you exactly where the problem is. Look how the line break is at the wrong I: ! LaTeX Error:...


2

You can try any of the following: Load your modern font through fontspec and type in the character ą (U+0105). In XeLaTeX or LuaLaTeX, you can also write ^^^^0105. A font might also support the combining accent ą (a + U+0328). You can also type this as a^^^^0328. Latin Modern Roman does not have this accent, but New Computer Modern does. The LaTeX ...


Only top voted, non community-wiki answers of a minimum length are eligible