New answers tagged

0

For me It worked well by just using \hyperref directly with the \addcontentsline. For example I want to add Introduction into the table of contents, we can just do this : \addcontentsline{toc}{chapter}{\hyperref[chap:Introduction]{Introduction}}. chap:Introduction is the label name for specific chapter and Introduction is the custom label. \documentclass{...


3

Array operations of TeX (hence, TikZ) is quite inconvernient. A simple use of arrays of numbers, texts (including colors), points (as pairs of 2 coordinates) is as follows. \documentclass[tikz,border=5mm]{standalone} \begin{document} % array of numbers a[i], i=0,1,2,3 \def\a{{6,8,11,12}} % array of texts b[i], i=0,1,2,3 \def\b{{"blue","red&...


5

pgfkeys can be your array \documentclass[tikz]{standalone} \pgfkeys{ /benis/.cd, 1/.initial=red, 2/.initial=orange, 3/.initial=yellow, 4/.initial=green, 5/.initial=blue, 6/.initial=purple, } \begin{document} \begin{tikzpicture} \foreach \i in {1,2,5} { \pgfkeysgetvalue{/benis/\i}\thiscolor \draw ...


8

As suggested, using the array functionality of TikZ you can get: \documentclass{standalone} \usepackage{tikz} %\usepackage{arrayjob} %\newarray\colours %\readarray{colours}{red&orange&yellow&green&blue&purple} \def\mycolours{{"red","orange","yellow","green","blue","purple"}} \...


3

Thanks to SebGlav, I got something working. I have to type the RGB codes for the colours I want, but that's fine. This code works: \documentclass{standalone} \usepackage{tikz} \usepackage{xcolor} \begin{document} \newcommand{\colours}{{"FF0000","FFA500","FFFF00","008000","0000FF","800080"}} ...


3

In some places you put your \index{} in the wrong column. Also, do not start a column entry with \index{} put it after a word. See below for a revised version of your tabular which is now narrow enough to fit in the textblock. % indexprob.tex SE 606820 \documentclass{book} \usepackage[paperwidth=6in, paperheight=9in, margin=0.8in]{geometry} \usepackage[...


3

Starting a paragraph (in the second/third column) with an \index (which technically doesn't set anything) is the cause of this issue. Instead of using \index{<name>}<name> consider using <name>\index{<name>} \documentclass{book} \usepackage[paperwidth=6in, paperheight=9in, margin=0.8in]{geometry} \usepackage{imakeidx} \makeindex \...


1

The problem here is that by default LaTeX treats a tabular environment as if it were just a letter (in technical terms, it typesets it in horizontal mode).¹ You can see this even more dramatically by slightly modifying your example to read: Some words \begin{tabular}{rp{0.3\linewidth}p{0.3\linewidth}} % ❶ \textbf{Year} & \textbf{Original text} & \...


0

To do that I recommend glossaries-extra with bib2gls. For example, if you have this three documents: MyDoc1.tex \documentclass{article} \usepackage[record,index,postdot]{glossaries-extra} \usepackage{glossary-bookindex} \setglossarystyle{bookindex} %number of columns \renewcommand{\glsxtrbookindexcols}{2} %names for glossaries, there can be more than one \...


0

I found an answer myself, but it is not complete yet. Now only one document is needed. \documentclass{article} \usepackage{makeidx} \usepackage{xpatch} \makeindex \makeatletter \patchcmd{\@wrindex}{\thepage}{\volumenr-\thepage}{}{} \makeatother \begin{document} \newcommand{\volumenr}{I} \index{word1}word1 \index{word2}word2 \index{word3}word3 \index{word4}...


3

Unless I'm missing something, this seems to work just fine \documentclass{memoir} %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% %%%%% try for 3 column index \newif\ifthreecolindex \newcommand{\threecolindex}{\threecolindextrue} \usepackage{multicol} \makeatletter \renewenvironment{theindex}{% \clearforchapter \ifthreecolindex \chapter*{\indexname} ...


0

Just for the record, @Cicada's comment answers my question. \documentclass{book} \usepackage{acro} \usepackage{xcolor} \usepackage{imakeidx} \makeindex[columns = 1] \acsetup{ index/use=true } \DeclareAcronym{asset}{% short=asset, long= underlying asset, index={asset}, } \DeclareAcronym{assetclass}{% short=asset class, long=...


2

There is an excess pair of curly braces around the \DeclareIndexNameFormat{default}. This pair of braces keeps the definition local, which means that it is immediately discarded. So the name indexing does not use your new names index. Remove the curly braces around \DeclareIndexNameFormat{default}. %! MWE Example % arara: lualatex % arara: biber % arara: ...


2

Please, make compilable examples: the definition for DarkPurple is missing and the openleft option does not exist for book. \documentclass[a4paper,11pt,twoside]{book} \usepackage{xcolor} \usepackage{imakeidx} \makeindex[intoc] \ExplSyntaxOn \NewDocumentCommand{\boldindex}{m} { \textcolor{DarkPurple}{\textbf{#1}} \index{\char_titlecase:N #1} } \...


2

You can just put the extra text after \printindex. Below I added a bit of vertical space. \documentclass[12pt]{book} \usepackage{imakeidx} \makeindex \usepackage{idxlayout} \begin{document} \thispagestyle{empty} Sentence\index{Index Entry1} \newpage Sentence\index{Index Entry2} \newpage \idxlayout{columns=2} \printindex \vspace{1cm}\centering\large THE ...


-1

removing \itshape from newcommand*\boldindexhardcode[1]{…}


0

The problem was solved adding \titleformat{name=\chapter, numberless}[block]{}{}{0pt}{\filright \Huge \bfseries}[\vskip4.5pt] to the code.


1

Here is a bit of a hacky solution based on the documentation of the doc package. I'm not sure how well it works, as I don't fully understand everything I've copied from its documentation, but here is what I am using: % \makeatletter % \def\DescribeKey{\leavevmode\@bsphack\begingroup\MakePrivateLetters\Describe@Key} % \def\Describe@Key#1{\endgroup\marginpar{\...


Top 50 recent answers are included