Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
6

XeTeX does have built in support for UTF-32 (and it could be coded in Lua for luatex) For example was produced from \XeTeXinputencoding UTF-32 XXX\XXXdXXXoXXXcXXXuXXXmXXXeXXXnXXXtXXXcXXXlXXXaXXXsXXXsXXX{XXXaXXXrXXXtXXXiXXXcXXXlXXXeXXX}XXX\XXXbXXXeXXXgXXXiXXXnXXX{XXXdXXXoXXXcXXXuXXXmXXXeXXXnXXXtXXX}XXXhXXXeXXXlXXXlXXXoXXX XXXwXXXoXXXrXXXlXXXdXXX\...


5

The pxrubrica package, which originally aimed to provide JLReq-compliant ruby, is the best way to use boten and kenten. Here are a very basic usage and its output (the optional argument s changes the emphasis mark to the secondary one): \documentclass{jsarticle} \usepackage{pxrubrica} \begin{document} \kenten{圏点}と\kenten[s]{傍点}。 \end{document} The package ...


5

First of all, please don't use CJK, because you cannot use better fonts. Use either one of the Japanese engines (platex, uplatex) or lualatex with luatexja. Then please look at the package jfontmaps which gives a long list of fonts supported, both free and non-free. Depending on whether you possess these fonts, Hiragino or Morisawa are good ones. Kozuka you ...


4

Do you have the ST fonts? \documentclass[a4paper,11pt]{article} \usepackage{xeCJK} \setCJKmainfont[BoldFont=STHeiti,ItalicFont=STKaiti]{STSong} \begin{document} Suzuki Matoshi (鈴木眞年). \textbf{Suzuki Matoshi (鈴木眞年).} \textit{Suzuki Matoshi (鈴木眞年).} \end{document} Edit: It seems the ST fonts are for OS X, not linux. Sorry about that. You may be able to ...


4

To long for a comment. I have no problem with your code (compiled with texlive 2018): \documentclass{article} \usepackage{CJKutf8} \begin{document} \begin{CJK}{UTF8}{min} \textbf{こんにちわ} こんにちわ \end{CJK} \end{document} With miktex it doesn't work. Miktex is missing some files. You would need to install them manually.


3

Passing options to caption in \usepackage is fragile; use \captionsetup. \documentclass[ fontsize=12pt, pagesize, parskip=half-, numbers=noendperiod, captions=nooneline, ]{scrartcl} % more packages \usepackage{lmodern} \usepackage[whole]{bxcjkjatype} \usepackage{caption} \usepackage{graphicx} \captionsetup{ justification=centering, tablename=...


3

The original website for Code 2002 no longer exists. fonts2u.com, which has never struck me as a reliable site, provides an old version, version 1.13, of three megabytes, and FontForge reports many errors when opening it. Stanford University hosts a newer version, version 1.16, of 7.5 megabytes, and your minimal example runs perfectly with this version. ...


3

In babel, you can switch between different ideographic alphabets, including Japanese and traditional Chinese: \documentclass{standalone} % Replace with the real class. \usepackage[english]{babel} \usepackage{fontspec} % A bug in Babel 3.22 requires setting the script= option to CJK and Kana, % respectively. \babelprovide{chinese-traditional} \babelprovide{...


3

Really I think it doesn't make sense any more to typeset these large scripts with fonts restricted to 256 characters per font, xelatex and lualatex can both handle Unicode OpenType fonts directly. However this typesets the needed character in pdflatex, producing \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{...


2

You can use your fonts with a short typescript for them. \starttypescript [serif] [heisei] \setups[font:fallback:serif] \definefontsynonym [Serif] [file:HeiseiMinStd-W3.otf] \definefontsynonym [SerifBold] [file:HeiseiMinStd-W7.otf] \stoptypescript \definetypeface [mainface] [rm] [serif] [heisei] [default] [features=default] \definetypeface [...


2

XELATEX XeLaTeX offers the possibility of importing external popular fonts or using the ones you already have in your Operating System: \documentclass{article} \usepackage{xeCJK} \setCJKmainfont{AozoraMinchoRegular.ttf} \setCJKsansfont{KodomoRounded-Light.otf} \setCJKmonofont{KodomoRounded-Light.otf} \begin{document} \section{これは最初のセクションである} 日本語で \LaTeX ...


2

In order to get a .dvi file you need to run latex myfile.tex in your terminal, but this is not going to work with xelatex. For this engine, you should run xelatex -no-pdf file.tex This will produce an .xdv file (an extended .dvi), however there is no "xdvtops", so your main choice becomes pdftops (which you might have to install separately). With it, after ...


2

Since you're sorting according to the romanized version, that makes it easier. (Neither makeindex nor xindy support Japanese, so you'd be limited to bib2gls to sort according to the kanjis/kanas.) I don't have your font, so I've had to substitute it to make the example compile so just change it back again. \documentclass[a4paper, 12pt]{article} \...


2

I do not know why this is, except that it seems like it's the kind of thing that is intended so as not to leave a space at the beginning of a line. But you can work around it by inserting a \strut before the opening bracket: \documentclass{article} \usepackage{xeCJK} \begin{document} \begin{enumerate} \item \strut「あああああああああああああ」  あああああああああああああ。 \...


1

What I see is that the quotation marks are badly treated. Skimming in the documentation I found the following: \documentclass[12pt,a4paper,headings=standardclasses,numbers=noenddot]{scrreprt} %\usepackage{showframe} \usepackage[left=2.50cm, right=2.50cm, top=2.50cm, bottom=2.00cm]{geometry} \usepackage[onehalfspacing]{setspace} \usepackage[main=ngerman, ...


1

I think you have to enclose CJK characters in \begin{CJK} ... \end{CJK} when using CJK package. For example, if you are using pdflatex: \documentclass{book} \usepackage{CJKutf8} \begin{document} \begin{CJK}{UTF8}{ipxm} 「さくら」 \end{CJK} \end{document}


1

The fontspec should be loaded before xeCJK if no-math. And the CJK environment is not provided by xeCJK and thus should be omitted. A minimal example: \documentclass{scrbook} \usepackage[no-math]{fontspec} \usepackage{xeCJK} \setCJKmainfont{Hiragino Mincho ProN} \begin{document} 角谷 静夫 \end{document}


1

\documentclass{article} \usepackage{bxcjkjatype} \begin{document} \begin{uCJK}\UTF{30A1}\end{uCJK} \end{document}


1

I have some time now, so I'd like to post my comment on egreg's answer as my own with some additional information. As egreg guesses, U+2019 is considered to be a Japanese character and the following adjustments are carried out: Switching to Japanese font Insertion of a space between CJK and Latin characters If you want to disable these adjustments, \...


1

The character U+2019 apparently implies a transition to Japanese. It's not clear what rule is followed, but spaces are added at transitions; moreover the character U+2019 in IPAMincho has the same width as kana characters, resulting in very wide space. This doesn't happen when ' is used. \documentclass{article} \usepackage{zxjatype} \usepackage[ipa]{...


1

Let me post this as an answer rather than as a comment because this is too long for a comment. As you say, I think I'm happy to use any of the options, if there's a way to solve the problem. I'll propose a XeLaTeX-based method. There is the fontspec, and it provides \newfontfamily, which defines a new font-switching command. Here is a simple examaple (I'...


1

You have to avoid untimely expanding \begin{CJK}: \documentclass{scrbook} \usepackage{CJKutf8} \usepackage{textcomp} \usepackage[utf8]{inputenc} \usepackage[OT1, T2A]{fontenc} \usepackage{imakeidx} \newcommand{\nameindex}[2]{% \index[name]{#1@\detokenize{\begin{CJK}{UTF8}{min}#2\end{CJK}}}% } \makeindex[name=name, title = {List of Persons}] \begin{...


1

The default font (FandolSong on my system) has no glyph for U+67FB, so the “F-box” appears. Choose a font which provides all the glyphs you need. For instance, my system has YuMincho and this is what I get: \documentclass{article} \usepackage{xeCJK} \setCJKmainfont{YuMincho} \begin{document} 現物\\ 入国審査 \end{document}


1

Remove \CJKnospace: \documentclass[12pt]{article} \usepackage{CJKutf8} \newenvironment{Japanese}{% \CJKfamily{min}% \CJKtilde % \CJKnospace }{} \begin{document} \title{\begin{CJK}{UTF8}{}\begin{Japanese}講道館 柔道 \end{Japanese}\end{CJK}} \author{} \date{} \maketitle \end{document}


1

First, basic information about Japanese LaTeX (not related to TeXnicCenter): Japanese version of LaTeX has two variants. pLaTeX is the traditional one, which can handle only characters in the range of JIS X 0208 (a Japanese Industrial Standard defining coded character sets). upLaTeX is the extended version of pLaTeX, which can handle all unicode characters. ...


1

As I mentioned in a comment above, the author of luatexja fixed this for me; you can download the updated file from osdn.jp/projects/luatex-ja/forums/25558/37917 Hopefully it will be included in the next release.


1

My current solution the CJKuft8 package. I put following in my preamble: \usepackage{CJKutf8} \newenvironment{Japanese}{% \CJKfamily{min}% \CJKtilde \CJKnospace}{} This allows us to open an Environment which can display Japanese characters like this: \begin{CJK}{UTF8}{} \begin{Japanese} 日本語 \end{Japanese} \end{CJK} This environment is also possible in ...


1

[Update 2016-12-18] The file japanese.ldf was only for use with Japanese pLaTeX/upLaTeX until yesterday (thus encoded in ISO-2022-JP), which is the reason why "invalid characters" error occured. Yesterday I (a member of Japanese TeX Development Community) submitted a new version of japanese.ldf, which supports LuaLaTeX/XeLaTeX as well as pLaTeX/upLaTeX. ...


1

There is currently no support for Japanese in Polyglossia (there's work on it, however). The japanese.ldf file you found is for platex (the Japanese version of TeX) and is incompatible with other engines. Here's a minimal working example, to be compiled with ptex2pdf -u -l <filename> Code, note that memoir is not supported. \documentclass[a4paper, ...


1

I don't know how it will work on Mac, but I use on Linux (texlive 2013) following template to make Japanese language tutorial \documentclass{book} \input{glyphtounicode} \pdfgentounicode=1 \usepackage[utf8]{inputenc} \usepackage{CJKutf8} \usepackage[thaicjk,english]{babel} \begin{document} \begin{CJK}{UTF8}{min} 日本語 \end{CJK} \end{document} And ...


Only top voted, non community-wiki answers of a minimum length are eligible