Hot answers tagged

34

They are not errors, but warnings from the gensymb package, and if you look in the .log file I think you'll find Package gensymb Warning: Not defining \perthousand. Package gensymb Warning: Not defining \micro. So it has nothing to with either beamer or Kile. If you don't use those two symbols, don't worry about it. If you want to get rid of those ...


17

You can install the Package texlive-latex-extra. That should resolve the problem. This seems to be a bug in Ubuntu which does not pull in this packet when installing Kile.


17

The standard viewer for Kile is Okular. Under Settings >> configure Kile >> Tools >> Build >> viewPDF you need to add --unique to the options. This will make Okular only open a single window.


15

Languages including: Amharic, Arabic, Asturian, Azerbaijani, Belarusianm Bulgarian, Bengali, Breton, Catalan, Czech, Kashubian, Welsh, Danish, German, Greek, English, Spanish, Estonian, Persian, Faroese, French, Frisian, Irish, Scottish, Galician, Ancient Greek, Gujarati, Manx Gaelic, Hebrew, Hindi, Hiligaynon, Croatian, Upper Sorbia, Hungarian, Huastec, ...


15

Go to Settings --> Configure Kile, look under Editor --> Appearance, and check "Dynamic word wrap".


15

First things first. :) According to The Kile Handbook, chapter 13, "Kile's scripting feature allows for the execution of ECMAScript code. Scripts can be managed through the scripting panel in the sidebar." As a reference, both JavaScript and ActionScript are dialects of ECMAScript. Unfortunately, my answer won't TeX-related. But here we go. :) A quick ...


14

Simple answer: no. The align environment works very differently from equation: all of the material has to be read before any typesetting. (In that sense, it's similar to the beamer class frame environment, which people also ask similar questions about.) The material to be aligned has to be read before it is typeset to allow measurement, so it's not an option ...


13

sudo apt-get install texlive-latex3 solved my problem.The reason behind this problem was, latex mathematical style file mathtools.sty was missing. When i installed texlive-latex3 those missing files were added. This is lighter than the full texlive.


13

The undefined command is, in both cases, the the last token on the line after the error message, which is the documented behaviour here. Thus the issue is not with TeX or the amsmath package but with the parsing of the log file by Kile which appears to be in error given your description. Perhaps you should raise a bug report with the editor. Note that the ...


13

Kile doesn't delete it - it collapses everything between \begin and \end. Kicking on the triangle will expand it again. This works for every environment you open; for example: \begin{itemize} \item Some item \item another item \end{itemize} When you look at the rownumbers where the triangle thing is it skips row 76-78.


11

You need to edit the xml file that provides the markup definitions. Depending on the distro, the file is /usr/share/apps/katepart/syntax/latex.xml ~/.kde4/share/apps/katepart/syntax/latex.xml /opt/share/apps/katepart/syntax/latex.xml /usr/share/kde4/apps/katepart/syntax/latex.xml You then need to add your environment name to <!-- filter the ...


11

Kile (and many other editors for various languages) have something often referred to as 'code folding' or 'code collapse'. For LaTeX, Kile will offer to 'hide' entire environments from view to make it easier to get a handle on the overarching structure of your document. I don't use Kile, but I imagine it would offer the same blue area (and indicative ...


10

AFAIK, Ubuntu ships with TeXLive 2009. The iso image is TeXLive 2011. There were many changes during this time. Also, tlmgr allows you to update the packages from the online repository. I used Debian TeXLive for many years, until changed to the current TeXLive at the end of 2011. I just got tired of manually updating my distribution with the new versions ...


10

The syntax highlighting of Kile is governed by the general syntax highlighting scheme of katepart. The relevant file for LaTeX is called latex.xml, and can be found on Unix-like systems in /usr/share/apps/katepart/syntax/latex.xml or ~/.kde4/share/apps/katepart/syntax/latex.xml or /opt/share/apps/katepart/syntax/latex.xml or /usr/share/kde4/apps/katepart/...


10

As always, egreg has a great alternative solution for my crazy idea (kept at the bottom of this update, for historical reasons). :) There's a tool named texloganalyser (gotta love the spelling!) which might help us. It's shipped in TeX Live, so a quick texdoc texloganalyser (which redirects us to a perldoc texloganalyser) gives us all the flags we need: -...


9

The latest stable version of Kile (2.1.3) does not offer automatic updates. You can however update to the development version (Kile 3 beta 1) to get automatic updates and live preview. The dev version is in beta from quite some time and I use it in my production environment without issues. It is still a beta by the way, so there may be some rough edges. To ...


8

You have to open the file .blg that was produced. In that file there are all the indications about the compilation of the bibliography and, if any, the detailed description of the errors.


8

Just make sure that automatic checking is enabled: Tools > Spelling > Automatic Spell Checking


7

Actually, Kile directly supports both a %TODO comment and a %FIXME comment. There may be others, but none of them seem to be documented anymore. Enter one of these and you will notice the syntax highlighting. To see all such comments in your TeX file or project look under the Structure tab in the side panel. You should see a tree of Sections, Figures, etc. ...


7

I tried what was described here and it did not work. I found this link from the University of Illinois and their suggestions worked; I'm working in Fedora 17, in case it makes any difference. Here is what they suggest: Open some LaTeX file in Kile Open "Settings -> Configure Kile..." Click "Tools -> Build -> LaTeX" Select the "Modern" ...


7

\usepackage[utf8x]{inputenc} will not work any longer on Ubuntu/Kile. I had the same problem as I updated from 10.04 to 11.11. Now you simply have to use: \usepackage[utf8]{inputenc} Just remove the x from utf8x.


7

This can be achieved by creating a custom auto completion file. Such a file has the extension cwl and (on my systom) has to be saved under ~/.kde4/share/apps/kile/completion/tex. The # is a comment char in such a file. In such a file you write the commands with the text you want to appear in the arguments. # custom auto-completion file # \mycommand{date}{...


7

I was looking for the same thing, and could not find it. Below is a Kate script I've written to manage indentation for {} \begin and \end, handling escape characters. The script is submitted in the Master-branch in Kate's repository. I won't update any changes here. If it checks out, they plan to include it in the next release. If you want to try it out, ...


7

You can create projects in Kile. In Kile you can create and work with projects. A project is a group of LATEX, graphic, BibTEX or other files that contain all the information that is used to build your complete document. A typical project would be a document consisting of several chapters, written in different .tex files; all of them could be included in ...


7

It's just a warning, which tells you, you didn't set a backend to manage your bibliography, so biblatex uses the fallback biber. If you want to get rid of the message, you can choose manually between bibtex, bibtex8, bibtexu and biber. Just add backend=xxx in your biblatex line. Since you didn't modify the code (and hence your outcommented string says it), ...


6

In my Kile version (2.1.0) I do have a "Settings" Menu which has a "Configure Kile" entry. Then I can configure "Build" and "Tools" execute any program I like. In fact, I have it configured to use either latexmk or my Makefile. You can even add buttons to the quick menu.


6

I have sucessfully used the following way: Remove tex-live-2009 sudo apt-get remove texlive* (kile gets uninstalled too) Install tex-live-2012 (http://www.tug.org/texlive/acquire-netinstall.html) Create modified kile deb package without dependency to old tex using the following shell commands (and then install it) srcpkg=kile_2.1.0-1ubuntu1_amd64.deb ...


6

You probably have tabs in your input file. You can, however, fix it without changing your input file, with either fancyvrb or listings; both packages allow also for making the type size smaller, so that the code fits in the margin. \documentclass{article} \usepackage{fancyvrb} % for simple solution \usepackage{listings,color} % for colored solution % for ...


6

Yes, Edit --> Block Selection Mode, or Ctrl + Shift + B. This switches the mode on/off. When it is on, selection with mouse/keyboard is block selection.


6

I could reproduce the problem with Kile 4.14.9: Kile expects the root document to contain the \documentclass command. Since it is hidden inside preface.tex, Kile thinks, you want to call LaTeX on a file without \documentclass. There is an easy trick too convince Kile, that this is the right file, add \iffalse\documentclass{article}\fi at the top of the ...


Only top voted, non community-wiki answers of a minimum length are eligible