New answers tagged

1

You have to enable the chapter prefix using either option chapterprefix=true or headings=chapterprefix. Do not use package sectsty with a KOMA-Script class. Additionally I have replaced package fancyhdr by scrlayer-scrpage which is part of the KOMA-Script bundle. \documentclass[twoside, open=right, fontsize=13pt, DIV=calc,% to avoid a warning ...


0

As an answer to the general question there is the epigraph package that can be used with any class which enables an epigraph (silly quote) to be inserted wherever in the document. Here is an example of putting an epigraph before a chapter title: \documentclass{book} \usepackage{epigraph} \begin{document} \chapter*{Celestial navigation} \epigraphhead[70]{\...


0

As the comment by @campa indicated [o] is sufficient to move the preamble up. Also \dictum helps with the quote: \documentclass[chapterprefix=true]{scrbook} \usepackage{blindtext} \usepackage{scrhack} \begin{document} \setchapterpreamble[o]{ \dictum[Author]{quote}} \chapter{MyChapter} \Blinddocument \end{document} I have decided to not add the bar ...


1

Maybe you only have to define an new command which steps a counter and prints the counter: \documentclass[12pt,DIV=14,a4paper,parskip=true]{scrartcl} \newcounter{parnum} \newcommand*\parnum{% \par\leavevmode \refstepcounter{parnum}% \makebox[0pt][r]{\theparnum.\quad}% } \title{Title} \begin{document} \maketitle \section{Intro} Lorem ipsum dolor sit ...


1

Your first and third point describe the behaviour of headings with style=chapter. scrartcl does not provide this sectioning style. So it is the wrong class for your first and third point. You have to switch to either scrreprt or scrbook, because they provide the sectioning command \chapter. \chapter executes \clearpage or \cleardoublepage (depending on the ...


2

You can declare a new TOC style entry appendixchapter using the prefix: \documentclass{scrreprt}[2019/10/12]% needs version 3.27 or newer \newcommand\entrywithprefix[2]{#1~#2} \DeclareTOCStyleEntry[ level:=chapter, indent:=chapter, numwidth:=chapter, dynnumwidth, entrynumberformat=\entrywithprefix{\appendixname} ]{chapter}{appendixchapter} \...


1

I grabbed the values of \parsep, \itemsep, and \topsep with the option turned off. Then, I used enumitem to reset those values manually. \documentclass[11pt, a4paper]{scrartcl} \usepackage[utf8]{inputenc} \usepackage{enumitem} % on/off \setparsizes{0pt}{\smallskipamount plus 2pt}{0pt plus 1fil} % \begin{document} \begin{itemize}[parsep=4.5pt plus 2pt ...


1

ToC, LoF, LoT etc. are chapters by default. But the desired result is possible, using \AfterTOCHead{\thispagestyle{scrheadings}} Load package scrhack to control the LoL by package tocbasic too. Example (unfortunaly there was no MWE in the question): \documentclass{scrbook} \usepackage{blindtext}% only for dummy text \usepackage{listings} \usepackage{...


3

The reason is the order of the layers in the layer page style. You can list all layers of a layer page style using: \documentclass{scrreprt} \usepackage{scrlayer-scrpage} \newcommand*\commaatlist{} \newcommand*\listpagestylelayers[1]{ \ForEachLayerOfPageStyle{scrheadings}{% \commaatlist##1\gdef\commaatlist{, }} \let\commaatlist\relax } \begin{...


0

To solve the problem, I manually set the margin of the algorithm via \setlength{\algomargin}{1em}.


3

It would appear to be possible. \documentclass[11pt, twoside, openright, BCOR=1cm, headsepline]{scrreprt} \usepackage[paperheight=24cm, paperwidth=17cm, inner=2.3cm, outer=1.6cm, top=2.5cm, bottom=1.9cm,footskip=1cm]{geometry} \usepackage{tikz} %%%---header/footer \usepackage[manualmark]{scrlayer-scrpage} %%--"Chapter #" in lehead (only for numbered ...


1

The problem has been resolved by an update of the sansmathaccent package. It now no longer uses the filehook package.


0

I found the answer in the TeXbook source code (I hope this is not a violation of copyright, as the information is publicly available. If it is I will immediately remove my answer). I'm still dissecting how it works and learning TeX, so if anyone is willing to help explain that would be great. \documentclass{scrartcl} % from TeXbook source: % https://ctan....


0

Finally, I get two different solutions. The first one thanks to @esdd, and the other one by mail. \documentclass[fontsize=12pt]{scrbook} \usepackage{lipsum} \DeclareSectionCommand[ indent=20mm, afterindent=true, beforeskip=3ex, afterskip=0.5ex, ]{section} \usepackage{xpatch} \newlength\firstindent \makeatletter \xpatchcmd{\@afterheading} ...


Top 50 recent answers are included