54

I'm the developer of LaTeXTools. To set the master file, you need to add the following line at the very top (i.e. as the first line) of any included files: %!TEX root = yourmasterfile.tex The README has further details. Right now there is no support for setting a compilation directory other than the one where the master file resides. It's something a few ...


11

You're using the simple builder, which is fine for some situations, but its important to understand that the simple builder really is just that, a simple builder: it builds LaTeX documents using pdflatex and, if necessary, runs bibtex to generate a bibliography. That's it. Its actually intended as an example of how to write a builder than a fully featured ...


6

There are a few different ways this could be approached. The traditional builder that LaTeXTools uses launches latexmk, so you can solve the issue the same way you would for latexmk, i.e., add a .latexmkrc file to the directory containing your main tex document with the following contents: add_cus_dep('glo', 'gls', 0, 'makeglossaries'); add_cus_dep('acn', '...


6

UPDATE 2019-01-14 An equivalent patch has been applied in tabu 2.9 which has been submitted to ctan. The following seems to work (I also added the other patch): \documentclass{article} \usepackage{longtable} \usepackage{tabu} \usepackage{color} \usepackage{etoolbox} \makeatletter \patchcmd\tabu@startpboxmeasure {\aftergroup\tabu@endpboxmeasure} {\...


4

IMHO, the best way is to design your own script because you often need different packages and options. For my convenience, I designed one named edit.sh which calls for the editor if the file exists and create a new .tex file on-the-fly, according to my needs, if it doesn't. The advantage of shell script is adapting your file to your peculiar needs Here is ...


3

There's a LaTeXTools setting called keep_focus that you'll need to change to false to stop this from happening. You can access the settings by selecting Preferences > Package Settings > LaTeXTools > Settings – User.


3

I found a satisfying solution. The gist of the idea is to compile the tex-file with a temporary jobname like "temp" using latexMk. After completion, copy or rename the produced temp.pdf and temp.synctex.gz file to match the original document name. LatexTools enables this by customizing the build settings in LaTeXTools.sublime-settings (Preferences -> ...


3

Currently there's no option to do so, though I'm intending to add one in a future update. If you're happy editing the Python files, the relevant code is near the bottom of makePDF.py in your local package, but if you make a change there, it will be clobbered by the next release.


2

So, just to document what's already in the comments: The issue was that LaTeXTools was installed in a folder named something other than LaTeXTools. LaTeXTools assumes and hardcodes that the folder it is in is called LaTeXTools.


2

So, as you discovered, you need a TeX distribution and you've installed that, which is great. A couple of other points. LaTeXTools and LaTeXing don't play well together. Among other things, their keybindings overlap. Choose between the two of them and uninstall the one that you do not want to use. It's possible that you haven't installed latexmk if you ...


2

From the first comment above, you can add flags to the LaTeXTools user settings. Specifically, you need to configure the builder. To do this 1. Go to preferences, 2. Go packages settings 3. Choose LaTeXTools 4. Go to user settings 5. Add the options tuple to "builder_settings" "builder_settings" : { "options": ["--shell-escape"], .... } You can ...


2

Launch MiKTeX Console (as Administrator), select Packages. In the list of packages, select those you want to install, rightclick on anyt of them and select Install Packages, like in this screenshot:


1

I have solved my problem: it turns out that for whatever reason, LaTeXtools was put into my list of ignored packages in my Sublime user settings file. Deleting the entry corresponding to it restored the functionality I had before.


1

I'll leave an answer because there was a similar question just 3 days ago. The problem here is the classic "only TeX can parse TeX". But what does that even mean? Most actual programming languages have a somewhat fixed syntax. For example, in C (not that I know C, but...) a for statement will always have the same syntax and do the same thing, no matter what,...


1

I asked about that on the Github project of LaTeXTools, see here. So it is deliberate, and at the moment, there is no intended way to change that behavior (but maybe in the future). As a provisional solution, I now opened the file latex_own_command_completions.py in my LaTeXTools package folder, and changed the line s = c.args + "{}" to s = c.args ...


1

The full command line of any commands LaTeXTools uses is logged to the console (in the View menu, select Show Console). If you really need the environment variables, they can be gleaned from the information displayed by the LaTeXTools: Check System command.


1

You can't write arbitrary contexts for snippets, but only scopes. Therefore you can't create a snippet for that. However you can emulate the snippet behavior by creating a keybinding for the tab key, which is only trigger if the text before the caret is test. This keybinding should remove the word before it and insert the snippet. If you install the "Chain ...


1

You can't do this with the built-in scopes, but need a context. I will add the next prerelease (which is st3-4.0.0-alpha.3) via LaTeXTools#1167. If you have that prerelease you can just add the keybindings: { "keys": ["ctrl+enter"], "command": "insert_snippet", "args": {"contents": "\n$1 & =$2 \\\\\\\\$0"}, "context": [ { "...


1

That's a feature a of the LaTeXTools package (it should also work on windows). You can disable it by setting forward_sync to false in your settings. Just open Preferences > Package Settings > LaTeXTools > Settings - User, search for forward_sync, and set the value to false.


1

Support of the import package is now on the plan #990 and will most likely be added in the next minor release (3.13.0). Until then I made a branch (pkgimport_merge) on github, which merges the pull requests to support the import package. You can download that branch (ensure you have selected that branch) as zip, unpack it, and replace the LaTeXTools package ...


1

It's exactly what you said in the comment. If there's an error, the PDF won't be automatically opened. This is because errors almost always mean the PDF file wasn't changed, and often that it's completely blank. You can, however, use LaTeXTools view command C-l,v or C-l,j (which syncs to the corresponding line in the file) to open the PDF anyways.


1

The easiest way to deal with this is just to turn off Okular's automatic reloading, which can be done by going to Settings -> Configure Okular and unchecking Reload document on file change. With that setting unchecked, LaTeXTools will build your document and only update Okular once the compilation is complete.


1

You've somehow got your Build System set to Python instead of LaTeX. You can change this from the menu under Tools > Build System which can be set to either LaTeX or Automatic. A likely culprit for this is the Anaconda plugin for SublimeText which seems to like to automatically change your builder to a Python builder. You can disable that behaviour through ...


1

Update: LaTeXTools now supports aux_directory and output_directory via settings or using comments such as %!TEX output_directory = out_dir. There are a few caveats to this support which are included in the documentation. LaTeXTools doesn't support -aux-directory or -output-directory (yet). However, if you can stomach having a couple of symbolic links in the ...


1

If you are not familiar with builder engine setting of LaTeXTool, please read the section of Build engine settings in ReadMe file of LaTeXTool The default LaTeXTools builder is "traditional" that uses latemk (Texify for MiKTeX) to trigger the compile system, which is equal to run this command in your terminal latexmk foo.tex foo is your tex file name (the ...


1

So lay out what's in the chat, the path to the pandoc executable, i.e., /usr/local/bin must be added to the path setting of your builder as well as /usr/texbin (to ensure pdflatex and friends can be found). So your path setting should be: "path": "/usr/texbin:/usr/local/bin:$PATH"


1

I reinstalled miktex and then got the COULD NOT CPOMPILE message from Sublime Text 3. After reading the hint to use the reconfigure LaTeXTools... functionality I used it and now it works.


Only top voted, non community-wiki answers of a minimum length are eligible